summaryrefslogtreecommitdiff
path: root/sec-keys/openpgp-keys-openssl/openpgp-keys-openssl-20220316-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-02 03:08:46 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-02 03:08:46 +0000
commit29badda007a3bcd85bb351f602790eb3b8922448 (patch)
treec61f9e929e2bf3796366d57707eda3245586ce7a /sec-keys/openpgp-keys-openssl/openpgp-keys-openssl-20220316-r1.ebuild
parentc37d894982b59595356319a2b4655fed277097ae (diff)
gentoo auto-resync : 02:11:2022 - 03:08:46
Diffstat (limited to 'sec-keys/openpgp-keys-openssl/openpgp-keys-openssl-20220316-r1.ebuild')
-rw-r--r--sec-keys/openpgp-keys-openssl/openpgp-keys-openssl-20220316-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sec-keys/openpgp-keys-openssl/openpgp-keys-openssl-20220316-r1.ebuild b/sec-keys/openpgp-keys-openssl/openpgp-keys-openssl-20220316-r1.ebuild
new file mode 100644
index 000000000000..2a62c757aa9f
--- /dev/null
+++ b/sec-keys/openpgp-keys-openssl/openpgp-keys-openssl-20220316-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="OpenPGP keys used by OpenSSL"
+HOMEPAGE="https://www.openssl.net/"
+# See https://www.openssl.org/source/ and https://www.openssl.org/community/omc.html
+# Mirrored from https://keyserver.ubuntu.com/pks/lookup?op=get&search=0x8657ABB260F056B1E5190839D9C4D26D0E604491 etc (unstable results)
+SRC_URI="
+ https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/openssl-${PV}-8657ABB260F056B1E5190839D9C4D26D0E604491.asc
+ https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/openssl-${PV}-7953AC1FBC3DC8B3B292393ED5E9E43F7DF9EE8C.asc
+"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+S=${WORKDIR}
+
+src_install() {
+ local files=( ${A} )
+ insinto /usr/share/openpgp-keys
+ newins - openssl.org.asc < <(cat "${files[@]/#/${DISTDIR}/}" || die)
+}