summaryrefslogtreecommitdiff
path: root/sci-visualization
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-01 17:20:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-01 17:20:35 +0100
commita88eb1d9b7042912d196e255eeb20e0c77f6cf47 (patch)
tree291cc788e33b3de8bf1b5e3f1fdddf315f2f5ee7 /sci-visualization
parentc3d14fe9accdf0b091e42f26a66ed7626ba8c24b (diff)
gentoo auto-resync : 01:05:2023 - 17:20:35
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/Manifest.gzbin4857 -> 4861 bytes
-rw-r--r--sci-visualization/g3data/Manifest4
-rw-r--r--sci-visualization/g3data/g3data-1.5.4.ebuild12
3 files changed, 12 insertions, 4 deletions
diff --git a/sci-visualization/Manifest.gz b/sci-visualization/Manifest.gz
index a1c1a4b8db20..3f1bd1488001 100644
--- a/sci-visualization/Manifest.gz
+++ b/sci-visualization/Manifest.gz
Binary files differ
diff --git a/sci-visualization/g3data/Manifest b/sci-visualization/g3data/Manifest
index b32ed646861e..af105ffddc99 100644
--- a/sci-visualization/g3data/Manifest
+++ b/sci-visualization/g3data/Manifest
@@ -1,4 +1,4 @@
AUX g3data-1.5.4-desktop-QA.patch 234 BLAKE2B fea81baad83edaf330f23b9f4e5cbf1f3ee8e43ad02aa9fa87cb9f41171d658ccf8186ba882944e1849e9d2ef937c148a4d6c6a82639244a28ea00e4dcf7b26b SHA512 f938c8659de9ff868156823c8112ce849e9acfa3c1a253d77a94a366875d275d4632b1b810d3ae15dbb9d83f1dfdae18aa9aa6aae01456107596a6d8ae6e3c1b
-DIST g3data-1.5.4.tar.gz 127973 BLAKE2B 19e6e6aaa7b33a4c4aa061c76aa2465bdb305ac9023e861dc1db42821cdb83c9b8221f6a5552f37731c3fe21fedc4174d46a7d2c01732916534539d382e6fac2 SHA512 b4651eb6ba87ddb745c46520ccf2d7146d179e69a614d7c6c247b82eaf188b30e955d60e7df59419f63a304a5c5215829d3bea3cc233d2729ff599c523d852e2
-EBUILD g3data-1.5.4.ebuild 468 BLAKE2B 1bffc954f10bc7532a09eb27174524aa671381e7c346e984786feaf6c28bb59585e6f9cfb296c89348ebdb89418772b9982a7455b5171f0cc19c695237954c4b SHA512 dfc505d0f0ad7bb553e99dbfee9c60c327820937da7ac4602a63b2c4b525247655496bf66af0e79c5cb07be3e31bb1055414c93f9d324a31a186a5ee329ead2d
+DIST g3data-1.5.4.gh.tar.gz 40296 BLAKE2B ac821f80323ba9d9fe59274bf1b9746ea53273a9b46b2a1f8366be28c5b58c6f098322293a4971ce80d6261de8e9719cea1f527b0c57a4bc3505be966ff14b23 SHA512 965e3d1f68865eea20e38bf428d32974c26407e3ccb736d2049141472d4ddf5bbe3e82fcea00195febb1de021396105217cfa8098b6724b9cedfe9dbbb3c5f76
+EBUILD g3data-1.5.4.ebuild 557 BLAKE2B 08c20f1b8142ff13fdacbde3328e7db69421d8a2ae56baf58b368ab732c9b7281593d35e157bcdf05c088df235ef1ee9020ca838c8775f94b1c4d6908f05e067 SHA512 b359e572707cfe7e9de9d4e3ec4664f3b32235ea86e3abb9d5430032c47866a37a6d196c31add7498603579a7dac59250f1a7b3c732f1f49f38905695fcf72c4
MISC metadata.xml 557 BLAKE2B 420bd535a9a6b99b2dd2b0a2e859cab98467457790c5f97cb1a27f442670953613b5cf1fd10dda1968cbde6d53438cad7269a200d83ef4ed089d87c3acf96d59 SHA512 e3f42a68891bcee652ec76146468cdf7bda983f9e3b14cf35ea46d502408e1a03225ef0e151edf306c97a3d0e144429b9f02b8f8dc87434c29bd5081f5caae6d
diff --git a/sci-visualization/g3data/g3data-1.5.4.ebuild b/sci-visualization/g3data/g3data-1.5.4.ebuild
index aff34e279401..9c6b9976382d 100644
--- a/sci-visualization/g3data/g3data-1.5.4.ebuild
+++ b/sci-visualization/g3data/g3data-1.5.4.ebuild
@@ -1,11 +1,13 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit autotools
+
DESCRIPTION="Tool for extracting data from graphs"
HOMEPAGE="https://github.com/pn2200/g3data"
-SRC_URI="https://github.com/downloads/pn2200/g3data/${P}.tar.gz"
+SRC_URI="https://github.com/pn2200/g3data/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -16,3 +18,9 @@ DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
PATCHES=( "${FILESDIR}"/${P}-desktop-QA.patch )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}