summaryrefslogtreecommitdiff
path: root/sci-visualization/xd3d/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-visualization/xd3d/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-visualization/xd3d/files')
-rw-r--r--sci-visualization/xd3d/files/xd3d-8.3.1-cflags.patch41
-rw-r--r--sci-visualization/xd3d/files/xd3d-8.3.1-gentoo.diff86
-rw-r--r--sci-visualization/xd3d/files/xd3d-8.3.1-parallel.patch61
-rw-r--r--sci-visualization/xd3d/files/xd3d-8.3.1-rotated.patch10
4 files changed, 198 insertions, 0 deletions
diff --git a/sci-visualization/xd3d/files/xd3d-8.3.1-cflags.patch b/sci-visualization/xd3d/files/xd3d-8.3.1-cflags.patch
new file mode 100644
index 000000000000..b62129b41bf4
--- /dev/null
+++ b/sci-visualization/xd3d/files/xd3d-8.3.1-cflags.patch
@@ -0,0 +1,41 @@
+ src/various/Makefile | 16 ++++++++--------
+ 1 files changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/src/various/Makefile b/src/various/Makefile
+index 7188b2a..80f47ec 100644
+--- a/src/various/Makefile
++++ b/src/various/Makefile
+@@ -3,25 +3,25 @@ include ../../RULES
+ all :; make clair clairc3d create_c3d obscur obscurc3d tradavoir translation txt2avoir
+
+ clair : clair.f $(LIBRAIRIE) ;\
+-$(LINK) $(BINDIR)/clair $(INCF) clair.f $(LIBRAIRIE) $(LINKOPTX)
++$(LINK) $(BINDIR)/clair $(FCFLAGS) $(INCF) clair.f $(LIBRAIRIE) $(LINKOPTX)
+
+ clairc3d : clairc3d.f $(LIBRAIRIE) ;\
+-$(LINK) $(BINDIR)/clairc3d $(INCF) clairc3d.f $(LIBRAIRIE) $(LINKOPTX)
++$(LINK) $(BINDIR)/clairc3d $(FCFLAGS) $(INCF) clairc3d.f $(LIBRAIRIE) $(LINKOPTX)
+
+ create_c3d : create_c3d.f $(LIBRAIRIE) ;\
+-$(LINK) $(BINDIR)/create_c3d $(INCF) create_c3d.f $(LIBRAIRIE) $(LINKOPTX)
++$(LINK) $(BINDIR)/create_c3d $(FCFLAGS) $(INCF) create_c3d.f $(LIBRAIRIE) $(LINKOPTX)
+
+ obscur : obscur.f $(LIBRAIRIE) ;\
+-$(LINK) $(BINDIR)/obscur $(INCF) obscur.f $(LIBRAIRIE) $(LINKOPTX)
++$(LINK) $(BINDIR)/obscur $(FCFLAGS) $(INCF) obscur.f $(LIBRAIRIE) $(LINKOPTX)
+
+ obscurc3d : obscurc3d.f $(LIBRAIRIE) ;\
+-$(LINK) $(BINDIR)/obscurc3d $(INCF) obscurc3d.f $(LIBRAIRIE) $(LINKOPTX)
++$(LINK) $(BINDIR)/obscurc3d $(FCFLAGS) $(INCF) obscurc3d.f $(LIBRAIRIE) $(LINKOPTX)
+
+ tradavoir : tradavoir.f $(LIBRAIRIE) ;\
+-$(LINK) $(BINDIR)/tradavoir $(INCF) tradavoir.f $(LIBRAIRIE) $(LINKOPTX)
++$(LINK) $(BINDIR)/tradavoir $(FCFLAGS) $(INCF) tradavoir.f $(LIBRAIRIE) $(LINKOPTX)
+
+ translation : translation.f $(LIBRAIRIE) ;\
+-$(LINK) $(BINDIR)/translation $(INCF) translation.f $(LIBRAIRIE) $(LINKOPTX)
++$(LINK) $(BINDIR)/translation $(FCFLAGS) $(INCF) translation.f $(LIBRAIRIE) $(LINKOPTX)
+
+ txt2avoir : txt2avoir.f $(LIBRAIRIE) ;\
+-$(LINK) $(BINDIR)/txt2avoir $(INCF) txt2avoir.f $(LIBRAIRIE) $(LINKOPTX)
++$(LINK) $(BINDIR)/txt2avoir $(FCFLAGS) $(INCF) txt2avoir.f $(LIBRAIRIE) $(LINKOPTX)
diff --git a/sci-visualization/xd3d/files/xd3d-8.3.1-gentoo.diff b/sci-visualization/xd3d/files/xd3d-8.3.1-gentoo.diff
new file mode 100644
index 000000000000..271fd0b8bd58
--- /dev/null
+++ b/sci-visualization/xd3d/files/xd3d-8.3.1-gentoo.diff
@@ -0,0 +1,86 @@
+diff -Naur RULES.gentoo RULES.gentoo
+--- /dev/null 1969-12-31 19:00:00.000000000 -0500
++++ ./RULES.gentoo 2008-01-21 06:41:41.000000000 -0500
+@@ -0,0 +1,82 @@
++#--------------------------------------------------------
++# Configuration file for the Makefiles of xd3d |
++# François Jouve 2005 (Francois.Jouve@Polytechnique.fr) |
++#--------------------------------------------------------
++
++#
++# Modifiable parameters
++#
++
++#
++# Root directory of the distribution
++#
++#XD3D_DIR = $(HOME)/xd3d-8.1.0
++XD3D_DIR = Please_Configure
++
++#
++# Install directory
++#
++#INSTALL_DIR = /usr/local/bin
++INSTALL_DIR = ##D##/usr/bin
++
++#
++# Location of the X11 lib (libX11.a)
++#
++#LIBX11 = /usr/X11R6/lib
++LIBX11 = /usr/##lib##/
++
++#
++# Language parameter
++#
++#LANGUAGE = FRANCAIS
++#LANGUAGE = ENGLISH
++LANGUAGE = ENGLISH
++
++#
++# Max memory for xd3d (MBytes)
++#
++#MEMORY_XD3D = 64
++MEMORY_XD3D = 64
++
++#
++# Fortran compiler
++#
++COMPILF = $(FC)
++
++#
++# C compiler
++#
++COMPILC = $(CC)
++RANLIB = ranlib
++AR = ar r
++STRIP = echo $@
++
++#
++# Options for the Fortran compiler
++#
++OPTF = $(FFLAGS)
++#
++# Options for the C compiler
++#
++OPTC = $(CFLAGS)
++
++#-----------------------------------------------
++# You should not need to change anything below !
++#-----------------------------------------------
++
++SRCDIR = $(XD3D_DIR)/src
++BINDIR = $(XD3D_DIR)/bin
++LIBDIR = $(XD3D_DIR)/lib
++SUFF =
++INCF = -I$(XD3D_DIR)/src/include
++INCC = -I$(LIBX11)/../include
++
++LINK = $(COMPILF) $(LDFLAGS) -o
++LINKOPT = -lc -lm
++LINKOPTX = -L$(LIBX11) -lX11 -lXpm -lc -lm
++LIBRAIRIE = $(LIBDIR)/question_lib.a
++MYXLIB = $(LIBDIR)/my_Xlib.a
++INTERP = $(LIBDIR)/interp.a
++
++.f.o: ; $(COMPILF) $(INCF) $(OPTF) -c $*.f
++.c.o: ; $(COMPILC) $(INCC) $(OPTC) -D$(LANGUAGE) -c $*.c
diff --git a/sci-visualization/xd3d/files/xd3d-8.3.1-parallel.patch b/sci-visualization/xd3d/files/xd3d-8.3.1-parallel.patch
new file mode 100644
index 000000000000..3143ff2420c4
--- /dev/null
+++ b/sci-visualization/xd3d/files/xd3d-8.3.1-parallel.patch
@@ -0,0 +1,61 @@
+--- a/src/various/Makefile 2009-12-04 18:16:57.000000000 +0000
++++ b/src/various/Makefile 2009-12-04 18:17:13.000000000 +0000
+@@ -1,6 +1,6 @@
+ include ../../RULES
+
+-all :; make clair clairc3d create_c3d obscur obscurc3d tradavoir translation txt2avoir
++all : clair clairc3d create_c3d obscur obscurc3d tradavoir translation txt2avoir
+
+ clair : clair.f $(LIBRAIRIE) ;\
+ $(LINK) $(BINDIR)/clair $(INCF) clair.f $(LIBRAIRIE) $(LINKOPTX)
+--- a/src/X/Makefile 2009-12-04 18:16:06.000000000 +0000
++++ b/src/X/Makefile 2009-12-04 18:16:36.000000000 +0000
+@@ -118,7 +118,7 @@
+ lib : $(LIBMARC)
+ $(LIBMARC) : $(OBJETS) $(OBJETSMARC) ; $(AR) $@ $(OBJETS) $(OBJETSMARC) ; $(RANLIB) $@
+
+-all :; make ; make lib
++all : lib
+
+ clean : ; /bin/rm -f $(OBJETS) $(LIB) $(LIBMARC)
+
+--- a/Makefile 2009-12-04 18:12:08.000000000 +0000
++++ b/Makefile 2009-12-04 19:06:37.000000000 +0000
+@@ -13,22 +13,24 @@
+ $(BINDIR)/xd3d$(SUFF) \
+ $(BINDIR)/xgraphic$(SUFF)
+
+-all :; make libs ; make utils ; make xgraphic ; make xd3d
++all : libs utils xgraphic xd3d
+
+ install :; /bin/cp -pidvu $(EXE) ./infps $(INSTALL_DIR)
+
+ libs :; \
+-cd $(SRCDIR)/qlib ; echo "---- Building utility lib ----" ; make ;\
+-cd $(SRCDIR)/interp ; echo "---- Building parsing lib ----" ; make ;\
+-cd $(SRCDIR)/X ; echo "---- Building X interface lib ----" ; make
+-
+-xd3d :; cd $(SRCDIR)/d3d ; echo "---- Building xd3d ----" ; make
+-
+-xgraphic :; cd $(SRCDIR)/graphic ; echo "---- Building xgraphic ----" ; make
+-
+-utils :; \
+-echo " ---- Building various utils ----" ;\
+-cd $(SRCDIR)/trad_nopo ; make ;\
+-cd $(SRCDIR)/various ; make
++cd $(SRCDIR)/qlib ; echo "---- Building utility lib ----" ; $(MAKE) ;\
++cd $(SRCDIR)/interp ; echo "---- Building parsing lib ----" ;$(MAKE) ;\
++cd $(SRCDIR)/X ; echo "---- Building X interface lib ----" ; $(MAKE)
++
++xd3d : libs
++ cd $(SRCDIR)/d3d ; echo "---- Building xd3d ----" ; $(MAKE)
++
++xgraphic : libs
++ cd $(SRCDIR)/graphic ; echo "---- Building xgraphic ----" ; $(MAKE)
++
++utils : libs
++ echo " ---- Building various utils ----" ;\
++ cd $(SRCDIR)/trad_nopo ; $(MAKE) ;\
++ cd $(SRCDIR)/various ; $(MAKE)
+
+ clean :; /bin/rm -f $(SRCDIR)/*/*.o $(LIBRAIRIE) $(MYXLIB) $(INTERP) $(EXE)
diff --git a/sci-visualization/xd3d/files/xd3d-8.3.1-rotated.patch b/sci-visualization/xd3d/files/xd3d-8.3.1-rotated.patch
new file mode 100644
index 000000000000..2d840c0a1342
--- /dev/null
+++ b/sci-visualization/xd3d/files/xd3d-8.3.1-rotated.patch
@@ -0,0 +1,10 @@
+--- a/src/X/rotated.c 2009-12-04 18:09:55.000000000 +0000
++++ b/src/X/rotated.c 2009-12-04 18:10:37.000000000 +0000
+@@ -29,6 +29,7 @@
+ #include <stdio.h>
+ #include <math.h>
+ #include <string.h>
++#include <stdlib.h>
+ #include "rotated.h"
+
+