summaryrefslogtreecommitdiff
path: root/sci-visualization/labplot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-visualization/labplot
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-visualization/labplot')
-rw-r--r--sci-visualization/labplot/Manifest6
-rw-r--r--sci-visualization/labplot/labplot-2.4.0.ebuild73
-rw-r--r--sci-visualization/labplot/labplot-9999.ebuild72
-rw-r--r--sci-visualization/labplot/metadata.xml20
4 files changed, 171 insertions, 0 deletions
diff --git a/sci-visualization/labplot/Manifest b/sci-visualization/labplot/Manifest
new file mode 100644
index 000000000000..0cab8df49618
--- /dev/null
+++ b/sci-visualization/labplot/Manifest
@@ -0,0 +1,6 @@
+DIST labplot-2.4.0-kf5.tar.xz 6038072 SHA256 86198247ff0d274c85607cdb07a0c4ef19149e4f4bf6c9d2e6e8249134e26bb2 SHA512 5d29dd7d63d484359e73c8d82d8dbc25a069e1f33829cf75c2a2009ebae2027353ecf578b51806b5f35ae17ec472f5cbfdb4caed2637dc1ecc9229d33033d21b WHIRLPOOL 8d5af85ae52bbe1526d00888c1a18922a0f27c3dbf4ff992736e6672008ca61f54f8df93a1c0185bf4fcdcebe4543e58aa7260eafaf40ba8abf87b39ab84bad4
+EBUILD labplot-2.4.0.ebuild 1819 SHA256 87317c762c8cdf68aeec8b7ce348e767b4e597b24ed2d6b071514927c826c9e7 SHA512 444a6ce0179cd5f5528714d3d75aa85e868b906bfaf02f67a20b921703f56b00d861466c349a8171d7eab01980214ce3b93926431d5c49640f996c40e407f2e8 WHIRLPOOL 84a2cdbb77fcdf0d7db3a18dea1e8aaeb161cd07e0239f736f7f629e3586f9fb6a11a3ac6b8889e43c977054a39abf3a32cb70794e5c3a957441a56b845dd6f2
+EBUILD labplot-9999.ebuild 1811 SHA256 7e74aec0647a86d1363976e61b21d8f85524ac08b7f062cf98a5a30a624c7f56 SHA512 0300f6644fd59d3d1bfb830876a41341e90eaedfcc9aed49dcfe9ece5db02f50e243130b9b6e438ceae7e9bcbbd4642450b9d484be9dbaffb45b6a4f99d2145c WHIRLPOOL 7b22ec33aba9a1bf129f31ae62c50ded1fb5326e67866205fb912bc691cfbe4e8043be447ec49a766c478ca3c0e22069da73a6f3bf14774e9009a902eca784a5
+MISC ChangeLog 3385 SHA256 08bfbddb69d635f79a59502e04d4e200780e61559294939ae6bfd726888405a3 SHA512 3f0942caf95dce64a6d5bc90c5f7a8e317294b0e1d94af536b3565d467410990dfa879c567ccbec76ec7427443063bf4f2b0bd517c89b6a3b1d7252198df2e8f WHIRLPOOL be21b3fdc25f91a1e227e6d2ae106acb0a9ef662843433dbdc3d38269b447ae876b5905a2272648dca9076eea6ff7a0515260e226ee3d076c3ede9bb6c9a2205
+MISC ChangeLog-2015 460 SHA256 48406615f5b686a352393f83938d0f83c6f436ad40a91eee926ddd34097459a6 SHA512 82fb79e09c95a3b7a2e1e37faa6b78f9940fa9c38fe9b076965bc6fe042fe70456e934db09cdd77cfca52cf7097e49253c205f42c2c7ccbb48d90e4092169656 WHIRLPOOL acaea33e68ecf3f37425c8f8755f135d971283f46e4324459dc699b79eb2e054f7c375a0036186e995c5150ddba8aa09d2570d5d452927afdae0f7732eca7192
+MISC metadata.xml 708 SHA256 6687aa3e641ab7c71ca3f08f817ca886c13bd02136beb4f522937f4e1d1a82b4 SHA512 ff837fb6ea47422781c06001c96a0f047a8ca1ca875267c8f26f2369b57b87e86d9816a423ae17fc69c88e9f6cf730c87194267f5f645c83df710f60a99d07eb WHIRLPOOL cb26597c11ea4edcf9964cdc08b7497b827d0fa98e24cc8d14d27229acf1201b744b6fcf0a2e98334bffcda7f16809a776fa9fe92f3775dfb879c714cb7fcd45
diff --git a/sci-visualization/labplot/labplot-2.4.0.ebuild b/sci-visualization/labplot/labplot-2.4.0.ebuild
new file mode 100644
index 000000000000..41c5faefd1e7
--- /dev/null
+++ b/sci-visualization/labplot/labplot-2.4.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_BRANCH="frameworks"
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Scientific data analysis and visualisation based on KDE Frameworks"
+HOMEPAGE="https://www.kde.org/applications/education/labplot/"
+[[ ${KDE_BUILD_TYPE} != live ]] && SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}-kf5.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="cantor fftw fits hdf5 netcdf"
+
+[[ ${KDE_BUILD_TYPE} != live ]] && S="${WORKDIR}/${P}-kf5"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ >=sci-libs/gsl-1.15:=
+ cantor? ( $(add_kdeapps_dep cantor) )
+ fftw? ( sci-libs/fftw:3.0= )
+ fits? ( sci-libs/cfitsio:= )
+ hdf5? ( sci-libs/hdf5:= )
+ netcdf? ( sci-libs/netcdf:= )
+"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/gettext
+ x11-misc/shared-mime-info
+"
+RDEPEND="${COMMON_DEPEND}
+ !sci-visualization/labplot:4
+"
+
+src_prepare() {
+ kde5_src_prepare
+
+ if ! use handbook && [[ ${KDE_BUILD_TYPE} != live ]]; then
+ cmake_comment_add_subdirectory doc-translations
+ fi
+
+ punt_bogus_dep KF5 NewStuff
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CANTOR=$(usex cantor)
+ -DENABLE_FFTW=$(usex fftw)
+ -DENABLE_FITS=$(usex fits)
+ -DENABLE_HDF5=$(usex hdf5)
+ -DENABLE_NETCDF=$(usex netcdf)
+ )
+
+ kde5_src_configure
+}
diff --git a/sci-visualization/labplot/labplot-9999.ebuild b/sci-visualization/labplot/labplot-9999.ebuild
new file mode 100644
index 000000000000..6eebaf152481
--- /dev/null
+++ b/sci-visualization/labplot/labplot-9999.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_BRANCH="frameworks"
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Scientific data analysis and visualisation based on KDE Frameworks"
+HOMEPAGE="https://www.kde.org/applications/education/labplot/"
+[[ ${KDE_BUILD_TYPE} != live ]] && SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}-kf5.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS=""
+IUSE="cantor fftw fits hdf5 netcdf"
+
+[[ ${KDE_BUILD_TYPE} != live ]] && S="${WORKDIR}/${P}-kf5"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ >=sci-libs/gsl-1.15:=
+ cantor? ( $(add_kdeapps_dep cantor) )
+ fftw? ( sci-libs/fftw:3.0= )
+ fits? ( sci-libs/cfitsio:= )
+ hdf5? ( sci-libs/hdf5:= )
+ netcdf? ( sci-libs/netcdf:= )
+"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/gettext
+ x11-misc/shared-mime-info
+"
+RDEPEND="${COMMON_DEPEND}
+ !sci-visualization/labplot:4
+"
+
+src_prepare() {
+ kde5_src_prepare
+
+ if ! use handbook && [[ ${KDE_BUILD_TYPE} != live ]]; then
+ cmake_comment_add_subdirectory doc-translations
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CANTOR=$(usex cantor)
+ -DENABLE_FFTW=$(usex fftw)
+ -DENABLE_FITS=$(usex fits)
+ -DENABLE_HDF5=$(usex hdf5)
+ -DENABLE_NETCDF=$(usex netcdf)
+ )
+
+ kde5_src_configure
+}
diff --git a/sci-visualization/labplot/metadata.xml b/sci-visualization/labplot/metadata.xml
new file mode 100644
index 000000000000..9e450bf9332f
--- /dev/null
+++ b/sci-visualization/labplot/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dilfridge@gentoo.org</email>
+ <name>Andreas K. Huettel</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <use>
+ <flag name="cantor">Enable support for different open-source computer algebra systems via <pkg>kde-apps/cantor</pkg></flag>
+ <flag name="fits">Enable support for NASA's <pkg>sci-libs/cfitsio</pkg> library</flag>
+ </use>
+</pkgmetadata>