summaryrefslogtreecommitdiff
path: root/sci-visualization/kst/kst-2.0.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-16 05:02:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-16 05:02:38 +0100
commitf1bc537f089cc8477a9a18db597cb349e1b00e91 (patch)
treec48eb730c43e5f35729fabbe5cb4bfbe4a1bc794 /sci-visualization/kst/kst-2.0.8.ebuild
parentcb3e8c6af7661fbcafdcacc7e0ecdfb610d098fa (diff)
gentoo resync : 16.06.2018
Diffstat (limited to 'sci-visualization/kst/kst-2.0.8.ebuild')
-rw-r--r--sci-visualization/kst/kst-2.0.8.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/sci-visualization/kst/kst-2.0.8.ebuild b/sci-visualization/kst/kst-2.0.8.ebuild
index 408da47f2984..1ea474c0cee9 100644
--- a/sci-visualization/kst/kst-2.0.8.ebuild
+++ b/sci-visualization/kst/kst-2.0.8.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit cmake-utils multilib
+inherit cmake-utils
MY_P=Kst-${PV}
@@ -40,7 +40,11 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
DOCS=( AUTHORS README.kstScript )
-PATCHES=( "${FILESDIR}/${P}-includes.patch" )
+
+PATCHES=(
+ "${FILESDIR}/${P}-includes.patch"
+ "${FILESDIR}/${P}-qt-5.11b3.patch"
+)
src_configure() {
local mycmakeargs=(
@@ -50,7 +54,7 @@ src_configure() {
-Dkst_release=$(usex debug OFF ON)
-Dkst_rpath=OFF
-Dkst_svnversion=OFF
- $(cmake-utils_use test kst_test)
+ -Dkst_test=$(usex test)
)
cmake-utils_src_configure