summaryrefslogtreecommitdiff
path: root/sci-visualization/grace/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-visualization/grace/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-visualization/grace/files')
-rw-r--r--sci-visualization/grace/files/grace-5.1.21-fortran.patch26
-rw-r--r--sci-visualization/grace/files/grace-5.1.21-netcdf.patch11
-rw-r--r--sci-visualization/grace/files/grace-5.1.22-dlmodule.patch12
-rw-r--r--sci-visualization/grace/files/grace-5.1.22-ldflags.patch41
-rw-r--r--sci-visualization/grace/files/grace-5.1.22-mkstemp.patch55
-rw-r--r--sci-visualization/grace/files/grace.desktop8
6 files changed, 153 insertions, 0 deletions
diff --git a/sci-visualization/grace/files/grace-5.1.21-fortran.patch b/sci-visualization/grace/files/grace-5.1.21-fortran.patch
new file mode 100644
index 000000000000..cdec666107ee
--- /dev/null
+++ b/sci-visualization/grace/files/grace-5.1.21-fortran.patch
@@ -0,0 +1,26 @@
+--- a/grace_np/gracef_np.c 2008-03-03 11:45:12.000000000 +0000
++++ b/grace_np/gracef_np.c 2008-03-03 12:05:37.000000000 +0000
+@@ -1,5 +1,11 @@
+ #include <config.h>
+
++#ifdef NEED_F77_UNDERSCORE
++# define F77_FNAME(fname) fname ## _
++#else
++# define F77_FNAME(fname) fname
++#endif
++
+ #if defined(WITH_F77_WRAPPER)
+
+ #include <stdio.h>
+@@ -8,11 +14,6 @@
+
+ #include "grace_np.h"
+
+-#ifdef NEED_F77_UNDERSCORE
+-# define F77_FNAME(fname) fname ## _
+-#else
+-# define F77_FNAME(fname) fname
+-#endif
+
+ typedef void (*GraceFortranFunctionType) (const char *str, int len);
+ static GraceFortranFunctionType fortran_error = (GraceFortranFunctionType) 0;
diff --git a/sci-visualization/grace/files/grace-5.1.21-netcdf.patch b/sci-visualization/grace/files/grace-5.1.21-netcdf.patch
new file mode 100644
index 000000000000..d843cb4b284c
--- /dev/null
+++ b/sci-visualization/grace/files/grace-5.1.21-netcdf.patch
@@ -0,0 +1,11 @@
+--- a/configure 2007-02-16 22:44:49.000000000 +0000
++++ b/configure 2007-09-28 23:03:29.000000000 +0100
+@@ -15181,7 +15181,7 @@
+ int main(void) {
+ char *vlib;
+ vlib = nc_inq_libvers();
+- if (strcmp(vlib, "3.0") < 0) {
++ if (((vlib[0] == '"') && (strcmp(vlib, "\"3.0") < 0)) || ((vlib[0] != '"') && (strcmp(vlib, "3.0") < 0))){
+ exit(1);
+ }
+ exit(0);
diff --git a/sci-visualization/grace/files/grace-5.1.22-dlmodule.patch b/sci-visualization/grace/files/grace-5.1.22-dlmodule.patch
new file mode 100644
index 000000000000..02fa06a8a9f9
--- /dev/null
+++ b/sci-visualization/grace/files/grace-5.1.22-dlmodule.patch
@@ -0,0 +1,12 @@
+--- a/src/dlmodule.c 2005-11-13 07:45:16.000000000 +0900
++++ b/src/dlmodule.c 2008-06-16 15:28:33.000000000 +0900
+@@ -89,6 +89,9 @@
+ return RETURN_FAILURE;
+ }
+
++ /* clear error indicator */
++ dlerror();
++
+ newkey.data = dlsym(handle, dl_function);
+ if (!newkey.data && (error = dlerror()) != NULL) {
+ errmsg(error);
diff --git a/sci-visualization/grace/files/grace-5.1.22-ldflags.patch b/sci-visualization/grace/files/grace-5.1.22-ldflags.patch
new file mode 100644
index 000000000000..2a65cd233361
--- /dev/null
+++ b/sci-visualization/grace/files/grace-5.1.22-ldflags.patch
@@ -0,0 +1,41 @@
+Respect LDFLAGS
+
+http://bugs.gentoo.org/show_bug.cgi?id=336984
+
+--- grace-5.1.22/src/Makefile
++++ grace-5.1.22/src/Makefile
+@@ -37,10 +37,10 @@
+ include Make.dep
+
+ xmgrace$(EXE) : $(GROBJS) $(PARS_C) $(GUIOBJS) $(CEPHES_LIB)
+- $(CC) $(CFLAGS) $(GROBJS) $(GUIOBJS) -o $@ $(LDFLAGS) $(LIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) $(GROBJS) $(GUIOBJS) -o $@ $(LIBS)
+
+ grace$(EXE) : $(GROBJS) $(PARS_C) $(CEPHES_LIB)
+- $(CC) $(CFLAGS) $(GROBJS) -o $@ $(LDFLAGS) $(LIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) $(GROBJS) -o $@ $(LIBS)
+
+
+ buildinfo$(EXE) : buildinfo$(O)
+--- grace-5.1.22/auxiliary/Makefile
++++ grace-5.1.22/auxiliary/Makefile
+@@ -22,7 +22,7 @@
+ devclean : distclean
+
+ convcal$(EXE) : convcal.c
+- $(CC) $(CFLAGS0) $(CPPFLAGS) -o $@ convcal.c $(NOGUI_LIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS0) $(CPPFLAGS) -o $@ convcal.c $(NOGUI_LIBS)
+
+ install : $(AUXILIARIES) $(PROGRAMS) $(SCRIPTS)
+ $(MKINSTALLDIRS) $(DESTDIR)$(GRACE_HOME)/auxiliary
+--- grace-5.1.22/grconvert/Makefile
++++ grace-5.1.22/grconvert/Makefile
+@@ -23,7 +23,7 @@
+ all : $(PROG)
+
+ $(PROG) : $(OBJS)
+- $(CC) -o $@ $(OBJS) $(LDFLAGS) $(LIBS)
++ $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
+
+ $(OBJS) : grconvert.h
+
diff --git a/sci-visualization/grace/files/grace-5.1.22-mkstemp.patch b/sci-visualization/grace/files/grace-5.1.22-mkstemp.patch
new file mode 100644
index 000000000000..402a5162c584
--- /dev/null
+++ b/sci-visualization/grace/files/grace-5.1.22-mkstemp.patch
@@ -0,0 +1,55 @@
+diff -Naur grace-5.1.22/src/editpwin.c grace-5.1.22.new/src/editpwin.c
+--- grace-5.1.22/src/editpwin.c 2006-06-03 17:19:52.000000000 -0400
++++ grace-5.1.22.new/src/editpwin.c 2008-07-26 12:45:21.000000000 -0400
+@@ -776,12 +776,12 @@
+ */
+ void do_ext_editor(int gno, int setno)
+ {
+- char *fname, ebuf[256];
++ char fname[64], ebuf[256];
+ FILE *cp;
+ int save_autos;
+
+- fname = tmpnam(NULL);
+- cp = grace_openw(fname);
++ strcpy(fname, "grace-XXXXXX");
++ cp = fdopen(mkstemp(fname), "wb");
+ if (cp == NULL) {
+ return;
+ }
+diff -Naur grace-5.1.22/src/plotone.c grace-5.1.22.new/src/plotone.c
+--- grace-5.1.22/src/plotone.c 2005-05-19 16:30:25.000000000 -0400
++++ grace-5.1.22.new/src/plotone.c 2008-07-26 12:45:40.000000000 -0400
+@@ -121,19 +121,27 @@
+ sprintf(print_file, "%s.%s", get_docbname(), dev.fext);
+ }
+ strcpy(fname, print_file);
++ prstream = grace_openw(fname);
+ } else {
++ int hdfd;
+ s = get_print_cmd();
+ if (s == NULL || s[0] == '\0') {
+ errmsg("No print command defined, output aborted");
+ return;
+ }
+- tmpnam(fname);
+- /* VMS doesn't like extensionless files */
+- strcat(fname, ".prn");
++ strcpy(fname, "grace-hardcopy-XXXXXX");
++ hdfd=mkstemp(fname);
++ if (hdfd == -1) {
++ errmsg("Could not create a temporary file, output aborted.");
++ return;
++ }
++ prstream = fdopen(hdfd, "wb");
++ if (prstream == NULL) {
++ errmsg("Could not create a temporary file, output aborted.");
++ return;
++ }
+ }
+
+- prstream = grace_openw(fname);
+-
+ if (prstream == NULL) {
+ return;
+ }
diff --git a/sci-visualization/grace/files/grace.desktop b/sci-visualization/grace/files/grace.desktop
new file mode 100644
index 000000000000..227d88d9cbe4
--- /dev/null
+++ b/sci-visualization/grace/files/grace.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Grace
+Comment=Numerical Data Processing and Visualization Tool
+Exec=xmgrace
+Icon=grace
+Terminal=false
+Type=Application
+Categories=Graphics;