summaryrefslogtreecommitdiff
path: root/sci-visualization/ggobi/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-visualization/ggobi/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-visualization/ggobi/files')
-rw-r--r--sci-visualization/ggobi/files/ggobi-2.1.10-desktop.patch11
-rw-r--r--sci-visualization/ggobi/files/ggobi-2.1.10-hardened.patch66
-rw-r--r--sci-visualization/ggobi/files/ggobi-2.1.11-Wformat-security.patch36
-rw-r--r--sci-visualization/ggobi/files/ggobi-2.1.8-plugindir.patch11
-rw-r--r--sci-visualization/ggobi/files/ggobi-2.1.9-as-needed.patch40
5 files changed, 164 insertions, 0 deletions
diff --git a/sci-visualization/ggobi/files/ggobi-2.1.10-desktop.patch b/sci-visualization/ggobi/files/ggobi-2.1.10-desktop.patch
new file mode 100644
index 000000000000..388cb85c975c
--- /dev/null
+++ b/sci-visualization/ggobi/files/ggobi-2.1.10-desktop.patch
@@ -0,0 +1,11 @@
+--- xdg/ggobi.desktop.orig 2013-02-24 22:20:02.616872402 -0800
++++ xdg/ggobi.desktop 2013-02-24 22:20:13.293924862 -0800
+@@ -6,6 +6,6 @@
+ Comment=Multivariate interactive graphics for exploratory data analysis
+ TryExec=ggobi
+ Exec=ggobi
+-Icon=ggobi.png
+-Categories=Graphics;2DGraphics
++Icon=ggobi
++Categories=Graphics;2DGraphics;
+ MimeType=text/comma-separated-values;text/csv;application/csv;
diff --git a/sci-visualization/ggobi/files/ggobi-2.1.10-hardened.patch b/sci-visualization/ggobi/files/ggobi-2.1.10-hardened.patch
new file mode 100644
index 000000000000..63681a0a03ea
--- /dev/null
+++ b/sci-visualization/ggobi/files/ggobi-2.1.10-hardened.patch
@@ -0,0 +1,66 @@
+Description: Upstream changes introduced in version 2.1.10-4
+ This patch has been created by dpkg-source during the package build.
+ Here's the last changelog entry, hopefully it gives details on why
+ those changes were made:
+ .
+ ggobi (2.1.10-4) unstable; urgency=low
+ .
+ * src/ggobi.c: Applied patch kindly supplied by Michael Lawrence to
+ address issues found under hardened compiler flags (Closes: #646260)
+ .
+ The person named in the Author field signed this changelog entry.
+Author: Dirk Eddelbuettel <edd@debian.org>
+Bug-Debian: http://bugs.debian.org/646260
+
+---
+The information above should follow the Patch Tagging Guidelines, please
+checkout http://dep.debian.net/deps/dep3/ to learn about the format. Here
+are templates for supplementary fields that you might want to add:
+
+Origin: <vendor|upstream|other>, <url of original patch>
+Bug: <url in upstream bugtracker>
+Bug-Debian: http://bugs.debian.org/<bugnumber>
+Bug-Ubuntu: https://launchpad.net/bugs/<bugnumber>
+Forwarded: <no|not-needed|url proving that it has been forwarded>
+Reviewed-By: <name and email of someone who approved the patch>
+Last-Update: <YYYY-MM-DD>
+
+--- ggobi-2.1.10.orig/src/ggobi.c
++++ ggobi-2.1.10/src/ggobi.c
+@@ -698,10 +698,10 @@ ValidateGGobiRef (ggobid * gg, gboolean
+ }
+
+ if (fatal) {
+- g_error (error_msg);
++ g_error ("%s", error_msg);
+ }
+ else
+- g_critical (error_msg);
++ g_critical ("%s", error_msg);
+
+ return (NULL);
+ }
+@@ -718,9 +718,9 @@ ValidateDatadRef (GGobiData * d, ggobid
+ }
+
+ if (fatal)
+- g_error (error_msg);
++ g_error ("%s", error_msg);
+ else
+- g_critical (error_msg);
++ g_critical ("%s", error_msg);
+
+ return (NULL);
+ }
+@@ -739,9 +739,9 @@ ValidateDisplayRef (displayd * d, ggobid
+ }
+
+ if (fatal)
+- g_error (error_msg);
++ g_error ("%s", error_msg);
+ else
+- g_critical (error_msg);
++ g_critical ("%s", error_msg);
+
+ return (NULL);
+ }
diff --git a/sci-visualization/ggobi/files/ggobi-2.1.11-Wformat-security.patch b/sci-visualization/ggobi/files/ggobi-2.1.11-Wformat-security.patch
new file mode 100644
index 000000000000..960d940a7908
--- /dev/null
+++ b/sci-visualization/ggobi/files/ggobi-2.1.11-Wformat-security.patch
@@ -0,0 +1,36 @@
+Fix -Wformat -Werror=format-security errors caused by wrong fprintf calls
+See also: https://bugs.gentoo.org/show_bug.cgi?id=577430
+* utils_ui.c: In function ‘quick_message’:
+* utils_ui.c:192:29: error: format not a string literal and no format arguments [-Werror=format-security]
+* message);
+
+--- ggobi-2.1.11/src/utils_ui.c
++++ ggobi-2.1.11/src/utils_ui.c
+@@ -189,7 +189,7 @@
+
+ dialog =
+ gtk_message_dialog_new (NULL, 0, GTK_MESSAGE_INFO, GTK_BUTTONS_OK,
+- message);
++ "%s", message);
+
+ if (modal)
+ gtk_window_set_modal (GTK_WINDOW (dialog), true);
+--- ggobi-2.1.11/src/write_xml.c
++++ ggobi-2.1.11/src/write_xml.c
+@@ -37,14 +37,14 @@
+ write_xml_string(FILE *f, gchar *str)
+ {
+ gchar *fmtstr = g_markup_printf_escaped("%s", str);
+- fprintf(f, fmtstr);
++ fprintf(f, "%s", fmtstr);
+ g_free(fmtstr);
+ }
+ static void
+ write_xml_string_fmt(FILE *f, gchar *fmt, gchar *str)
+ {
+ gchar *fmtstr = g_markup_printf_escaped(fmt, str);
+- fprintf(f, fmtstr);
++ fprintf(f, "%s", fmtstr);
+ g_free(fmtstr);
+ }
+
diff --git a/sci-visualization/ggobi/files/ggobi-2.1.8-plugindir.patch b/sci-visualization/ggobi/files/ggobi-2.1.8-plugindir.patch
new file mode 100644
index 000000000000..0476f47a816d
--- /dev/null
+++ b/sci-visualization/ggobi/files/ggobi-2.1.8-plugindir.patch
@@ -0,0 +1,11 @@
+--- plugins/Makefile.plugin.orig 2009-12-14 22:15:01.000000000 +0000
++++ plugins/Makefile.plugin 2009-12-14 22:15:16.000000000 +0000
+@@ -2,7 +2,7 @@
+
+ # Every plugin provides a single library to GGobi, define it here.
+ # Its name should start with 'lib' and end with '.la'.
+-plugindir = $(datadir)/ggobi/plugins/$(PACKAGE_NAME)
++plugindir = $(libdir)/ggobi/plugins/$(PACKAGE_NAME)
+ plugin_LTLIBRARIES = plugin.la
+
+ # Most plugins will only require GGobi and its dependencies (gtk, libxml2)
diff --git a/sci-visualization/ggobi/files/ggobi-2.1.9-as-needed.patch b/sci-visualization/ggobi/files/ggobi-2.1.9-as-needed.patch
new file mode 100644
index 000000000000..3bec9b55c21d
--- /dev/null
+++ b/sci-visualization/ggobi/files/ggobi-2.1.9-as-needed.patch
@@ -0,0 +1,40 @@
+--- configure.ac.orig 2012-06-26 05:46:07.000000000 +0100
++++ configure.ac 2012-06-26 05:46:44.000000000 +0100
+@@ -178,6 +178,8 @@
+ echo "Looking for gtk2"
+
+ PKG_CHECK_MODULES(GTK, [gtk+-2.0 >= 2.6.0])
++AC_CHECK_LIB(m,sqrt)
++PKG_CHECK_MODULES(GMODULE, [gmodule-2.0 >= 2.0])
+
+ AC_SUBST(GTK_CFLAGS)
+ AC_SUBST(GTK_LIBS)
+
+--- src/Makefile.am.orig 2012-06-26 04:53:20.000000000 +0100
++++ src/Makefile.am 2012-06-26 04:54:04.000000000 +0100
+@@ -4,7 +4,6 @@
+ libggobi_la_GOBHEADERS = $(libggobi_la_GOBS:%.gob=ggobi-%.h)
+ libggobi_la_GOBOBJECTS = $(libggobi_la_GOBS:%.gob=ggobi-%.lo)
+ libggobi_la_GOBSTAMPS = $(libggobi_la_GOBS:%.gob=.%.gob.stamp)
+-libggobi_la_LDFLAGS = @GTK_LIBS@ @LIBXML_LIBS@
+ libggobi_la_BUILT = array.c ash1d.c barchart.c barchartClass.c \
+ barchart_ui.c brush.c brush_api.c brush_bins.c brush_init.c brush_link.c \
+ brush_ui.c color.c color_ui.c cpanel.c display.c display_tree.c display_ui.c \
+@@ -27,7 +26,7 @@
+ write_csv.c write_xml.c wvis.c wvis_ui.c xlines.c xyplot.c \
+ xyplot_ui.c $(libggobi_la_GOBSOURCES)
+ libggobi_la_SOURCES = $(libggobi_la_BUILT) $(libggobi_la_GOBSTAMPS)
+-libggobi_la_LIBADD = $(libggobi_la_GOBOBJECTS)
++libggobi_la_LIBADD = $(libggobi_la_GOBOBJECTS) @GTK_LIBS@ @LIBXML_LIBS@ @GMODULE_LIBS@
+ libggobi_la_DEPENDENCIES = $(libggobi_la_GOBOBJECTS)
+ pkginclude_HEADERS = GGobiAPI.h ggobiClass.h tour1d_pp.h GGobiApp.h \
+ noop-toggle.h tour2d_pp.h GGobiEvents.h parcoordsClass.h tour_pp.h \
+@@ -59,7 +58,7 @@
+ # Windows specific
+ if OS_WIN32
+ libggobi_la_DEPENDENCIES+=libggobi.def
+-libggobi_la_LDFLAGS+=-Wc,-s -no-undefined -export-symbols libggobi.def
++libggobi_la_LDFLAGS=-Wc,-s -no-undefined -export-symbols libggobi.def
+ ggobi_LDFLAGS = -mwindows -s
+ endif
+