summaryrefslogtreecommitdiff
path: root/sci-visualization/dash
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /sci-visualization/dash
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'sci-visualization/dash')
-rw-r--r--sci-visualization/dash/Manifest3
-rw-r--r--sci-visualization/dash/dash-1.20.0.ebuild51
-rw-r--r--sci-visualization/dash/metadata.xml29
3 files changed, 83 insertions, 0 deletions
diff --git a/sci-visualization/dash/Manifest b/sci-visualization/dash/Manifest
new file mode 100644
index 000000000000..550335609d50
--- /dev/null
+++ b/sci-visualization/dash/Manifest
@@ -0,0 +1,3 @@
+DIST dash-1.20.0.tar.gz 1786368 BLAKE2B 2826336f72b9bea80be6ef77df49109b7b68ed93678b606c998a1906907551551a3228e1140d20c6e1b5bf5e53fb9cebd0c0a4d7ab5cc1a590e47ef351558a40 SHA512 670cf593068370c70f1db25c70c7a76ce98c696efbff1146cc90f90a99b8b48bf80cf47688504d173ef253ccb9f1170c2067b3af9414eacb226f7ef25149ffff
+EBUILD dash-1.20.0.ebuild 1132 BLAKE2B 03417dda28e853a9e75213681febab9426eef56449369414659e22de5ea078a69c23e6a1bad166fb3fbd7596947644ebd061914e22bbfba5d0d84220800be0cb SHA512 98d5bf3a66a7e758861efe701c420694b9009708fbe8c265c7084f2dda2cdf17c444b504ae1ec2e37a9a2e0ac80ca941fb1ab6a45dd2a618d0cc91a19ce014ca
+MISC metadata.xml 1361 BLAKE2B 9e26c68268b511740225421daa576f511cef16cedade769fce590be5cbe7a3bd29391b9cdb96b3d717cba41ec91152d653c4bc0e3d9639dd31f8cf8893e48218 SHA512 44b4aded0185eeb4604605b80cc5eb52d7b8b1f2696deb4182db2cbc6b6c687de1f46f3bffc282b74ad810fcb5505161191e8d16fb0e0a6bd95e82e63804a547
diff --git a/sci-visualization/dash/dash-1.20.0.ebuild b/sci-visualization/dash/dash-1.20.0.ebuild
new file mode 100644
index 000000000000..3d4344e62315
--- /dev/null
+++ b/sci-visualization/dash/dash-1.20.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Python framework for building ML & data science web apps"
+HOMEPAGE="https://github.com/plotly/dash"
+SRC_URI="https://github.com/plotly/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/future[${PYTHON_USEDEP}]
+ sci-visualization/dash-table[${PYTHON_USEDEP}]
+ sci-visualization/dash-html-components[${PYTHON_USEDEP}]
+ sci-visualization/dash-core-components[${PYTHON_USEDEP}]
+ dev-python/plotly[${PYTHON_USEDEP}]
+ dev-python/flask-compress[${PYTHON_USEDEP}]"
+BDEPEND=""
+
+src_prepare() {
+ distutils-r1_src_prepare
+ cd dash-renderer
+ distutils-r1_src_prepare
+}
+
+src_configure() {
+ distutils-r1_src_configure
+ cd dash-renderer
+ distutils-r1_src_configure
+}
+
+src_compile() {
+ distutils-r1_src_compile
+ cd dash-renderer
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+ cd dash-renderer
+ distutils-r1_src_install
+}
diff --git a/sci-visualization/dash/metadata.xml b/sci-visualization/dash/metadata.xml
new file mode 100644
index 000000000000..166d71c6fb59
--- /dev/null
+++ b/sci-visualization/dash/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <longdescription lang="en">
+ Dash is a productive Python framework for building web analytic
+ applications.
+ Written on top of Flask, Plotly.js, and React.js, Dash is ideal for
+ building data visualization apps with highly custom user interfaces in
+ pure Python. It's particularly suited for anyone who works with data in
+ Python.
+ Through a couple of simple patterns, Dash abstracts away all of the
+ technologies and protocols that are required to build an interactive
+ web-based application. Dash is simple enough that you can bind a user
+ interface around your Python code in an afternoon.
+ Dash apps are rendered in the web browser. You can deploy your apps to
+ servers and then share them through URLs. Since Dash apps are viewed in
+ the web browser, Dash is inherently cross-platform and mobile ready.
+ Dash ships with supercharged components for interactive user
+ interfaces. A core set of components, written and maintained by the
+ Dash team, is available in the dash-core-components library.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">plotly/dash</remote-id>
+ </upstream>
+</pkgmetadata>