summaryrefslogtreecommitdiff
path: root/sci-physics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-28 23:59:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-28 23:59:44 +0100
commit5f0030fd1370c4d03dbb2e0d3086f5e618a33749 (patch)
treed3996b456278fbe1e1528053ddd115c4bac05401 /sci-physics
parent413421048cc2b0df9a218f0ab3cb151846809eb5 (diff)
gentoo auto-resync : 28:04:2024 - 23:59:44
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/Manifest.gzbin4363 -> 4361 bytes
-rw-r--r--sci-physics/heppdt/Manifest2
-rw-r--r--sci-physics/heppdt/heppdt-3.04.01-r2.ebuild (renamed from sci-physics/heppdt/heppdt-3.04.01-r1.ebuild)25
3 files changed, 10 insertions, 17 deletions
diff --git a/sci-physics/Manifest.gz b/sci-physics/Manifest.gz
index 41c99148248f..77f0d3ec5dea 100644
--- a/sci-physics/Manifest.gz
+++ b/sci-physics/Manifest.gz
Binary files differ
diff --git a/sci-physics/heppdt/Manifest b/sci-physics/heppdt/Manifest
index 8e37a8a51dca..c467cf9e01fe 100644
--- a/sci-physics/heppdt/Manifest
+++ b/sci-physics/heppdt/Manifest
@@ -1,3 +1,3 @@
DIST HepPDT-3.04.01.tar.gz 1851879 BLAKE2B 7fbd73818a04cce4e5911dfdeb03c59878f75baf1d416bd2814d9d820179ee31e6f7938017d628f22994e71930746a4a485d0bc4316c23c2c82ba513e19e6fa0 SHA512 33a93b7d18c0cc64ab13923eb5edca89ed753a7f888a31c1d6a5f84f735e4042e2eaaf04e221d487976603a40fbd84cede4b4dd2bcd2e7479d97cc637dda637b
-EBUILD heppdt-3.04.01-r1.ebuild 1172 BLAKE2B 71429701bb916b1e157d46022da145f5511007329adff4f47dab991c15db6e6a07ea5724bdbf70894cbe7d930524011fc430bf56ea9b7a91a3e9e561ab8aab91 SHA512 a4bc98978293a6e36c2103850d6945bf0535435e363a34a6a58f072c4e961c567c5efc90c703568f4ba9a84672aa06db8a8eaba4713cac9b4eb1980088ae1d6b
+EBUILD heppdt-3.04.01-r2.ebuild 1134 BLAKE2B aa3bd6156ee55cd7287ae2a47849b81e542b8b45867ad52ef0fa56208c8cba3428a15d4db0e33e443ae97046bed72c748fb8889b853ad00ae555516aaf78bc11 SHA512 b4301780d299d319778379c444053e5f92609bada069d91925a2672eeeaebe5970f728d28d19999554b2cc8394639c7c4e4d6420ec191c9095a6cd7e0f55af08
MISC metadata.xml 729 BLAKE2B 0979d8638bc3aa3055cc8ba76afeed98f038c533653e7866b2d454c5ef13950ef97cc0469fcdef0210880617dd697929d48aeb207109d52ecc0c10e06aa43e1a SHA512 061f2842dc7a2706ea1559263b8d2add23a8675826acf08f8cd4a29e6b8d59af150feb6ca2372ff1adf1471260e8e79c2f9d6dcdbdd0f03bfd9b1d9edeb0984e
diff --git a/sci-physics/heppdt/heppdt-3.04.01-r1.ebuild b/sci-physics/heppdt/heppdt-3.04.01-r2.ebuild
index 9f5e3c36d28e..8751a4c1512d 100644
--- a/sci-physics/heppdt/heppdt-3.04.01-r1.ebuild
+++ b/sci-physics/heppdt/heppdt-3.04.01-r2.ebuild
@@ -1,33 +1,26 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools
-MY_P=HepPDT-${PV}
-
DESCRIPTION="Data about each particle from the Review of Particle Properties"
HOMEPAGE="http://lcgapp.cern.ch/project/simu/HepPDT/"
-SRC_URI="http://lcgapp.cern.ch/project/simu/HepPDT/download/${MY_P}.tar.gz"
+SRC_URI="http://lcgapp.cern.ch/project/simu/HepPDT/download/HepPDT-${PV}.tar.gz"
+S=${WORKDIR}/HepPDT-${PV}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc examples static-libs"
-S="${WORKDIR}/${MY_P}"
-
src_prepare() {
default
# respect user flags
- sed -i \
- -e '/AC_SUBST(AM_CXXFLAGS)/d' \
- configure.ac || die
+ sed -i configure.ac -e '/AC_SUBST(AM_CXXFLAGS)/d' || die
# directories
- sed -i \
- -e 's:$(prefix)/data:$(datadir)/${PN}:g' \
- data/Makefile.am || die
+ sed -i data/Makefile.am -e 's:$(prefix)/data:$(datadir)/${PN}:g' || die
eautoreconf
}
@@ -44,11 +37,11 @@ src_install() {
default
if use doc; then
- mv "${ED%/}"/usr/doc/* "${ED%/}"/usr/share/doc/${PF}/ || die
+ mv "${ED}"/usr/doc/* "${ED}"/usr/share/doc/${PF}/ || die
fi
if use examples; then
- mv "${ED%/}"/usr/examples "${ED%/}"/usr/share/doc/${PF}/ || die
+ mv "${ED}"/usr/examples "${ED}"/usr/share/doc/${PF}/ || die
docompress -x /usr/share/doc/${PF}/examples
fi
- rm -rf "${ED%/}"/usr/{doc,examples} || die
+ rm -rf "${ED}"/usr/{doc,examples} || die
}