summaryrefslogtreecommitdiff
path: root/sci-physics/yoda
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
commit463397cf1e064185110fe57c568d73f99a06f5d1 (patch)
tree9aa75eefc5154eaf0e3c33658b830fc54dc68052 /sci-physics/yoda
parentc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (diff)
gentoo resync : 17.02.2021
Diffstat (limited to 'sci-physics/yoda')
-rw-r--r--sci-physics/yoda/Manifest4
-rw-r--r--sci-physics/yoda/yoda-1.8.5.ebuild (renamed from sci-physics/yoda/yoda-1.7.0-r2.ebuild)18
2 files changed, 11 insertions, 11 deletions
diff --git a/sci-physics/yoda/Manifest b/sci-physics/yoda/Manifest
index 86793c5e6fb9..336dd9fcc566 100644
--- a/sci-physics/yoda/Manifest
+++ b/sci-physics/yoda/Manifest
@@ -1,3 +1,3 @@
-DIST YODA-1.7.0.tar.bz2 949964 BLAKE2B 44063500b95e6a089adac0a28eb0165c6d91f09642dcba7eae994a8b2dd9c4cc5cff40d63cbb481f41e023193632b9b2c17c4304bc03afa4ad2c6010b52c15da SHA512 de4eff3fdd7f8f031745152907eadfe4687c6c8597772d8aba628e58e7d6f203bbe55ba030a77990b2441a9b046a4d7e2bce1fb29ba9a631c1cff17acd95b1e5
-EBUILD yoda-1.7.0-r2.ebuild 846 BLAKE2B f3dc73cb7ee52315ff40b6a4cb0162e50c01022e2e614aea217e9118aee9b02573b39493341b6fdc70780b5cd6673e3235c5c5bb9f70d2ce8ae4535055e7d034 SHA512 d3f31ca3a517874f43af46ab3b0c6908eb87b77a067c74c8c722839544b839088e03ca9684a18cd496bc170062ed7cd94c9b9543551e597b79623e13a3752278
+DIST YODA-1.8.5.tar.bz2 1057576 BLAKE2B 3c6abb680afcfb8250c3ae340a1b1307cb5498b726199ecf9afe593fc49c4099fd2b4ac881568c303abd10c22fcf91ffae4283021443fc6230456376617f0de1 SHA512 d1fffa55af069f894b3c88bcd105f77a3105095281febf9c06c0cea2fadea6c63d69df5bde4aa96646d2d560bd83cade6802d9ed19d5a30553cd003ace19dfc8
+EBUILD yoda-1.8.5.ebuild 841 BLAKE2B 451e469bbca5da56c96177719bb2766ddae3a7302f31dd7461df5a2190736bd2953e82e0da02730dd65568abb9748d781796460f78a029bd9cdb66251d6ec6fa SHA512 e50f47d5664dd5e5888bb40fa7355081ad04cea31ebcfcb0501e445239c19cf426aa996494fd64610eaada2bcc3d683dc642d546683b65c17661985215ecd30b
MISC metadata.xml 659 BLAKE2B 460df9dfdf485eb860ba7eb737ee9cc715e823b4961894a99e51e9bbdb98ce14a87639ddb0774aeed11d111ed21ddc4e1804f41fcb4cd72c5b0b456402588f6f SHA512 ad6899122310e6e4ecb0e72737362379cc180524dd7e60c6dbacbd7d2a0eab5c633eb5ecf8b6731ed40b12e0e186eba8ce6def539c1c0969974e75467250b7b7
diff --git a/sci-physics/yoda/yoda-1.7.0-r2.ebuild b/sci-physics/yoda/yoda-1.8.5.ebuild
index a17c010c34b1..5e3646209677 100644
--- a/sci-physics/yoda/yoda-1.7.0-r2.ebuild
+++ b/sci-physics/yoda/yoda-1.8.5.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit bash-completion-r1
@@ -12,10 +12,9 @@ SRC_URI="https://www.hepforge.org/archive/${PN}/${P^^}.tar.bz2"
LICENSE="GPL-2"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="root static-libs"
+IUSE="root"
-RDEPEND="
- root? ( sci-physics/root:= )"
+RDEPEND="root? ( sci-physics/root:= )"
DEPEND="${RDEPEND}"
S="${WORKDIR}/${P^^}"
@@ -23,8 +22,8 @@ S="${WORKDIR}/${P^^}"
src_configure() {
econf \
--disable-pyext \
- $(use_enable root) \
- $(use_enable static-libs static)
+ --disable-static \
+ $(use_enable root)
}
src_test() {
@@ -34,6 +33,7 @@ src_test() {
src_install() {
default
- newbashcomp "${ED%/}"/usr/share/YODA/yoda-completion ${PN}
- rm "${ED%/}"/usr/share/YODA/yoda-completion || die
+ newbashcomp "${ED}"/usr/share/YODA/yoda-completion yoda
+ rm "${ED}"/usr/share/YODA/yoda-completion || die
+ rm -r "${ED}"/usr/etc || die
}