summaryrefslogtreecommitdiff
path: root/sci-physics/yoda/yoda-1.9.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /sci-physics/yoda/yoda-1.9.5.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'sci-physics/yoda/yoda-1.9.5.ebuild')
-rw-r--r--sci-physics/yoda/yoda-1.9.5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-physics/yoda/yoda-1.9.5.ebuild b/sci-physics/yoda/yoda-1.9.5.ebuild
new file mode 100644
index 000000000000..e21cc066b474
--- /dev/null
+++ b/sci-physics/yoda/yoda-1.9.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="Yet more Objects for (High Energy Physics) Data Analysis"
+HOMEPAGE="https://yoda.hepforge.org/"
+SRC_URI="https://yoda.hepforge.org/downloads?f=${P^^}.tar.bz2 -> ${P^^}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="root"
+
+RDEPEND="root? ( sci-physics/root:= )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P^^}"
+
+src_configure() {
+ econf \
+ --disable-pyext \
+ --disable-static \
+ $(use_enable root)
+}
+
+src_test() {
+ # PYTESTS and SHTESTS both require python tools
+ emake check PYTESTS= SHTESTS=
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+ newbashcomp "${ED}"/etc/bash_completion.d/yoda-completion yoda
+ rm "${ED}"/etc/bash_completion.d/yoda-completion || die
+}