summaryrefslogtreecommitdiff
path: root/sci-physics/root/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
commit6b933047f46efec1aa747570f945344254227457 (patch)
treea12a4b87b38f954c4de435272cf4b90d721df5e8 /sci-physics/root/files
parentf45955e60d4da9b7f4a1088c98042f9c06669039 (diff)
gentoo resync : 15.12.2017
Diffstat (limited to 'sci-physics/root/files')
-rw-r--r--sci-physics/root/files/root-6.11.02-hsimple.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-physics/root/files/root-6.11.02-hsimple.patch b/sci-physics/root/files/root-6.11.02-hsimple.patch
new file mode 100644
index 000000000000..c1e88bd55b7d
--- /dev/null
+++ b/sci-physics/root/files/root-6.11.02-hsimple.patch
@@ -0,0 +1,34 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index aa05c02568..ef2b5e3f52 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -354,28 +354,6 @@ add_dependencies(onepcm ${__allTargets})
+ install(FILES ${CMAKE_BINARY_DIR}/etc/allDict.cxx.pch DESTINATION ${CMAKE_INSTALL_SYSCONFDIR})
+ install(DIRECTORY ${CMAKE_BINARY_DIR}/etc/dictpch DESTINATION ${CMAKE_INSTALL_SYSCONFDIR})
+
+-#---hsimple.root---------(use the executable for clearer dependencies and proper return code)---
+-if(NOT WIN32)
+-add_custom_target(hsimple ALL DEPENDS tutorials/hsimple.root)
+-add_dependencies(hsimple onepcm)
+-if(WIN32)
+- add_custom_command(OUTPUT tutorials/hsimple.root
+- COMMAND set PATH=${CMAKE_RUNTIME_OUTPUT_DIRECTORY} &&
+- set ROOTIGNOREPREFIX=1 &&
+- $<TARGET_FILE:root.exe> -l -q -b -n -x hsimple.C -e return
+- WORKING_DIRECTORY tutorials
+- DEPENDS $<TARGET_FILE:root.exe> Cling Hist Tree Gpad Graf HistPainter move_artifacts)
+-else()
+- add_custom_command(OUTPUT tutorials/hsimple.root
+- COMMAND ${ld_library_path}=${CMAKE_LIBRARY_OUTPUT_DIRECTORY}:$ENV{${ld_library_path}}
+- ROOTIGNOREPREFIX=1
+- $<TARGET_FILE:root.exe> -l -q -b -n -x hsimple.C -e return
+- WORKING_DIRECTORY tutorials
+- DEPENDS $<TARGET_FILE:root.exe> Cling Hist Tree Gpad Graf HistPainter move_artifacts)
+-endif()
+-install(FILES ${CMAKE_BINARY_DIR}/tutorials/hsimple.root DESTINATION ${CMAKE_INSTALL_TUTDIR} COMPONENT tests)
+-endif()
+-
+ #---version--------------------------------------------------------------------------------------
+ if(NOT WIN32)
+ add_custom_target(version COMMAND ${CMAKE_SOURCE_DIR}/build/unix/makeversion.sh ${CMAKE_BINARY_DIR}
+