summaryrefslogtreecommitdiff
path: root/sci-physics/root/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-physics/root/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-physics/root/files')
-rw-r--r--sci-physics/root/files/proofd.confd12
-rw-r--r--sci-physics/root/files/proofd.initd25
-rw-r--r--sci-physics/root/files/root-5.28.00b-glibc212.patch11
-rw-r--r--sci-physics/root/files/root-5.32.00-afs.patch33
-rw-r--r--sci-physics/root/files/root-5.32.00-cfitsio.patch13
-rw-r--r--sci-physics/root/files/root-5.32.00-chklib64.patch24
-rw-r--r--sci-physics/root/files/root-5.32.00-dotfont.patch58
-rw-r--r--sci-physics/root/files/root-5.34.05-nobyte-compile.patch137
-rw-r--r--sci-physics/root/files/root-5.34.13-unuran.patch40
-rw-r--r--sci-physics/root/files/root-5.34.26-ldflags.patch19
-rw-r--r--sci-physics/root/files/root-6.00.01-dotfont.patch58
-rw-r--r--sci-physics/root/files/root-6.00.01-llvm.patch13
-rw-r--r--sci-physics/root/files/root-6.00.01-nobyte-compile.patch33
-rw-r--r--sci-physics/root/files/root-6.02.05-xrootd4.patch11
-rw-r--r--sci-physics/root/files/root-6.04.06-gsl2.patch58
-rw-r--r--sci-physics/root/files/root-6.04.06-prop-flags.patch22
-rw-r--r--sci-physics/root/files/rootd.confd8
-rw-r--r--sci-physics/root/files/rootd.initd27
18 files changed, 602 insertions, 0 deletions
diff --git a/sci-physics/root/files/proofd.confd b/sci-physics/root/files/proofd.confd
new file mode 100644
index 000000000000..81720a7eb335
--- /dev/null
+++ b/sci-physics/root/files/proofd.confd
@@ -0,0 +1,12 @@
+# conf.d file for proof daemon
+#
+# Please refer to the proofd(1) man(1) page for more information on
+# command line parameters.
+#
+PROOFD_OPTS=
+
+# Specify your base of your PROOF directory here. If left blank, it
+# will use the system default (e.g., /usr/share/root/proof).
+# Note, however, that ROOT recommends that this directory is shared (via
+# NFS or similar) among all the nodes of the cluster.
+PROOF_DIR=
diff --git a/sci-physics/root/files/proofd.initd b/sci-physics/root/files/proofd.initd
new file mode 100644
index 000000000000..ee865133cb25
--- /dev/null
+++ b/sci-physics/root/files/proofd.initd
@@ -0,0 +1,25 @@
+#!/sbin/openrc-run
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need root-file-server
+ use logger
+}
+
+start() {
+ ebegin "Starting parallel ROOT facility server"
+ start-stop-daemon --start --quiet \
+ --pidfile /var/run/proofd.pid \
+ --exec /usr/bin/proofd -- ${PROOFD_OPTS} ${PROOF_DIR}
+ pidof /usr/bin/proofd > /var/run/proofd.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping parallel ROOT facility server"
+ start-stop-daemon --stop --quiet \
+ --pidfile /var/run/proofd.pid \
+ --exec /usr/bin/proofd
+ eend $?
+}
diff --git a/sci-physics/root/files/root-5.28.00b-glibc212.patch b/sci-physics/root/files/root-5.28.00b-glibc212.patch
new file mode 100644
index 000000000000..a365431396f5
--- /dev/null
+++ b/sci-physics/root/files/root-5.28.00b-glibc212.patch
@@ -0,0 +1,11 @@
+--- root.orig/net/auth/src/TAFS.cxx 2010-09-14 03:22:22.647915854 +0400
++++ root/net/auth/src/TAFS.cxx 2010-09-14 03:22:39.034599899 +0400
+@@ -11,6 +11,7 @@
+
+ #ifndef WIN32
+ # include <unistd.h>
++# include <sys/stat.h>
+ #else
+ # define ssize_t int
+ # include <io.h>
+
diff --git a/sci-physics/root/files/root-5.32.00-afs.patch b/sci-physics/root/files/root-5.32.00-afs.patch
new file mode 100644
index 000000000000..2bf31798e6e0
--- /dev/null
+++ b/sci-physics/root/files/root-5.32.00-afs.patch
@@ -0,0 +1,33 @@
+--- root/net/auth/src/TAFS.cxx.orig 2011-12-04 00:56:29.405007770 +0400
++++ root/net/auth/src/TAFS.cxx 2011-12-04 00:56:35.534709259 +0400
+@@ -138,7 +138,7 @@
+ } else {
+ if (isatty(0) != 0 && isatty(1) != 0) {
+ Gl_config("noecho", 1);
+- pw = Getline((char *) prompt.Data());
++ pw = const_cast<char *>( Getline((char *) prompt.Data()) );
+ Gl_config("noecho", 0);
+ } else {
+ Warning("TAFS", "not tty: cannot prompt for passwd: failure");
+--- root/core/clib/src/strlcat.c.orig 2011-12-04 01:49:26.495179487 +0400
++++ root/core/clib/src/strlcat.c 2011-12-04 01:50:41.407524763 +0400
+@@ -38,7 +38,7 @@
+ * Returns strlen(src) + MIN(siz, strlen(initial dst)).
+ * If retval >= siz, truncation occurred.
+ */
+-size_t
++size_t __attribute__((weak))
+ strlcat(char *dst, const char *src, size_t siz)
+ {
+ register char *d = dst;
+--- root/core/clib/src/strlcpy.c.orig 2011-12-04 01:49:34.329797251 +0400
++++ root/core/clib/src/strlcpy.c 2011-12-04 01:50:49.051151843 +0400
+@@ -36,7 +36,7 @@
+ * will be copied. Always NUL terminates (unless siz == 0).
+ * Returns strlen(src); if retval >= siz, truncation occurred.
+ */
+-size_t
++size_t __attribute__((weak))
+ strlcpy(char *dst, const char *src, size_t siz)
+ {
+ register char *d = dst;
diff --git a/sci-physics/root/files/root-5.32.00-cfitsio.patch b/sci-physics/root/files/root-5.32.00-cfitsio.patch
new file mode 100644
index 000000000000..853c3f39f207
--- /dev/null
+++ b/sci-physics/root/files/root-5.32.00-cfitsio.patch
@@ -0,0 +1,13 @@
+--- configure.orig 2012-01-19 23:44:44.127607638 +0100
++++ configure 2012-01-20 00:19:20.420652913 +0100
+@@ -3435,9 +3435,7 @@
+ cfitsioinc=$found_hdr
+ cfitsioincdir=$found_dir
+
+- # At this time, libcfitsio.a should always be prefered over .so,
+- # to avoid forcing users to install cfitsio.
+- check_library "libcfitsio cfitsio" "no" "$cfitsiolibdir" \
++ check_library "libcfitsio cfitsio" "yes" "$cfitsiolibdir" \
+ $CFITSIO ${CFITSIO:+$CFITSIO/lib} ${CFITSIO:+$CFITSIO/.libs} \
+ ${finkdir:+$finkdir/lib} \
+ /usr/local/lib /usr/lib /opt/cfitsio/lib
diff --git a/sci-physics/root/files/root-5.32.00-chklib64.patch b/sci-physics/root/files/root-5.32.00-chklib64.patch
new file mode 100644
index 000000000000..979220f02f35
--- /dev/null
+++ b/sci-physics/root/files/root-5.32.00-chklib64.patch
@@ -0,0 +1,24 @@
+bug fix for #406817
+--- configure.orig 2012-02-29 19:46:41.000000000 +0400
++++ configure 2012-03-22 03:28:43.458968696 +0400
+@@ -441,14 +441,13 @@
+ fi
+ else
+ if file $filearg $chklib64 | grep 'ASCII' > /dev/null 2>& 1 ; then
+- check_link $chklib64
+- ret=$link_result
+- else
+- logmsg " file $filearg $chklib64 | grep '64-bit'"
+- if file $filearg $chklib64 | grep '64-bit' > /dev/null 2>& 1 ; then
+- ret=1
+- fi
++ # get real binary .so name from .so ld script
++ chklib64=$(gawk '($1 == "GROUP") { print $3 }' $chklib64)
+ fi
++ logmsg " file $filearg $chklib64 | grep '64-bit'"
++ if file $filearg $chklib64 | grep '64-bit' > /dev/null 2>& 1 ; then
++ ret=1
++ fi
+ fi
+ logmsg " result: $ret"
+ if test $ret -eq 1 ; then
diff --git a/sci-physics/root/files/root-5.32.00-dotfont.patch b/sci-physics/root/files/root-5.32.00-dotfont.patch
new file mode 100644
index 000000000000..85d6dea7655e
--- /dev/null
+++ b/sci-physics/root/files/root-5.32.00-dotfont.patch
@@ -0,0 +1,58 @@
+--- root/html/src/TClassDocOutput.cxx.orig 2012-05-25 16:18:10.000000000 +0400
++++ root/html/src/TClassDocOutput.cxx 2012-05-29 21:36:53.813593012 +0400
+@@ -625,7 +625,7 @@
+ << "size=\"8,10\";" << endl
+ << "ratio=auto;" << endl
+ << "margin=0;" << endl
+- << "node [shape=plaintext,fontsize=40,width=4,height=0.75];" << endl
++ << "node [shape=plaintext,fontsize=40,width=4,height=0.75,fontname=\"DejaVu Serif\"];" << endl
+ << "\"" << fCurrentClass->GetName() << "\" [shape=ellipse];" << endl;
+
+ std::stringstream ssDep;
+@@ -704,7 +704,7 @@
+ outdot << ";" << endl;
+ } else if (writeAndMoreFor) {
+ outdot << " \"...andmore" << writeAndMoreFor->GetName()
+- << "\" [label=\"...and more\",fontname=\"Times-Italic\",fillcolor=lightgrey,style=filled];" << endl;
++ << "\" [label=\"...and more\",fontname=\"DejaVu Serif Italic\",fillcolor=lightgrey,style=filled];" << endl;
+ }
+ }
+ if (!levelExists) break;
+@@ -733,7 +733,7 @@
+ << "ranksep=0.1;" << endl
+ << "nodesep=0;" << endl
+ << "margin=0;" << endl;
+- outdot << " node [style=filled,width=0.7,height=0.15,fixedsize=true,shape=plaintext,fontsize=10];" << endl;
++ outdot << " node [style=filled,width=0.7,height=0.15,fixedsize=true,shape=plaintext,fontsize=10,fontname=\"DejaVu Serif\"];" << endl;
+
+ std::stringstream ssDep;
+ const int numColumns = 3;
+@@ -939,7 +939,7 @@
+ << "ranksep=0;" << endl
+ << "nodesep=0;" << endl
+ << "size=\"8,10\";" << endl
+- << "node [fontsize=20,shape=plaintext];" << endl;
++ << "node [fontsize=20,shape=plaintext,fontname=\"DejaVu Serif\"];" << endl;
+
+ for (std::list<std::string>::iterator iFile = listFilesToParse.begin();
+ iFile != listFilesToParse.end(); ++iFile) {
+@@ -999,7 +999,8 @@
+ << "ranksep=0.7;" << endl
+ << "nodesep=0.3;" << endl
+ << "size=\"8,8\";" << endl
+- << "ratio=compress;" << endl;
++ << "ratio=compress;" << endl
++ << "node [fontname=\"DejaVu Serif\"];" << endl;
+
+ TString libs(fCurrentClass->GetSharedLibs());
+ outdot << "\"All Libraries\" [URL=\"LibraryDependencies.html\",shape=box,rank=max,fillcolor=lightgray,style=filled];" << endl;
+@@ -1109,7 +1110,8 @@
+
+ dotout << "digraph G {" << endl
+ << "ratio=auto;" << endl
+- << "rankdir=RL;" << endl;
++ << "rankdir=RL;" << endl
++ << "node [fontname=\"DejaVu Serif\"];" << endl;
+
+ // loop on all classes
+ TClassDocInfo* cdi = 0;
diff --git a/sci-physics/root/files/root-5.34.05-nobyte-compile.patch b/sci-physics/root/files/root-5.34.05-nobyte-compile.patch
new file mode 100644
index 000000000000..ec67a15887f6
--- /dev/null
+++ b/sci-physics/root/files/root-5.34.05-nobyte-compile.patch
@@ -0,0 +1,137 @@
+diff -Naur root.as-needed/Makefile root/Makefile
+--- a/Makefile.orig 2013-02-15 02:27:56.000000000 +0400
++++ b/Makefile 2013-02-23 02:22:14.556465852 +0400
+@@ -1258,10 +1258,7 @@
+ for lib in $(RFLX_GRFLXPY); do \
+ rm -f $(DESTDIR)$(LIBDIR)/$${lib#lib/}; \
+ done; \
+- for lib in $(RFLX_GRFLXPYC); do \
+- rm -f $(DESTDIR)$(LIBDIR)/$${lib#lib/}; \
+- done; \
+- if test "x$(RFLX_GRFLXPY)$(RFLX_GRFLXPYC)" != "x"; then \
++ if test "x$(RFLX_GRFLXPY)" != "x"; then \
+ dir=$(subst lib/,,$(RFLX_GRFLXDD)); \
+ while test "x$${dir}" != "x" && \
+ test -d $(DESTDIR)$(LIBDIR)/$${dir} && \
+diff -Naur root.as-needed/bindings/pyroot/Module.mk root/bindings/pyroot/Module.mk
+--- root.as-needed/bindings/pyroot/Module.mk 2011-07-10 10:42:48.991561304 +0400
++++ root/bindings/pyroot/Module.mk 2011-07-10 10:43:21.493339703 +0400
+@@ -48,8 +48,6 @@
+ ROOTPY := $(subst $(MODDIR),$(LPATH),$(ROOTPYS))
+ $(LPATH)/%.py: $(MODDIR)/%.py; cp $< $@
+ endif
+-ROOTPYC := $(ROOTPY:.py=.pyc)
+-ROOTPYO := $(ROOTPY:.py=.pyo)
+
+ # used in the main Makefile
+ ALLHDRS += $(patsubst $(MODDIRI)/%.h,include/%.h,$(PYROOTH))
+@@ -68,10 +66,8 @@
+ include/%.h: $(PYROOTDIRI)/%.h
+ cp $< $@
+
+-%.pyc: %.py; python -c 'import py_compile; py_compile.compile( "$<" )'
+-%.pyo: %.py; python -O -c 'import py_compile; py_compile.compile( "$<" )'
+
+-$(PYROOTLIB): $(PYROOTO) $(PYROOTDO) $(ROOTPY) $(ROOTPYC) $(ROOTPYO) \
++$(PYROOTLIB): $(PYROOTO) $(PYROOTDO) $(ROOTPY) \
+ $(ROOTLIBSDEP) $(PYTHONLIBDEP)
+ @$(MAKELIB) $(PLATFORM) $(LD) "$(LDFLAGS)" \
+ "$(SOFLAGS)" libPyROOT.$(SOEXT) $@ \
+@@ -113,7 +109,7 @@
+
+ distclean-$(MODNAME): clean-$(MODNAME)
+ @rm -f $(PYROOTDEP) $(PYROOTDS) $(PYROOTDH) $(PYROOTLIB) \
+- $(ROOTPY) $(ROOTPYC) $(ROOTPYO) $(PYROOTMAP) \
++ $(ROOTPY) $(PYROOTMAP) \
+ $(PYROOTPYD) $(PYTHON64DEP) $(PYTHON64)
+
+ distclean:: distclean-$(MODNAME)
+diff -Naur root.as-needed/build/package/debian/rules root/build/package/debian/rules
+--- root.as-needed/build/package/debian/rules 2011-07-10 10:42:49.241549346 +0400
++++ root/build/package/debian/rules 2011-07-10 10:48:06.989670589 +0400
+@@ -691,10 +691,6 @@
+ -X$(SYSCONFDIR)/root/system.rootauthrc \
+ -X$(SYSCONFDIR)/root/system.rootdaemonrc \
+ -X$(PREFIX)/lib/root/$(SOVERS)/libAfterImage.a \
+- -X$(PREFIX)/lib/root/$(SOVERS)/PyCintex.pyc \
+- -X$(PREFIX)/lib/root/$(SOVERS)/PyCintex.pyo \
+- -X$(PREFIX)/lib/root/$(SOVERS)/ROOT.pyc \
+- -X$(PREFIX)/lib/root/$(SOVERS)/ROOT.pyo \
+ -X$(PREFIX)/lib/root/$(SOVERS)/cint7 \
+ -X$(PREFIX)/include/root/Minuit2
+ # $(foreach i, \
+diff -Naur root.as-needed/cint/cintex/Module.mk root/cint/cintex/Module.mk
+--- root.as-needed/cint/cintex/Module.mk 2011-07-10 10:42:49.104889217 +0400
++++ root/cint/cintex/Module.mk 2011-07-10 10:43:21.496672876 +0400
+@@ -31,10 +31,6 @@
+ CINTEXPY := $(subst $(MODDIR)/python,$(LPATH),$(CINTEXPYS))
+ $(LPATH)/%.py: $(MODDIR)/python/%.py; cp $< $@
+ endif
+-ifneq ($(BUILDPYTHON),no)
+-CINTEXPYC := $(CINTEXPY:.py=.pyc)
+-CINTEXPYO := $(CINTEXPY:.py=.pyo)
+-endif
+
+ # used in the main Makefile
+ ALLHDRS += $(patsubst $(MODDIRI)/Cintex/%.h,include/Cintex/%.h,$(CINTEXH))
+@@ -86,8 +82,6 @@
+ fi)
+ cp $< $@
+
+-%.pyc: %.py; python -c 'import py_compile; py_compile.compile( "$<" )'
+-%.pyo: %.py; python -O -c 'import py_compile; py_compile.compile( "$<" )'
+
+ $(CINTEXLIB): $(CINTEXO) $(CINTEXPY) $(CINTEXPYC) $(CINTEXPYO) \
+ $(ORDER_) $(subst $(CINTEXLIB),,$(MAINLIBS)) $(CINTEXLIBDEP)
+diff -Naur root.as-needed/cint/reflex/Module.mk root/cint/reflex/Module.mk
+--- root.as-needed/cint/reflex/Module.mk 2011-07-10 10:42:49.074890651 +0400
++++ root/cint/reflex/Module.mk 2011-07-10 10:43:21.496672876 +0400
+@@ -48,9 +48,6 @@
+ RFLX_GRFLXS := $(wildcard $(RFLX_GRFLXSD)/*.py)
+ RFLX_GRFLXPY := $(patsubst $(RFLX_GRFLXSD)/%.py,$(RFLX_GRFLXDD)/%.py,$(RFLX_GRFLXS))
+ RFLX_GRFLXPY += $(RFLX_GCCXMLPATHPY)
+-ifneq ($(BUILDPYTHON),no)
+-RFLX_GRFLXPYC := $(subst .py,.pyc,$(RFLX_GRFLXPY))
+-endif
+
+ RFLX_LIBDIR = $(LIBDIR)
+
+@@ -92,7 +89,7 @@
+
+ ALLEXECS += $(RFLX_GENMAPX)
+
+-POSTBIN += $(RFLX_GRFLXPYC) $(RFLX_GRFLXPY)
++POSTBIN += $(RFLX_GRFLXPY)
+
+ ##### local rules #####
+ .PHONY: all-$(MODNAME) clean-$(MODNAME) distclean-$(MODNAME) \
+@@ -122,8 +119,6 @@
+ mkdir -p lib/python/genreflex; fi )
+ cp $< $@
+
+-$(RFLX_GRFLXDD)/%.pyc: $(RFLX_GRFLXDD)/%.py
+- @python -c 'import py_compile; py_compile.compile( "$<" )'
+
+ $(RFLX_GENMAPO) : CXXFLAGS += -I$(REFLEXDIRS)/genmap
+
+@@ -149,7 +144,7 @@
+ $(RLIBMAP) -o $@ -l $(REFLEXDICTLIB) \
+ -d $(REFLEXDICTLIBDEPM) -c $(REFLEXL)
+
+-all-$(MODNAME): $(REFLEXLIB) $(REFLEXDICTLIB) $(REFLEXDICTMAP) $(RFLX_GRFLXPYC) $(RFLX_GRFLXPY)
++all-$(MODNAME): $(REFLEXLIB) $(REFLEXDICTLIB) $(REFLEXDICTMAP) $(RFLX_GRFLXPY)
+
+ clean-genreflex:
+ @rm -rf lib/python/genreflex
+diff -Naur root.as-needed/cint/reflex/python/CMakeLists.txt root/cint/reflex/python/CMakeLists.txt
+--- root.as-needed/cint/reflex/python/CMakeLists.txt 2011-07-10 10:42:49.074890651 +0400
++++ root/cint/reflex/python/CMakeLists.txt 2011-07-10 10:43:21.496672876 +0400
+@@ -15,7 +15,7 @@
+ ##################### sources ####################
+
+ FILE(GLOB_RECURSE GENREFLEX_SRCS RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} genreflex/*.py)
+-SET(GENREFLEX_SCRIPT ${CMAKE_CURRENT_BINARY_DIR}/genreflex/genreflex.pyc PARENT_SCOPE)
++SET(GENREFLEX_SCRIPT PARENT_SCOPE)
+
+ ##################### gccxmlpath ####################
+
diff --git a/sci-physics/root/files/root-5.34.13-unuran.patch b/sci-physics/root/files/root-5.34.13-unuran.patch
new file mode 100644
index 000000000000..8262313184b5
--- /dev/null
+++ b/sci-physics/root/files/root-5.34.13-unuran.patch
@@ -0,0 +1,40 @@
+diff --git a/math/unuran/Module.mk b/math/unuran/Module.mk
+index 00a530b..7cd22dc 100644
+--- a/math/unuran/Module.mk
++++ b/math/unuran/Module.mk
+@@ -31,7 +31,7 @@ UNRS := $(wildcard $(UNRDIRS)/src/utils/*.c) \
+ $(wildcard $(UNRDIRS)/src/uniform/*.c) \
+ $(wildcard $(UNRDIRS)/src/urng/*.c)
+ else
+-UNRTARCONTENT:=$(subst $(UNRVERS),$(UNRDIRS),$(shell mkdir -p $(UNRDIR); cd $(UNRDIR); gunzip -c $(UNRSRCS) | tar tf -))
++UNRTARCONTENT:=
+ UNRS := $(filter %.c, \
+ $(filter $(UNRDIRS)/src/utils/%,$(UNRTARCONTENT)) \
+ $(filter $(UNRDIRS)/src/methods/%,$(UNRTARCONTENT)) \
+@@ -81,10 +81,9 @@ INCLUDEFILES += $(UNURANDEP)
+ ##### local rules #####
+ .PHONY: all-$(MODNAME) clean-$(MODNAME) distclean-$(MODNAME)
+
+-include/%.h: $(UNURANDIRI)/%.h $(UNURANETAG)
++include/%.h: $(UNURANDIRI)/%.h
+ cp $< $@
+
+-$(UNURANDEP): $(UNRCFG)
+ $(UNRS): $(UNURANETAG)
+
+ $(UNURANETAG): $(UNRSRCS)
+@@ -137,12 +136,12 @@ $(UNRCFG): $(UNURANETAG)
+ GNUMAKE=$(MAKE) ./configure CC="$$ACC" \
+ CFLAGS="$$ACFLAGS");
+
+-$(UNURANLIB): $(UNRCFG) $(UNRO) $(UNURANO) $(UNURANDO) $(ORDER_) \
++$(UNURANLIB): $(UNURANO) $(UNURANDO) $(ORDER_) \
+ $(MAINLIBS) $(UNURANLIBDEP)
+ @$(MAKELIB) $(PLATFORM) $(LD) "$(LDFLAGS)" \
+ "$(SOFLAGS)" libUnuran.$(SOEXT) $@ \
+ "$(UNURANO) $(UNURANDO)" \
+- "$(UNURANLIBEXTRA) $(UNRO)"
++ "$(UNURANLIBEXTRA) -lunuran"
+
+ $(UNURANDS): $(UNRINIT) $(UNURANDH1) $(UNURANL) $(ROOTCINTTMPDEP)
+ $(MAKEDIR)
diff --git a/sci-physics/root/files/root-5.34.26-ldflags.patch b/sci-physics/root/files/root-5.34.26-ldflags.patch
new file mode 100644
index 000000000000..b81dbb5edb00
--- /dev/null
+++ b/sci-physics/root/files/root-5.34.26-ldflags.patch
@@ -0,0 +1,19 @@
+commit 3c8bc686abf57e7e2037c4c191cb63a1a5172b5b
+Author: Andrew Savchenko <bircoph@gmail.com>
+Date: Sun Feb 22 03:45:21 2015 +0300
+
+ root-5.32.00-prop-flags.patch -> root-5.34.26-prop-flags.patch
+
+diff --git a/config/Makefile.in b/config/Makefile.in
+index 89674e7..91d25b9 100644
+--- a/config/Makefile.in
++++ b/config/Makefile.in
+@@ -29,7 +29,7 @@ EXTRA_CFLAGS := -Iinclude @cflags@
+ USERCONF_CFLAGS:= @usercflags@
+ EXTRA_CXXFLAGS := -Iinclude @cflags@
+ USERCONF_CXXFLAGS:= @usercxxflags@
+-EXTRA_LDFLAGS := @ldflags@
++EXTRA_LDFLAGS := @ldflags@ $(LDFLAGS)
+ WERROR := @werror@
+ WINRTDEBUG := @winrtdebug@
+
diff --git a/sci-physics/root/files/root-6.00.01-dotfont.patch b/sci-physics/root/files/root-6.00.01-dotfont.patch
new file mode 100644
index 000000000000..6c765f75a505
--- /dev/null
+++ b/sci-physics/root/files/root-6.00.01-dotfont.patch
@@ -0,0 +1,58 @@
+--- root/html/src/TClassDocOutput.cxx.orig 2012-06-08 02:13:51.000000000 +0400
++++ root/html/src/TClassDocOutput.cxx 2012-06-08 02:34:45.705436577 +0400
+@@ -625,7 +625,7 @@
+ << "size=\"8,10\";" << std::endl
+ << "ratio=auto;" << std::endl
+ << "margin=0;" << std::endl
+- << "node [shape=plaintext,fontsize=40,width=4,height=0.75];" << std::endl
++ << "node [shape=plaintext,fontsize=40,width=4,height=0.75,fontname=\"DejaVu Serif\"];" << std::endl
+ << "\"" << fCurrentClass->GetName() << "\" [shape=ellipse];" << std::endl;
+
+ std::stringstream ssDep;
+@@ -704,7 +704,7 @@
+ outdot << ";" << std::endl;
+ } else if (writeAndMoreFor) {
+ outdot << " \"...andmore" << writeAndMoreFor->GetName()
+- << "\" [label=\"...and more\",fontname=\"Times-Italic\",fillcolor=lightgrey,style=filled];" << std::endl;
++ << "\" [label=\"...and more\",fontname=\"DejaVu Serif Italic\",fillcolor=lightgrey,style=filled];" << std::endl;
+ }
+ }
+ if (!levelExists) break;
+@@ -733,7 +733,7 @@
+ << "ranksep=0.1;" << std::endl
+ << "nodesep=0;" << std::endl
+ << "margin=0;" << std::endl;
+- outdot << " node [style=filled,width=0.7,height=0.15,fixedsize=true,shape=plaintext,fontsize=10];" << std::endl;
++ outdot << " node [style=filled,width=0.7,height=0.15,fixedsize=true,shape=plaintext,fontsize=10,fontname=\"DejaVu Serif\"];" << std::endl;
+
+ std::stringstream ssDep;
+ const int numColumns = 3;
+@@ -939,7 +939,7 @@
+ << "ranksep=0;" << std::endl
+ << "nodesep=0;" << std::endl
+ << "size=\"8,10\";" << std::endl
+- << "node [fontsize=20,shape=plaintext];" << std::endl;
++ << "node [fontsize=20,shape=plaintext,fontname=\"DejaVu Serif\"];" << std::endl;
+
+ for (std::list<std::string>::iterator iFile = listFilesToParse.begin();
+ iFile != listFilesToParse.end(); ++iFile) {
+@@ -999,7 +999,8 @@
+ << "ranksep=0.7;" << std::endl
+ << "nodesep=0.3;" << std::endl
+ << "size=\"8,8\";" << std::endl
+- << "ratio=compress;" << std::endl;
++ << "ratio=compress;" << std::endl
++ << "node [fontname=\"DejaVu Serif\"];" << std::endl;
+
+ TString libs(fCurrentClass->GetSharedLibs());
+ outdot << "\"All Libraries\" [URL=\"LibraryDependencies.html\",shape=box,rank=max,fillcolor=lightgray,style=filled];" << std::endl;
+@@ -1109,7 +1110,8 @@
+
+ dotout << "digraph G {" << std::endl
+ << "ratio=auto;" << std::endl
+- << "rankdir=RL;" << std::endl;
++ << "rankdir=RL;" << std::endl
++ << "node [fontname=\"DejaVu Serif\"];" << std::endl;
+
+ // loop on all classes
+ TClassDocInfo* cdi = 0;
diff --git a/sci-physics/root/files/root-6.00.01-llvm.patch b/sci-physics/root/files/root-6.00.01-llvm.patch
new file mode 100644
index 000000000000..c6abb353ee64
--- /dev/null
+++ b/sci-physics/root/files/root-6.00.01-llvm.patch
@@ -0,0 +1,13 @@
+diff --git a/interpreter/llvm/src/Makefile.config.in b/interpreter/llvm/src/Makefile.config.in
+index 7633be2..c8756b1 100644
+--- a/interpreter/llvm/src/Makefile.config.in
++++ b/interpreter/llvm/src/Makefile.config.in
+@@ -170,6 +170,8 @@ CXXFLAGS += @CXXFLAGS@
+
+ # Linker flags.
+ LDFLAGS += @LDFLAGS@
++NOUNDEF := -Wl,--no-undefined
++LDFLAGS := $(filter-out $(NOUNDEF),$(LDFLAGS))
+
+ # Path to the library archiver program.
+ AR_PATH = @AR@
diff --git a/sci-physics/root/files/root-6.00.01-nobyte-compile.patch b/sci-physics/root/files/root-6.00.01-nobyte-compile.patch
new file mode 100644
index 000000000000..aa58f20686dc
--- /dev/null
+++ b/sci-physics/root/files/root-6.00.01-nobyte-compile.patch
@@ -0,0 +1,33 @@
+diff -Naur root.as-needed/bindings/pyroot/Module.mk root/bindings/pyroot/Module.mk
+--- root.as-needed/bindings/pyroot/Module.mk 2011-07-10 10:42:48.991561304 +0400
++++ root/bindings/pyroot/Module.mk 2011-07-10 10:43:21.493339703 +0400
+@@ -48,8 +48,6 @@
+ ROOTPY := $(subst $(MODDIR),$(LPATH),$(ROOTPYS))
+ $(LPATH)/%.py: $(MODDIR)/%.py; cp $< $@
+ endif
+-ROOTPYC := $(ROOTPY:.py=.pyc)
+-ROOTPYO := $(ROOTPY:.py=.pyo)
+
+ # used in the main Makefile
+ ALLHDRS += $(patsubst $(MODDIRI)/%.h,include/%.h,$(PYROOTH))
+@@ -68,10 +66,8 @@
+ include/%.h: $(PYROOTDIRI)/%.h
+ cp $< $@
+
+-%.pyc: %.py; python -c 'import py_compile; py_compile.compile( "$<" )'
+-%.pyo: %.py; python -O -c 'import py_compile; py_compile.compile( "$<" )'
+
+-$(PYROOTLIB): $(PYROOTO) $(PYROOTDO) $(ROOTPY) $(ROOTPYC) $(ROOTPYO) \
++$(PYROOTLIB): $(PYROOTO) $(PYROOTDO) $(ROOTPY) \
+ $(ROOTLIBSDEP) $(PYTHONLIBDEP)
+ @$(MAKELIB) $(PLATFORM) $(LD) "$(LDFLAGS)" \
+ "$(SOFLAGS)" libPyROOT.$(SOEXT) $@ \
+@@ -113,7 +109,7 @@
+
+ distclean-$(MODNAME): clean-$(MODNAME)
+ @rm -f $(PYROOTDEP) $(PYROOTDS) $(PYROOTDH) $(PYROOTLIB) \
+- $(ROOTPY) $(ROOTPYC) $(ROOTPYO) $(PYROOTMAP) \
++ $(ROOTPY) $(PYROOTMAP) \
+ $(PYROOTPYD) $(PYTHON64DEP) $(PYTHON64)
+
+ distclean:: distclean-$(MODNAME)
diff --git a/sci-physics/root/files/root-6.02.05-xrootd4.patch b/sci-physics/root/files/root-6.02.05-xrootd4.patch
new file mode 100644
index 000000000000..0b4a4bef0f2e
--- /dev/null
+++ b/sci-physics/root/files/root-6.02.05-xrootd4.patch
@@ -0,0 +1,11 @@
+https://sft.its.cern.ch/jira/browse/ROOT-6998
+--- root-6.02.05/net/netxng/src/TNetXNGFile.cxx.orig 2015-02-09 11:59:47.000000000 +0300
++++ root-6.02.05/net/netxng/src/TNetXNGFile.cxx 2015-04-05 11:32:31.893127758 +0300
+@@ -28,6 +28,7 @@
+ #include <XrdCl/XrdClFile.hh>
+ #include <XrdCl/XrdClXRootDResponses.hh>
+ #include <XrdCl/XrdClDefaultEnv.hh>
++#include <XrdVersion.hh>
+ #include <iostream>
+
+ //------------------------------------------------------------------------------
diff --git a/sci-physics/root/files/root-6.04.06-gsl2.patch b/sci-physics/root/files/root-6.04.06-gsl2.patch
new file mode 100644
index 000000000000..5d9fb102b73c
--- /dev/null
+++ b/sci-physics/root/files/root-6.04.06-gsl2.patch
@@ -0,0 +1,58 @@
+commit ee9964210c56e7c1868618a4434c5340fef38fe4
+Author: Pere Mato <pere.mato@cern.ch>
+Date: Tue Dec 15 11:58:24 2015 +0100
+
+ Fix for ROOT-7776 - Integrate GSL 2.0 in ROOT. Changed the version used when option builtin_gsl=ON to 2.1 (latest production).
+
+diff --git a/cmake/modules/SearchInstalledSoftware.cmake b/cmake/modules/SearchInstalledSoftware.cmake
+index 6f04dad..309a8de 100644
+--- a/cmake/modules/SearchInstalledSoftware.cmake
++++ b/cmake/modules/SearchInstalledSoftware.cmake
+@@ -332,7 +332,7 @@ if(mathmore OR builtin_gsl)
+ endif()
+ endif()
+ else()
+- set(gsl_version 1.15)
++ set(gsl_version 2.1)
+ message(STATUS "Downloading and building GSL version ${gsl_version}")
+ ExternalProject_Add(
+ GSL
+diff --git a/math/mathmore/src/GSLMultiFit.h b/math/mathmore/src/GSLMultiFit.h
+index 1d86da5..5b5a887 100644
+--- a/math/mathmore/src/GSLMultiFit.h
++++ b/math/mathmore/src/GSLMultiFit.h
+@@ -31,6 +31,7 @@
+ #include "gsl/gsl_matrix.h"
+ #include "gsl/gsl_multifit_nlin.h"
+ #include "gsl/gsl_blas.h"
++#include "gsl/gsl_version.h"
+ #include "GSLMultiFitFunctionWrapper.h"
+
+ #include "Math/IFunction.h"
+@@ -143,7 +144,11 @@ public:
+ /// gradient value at the minimum
+ const double * Gradient() const {
+ if (fSolver == 0) return 0;
++#if GSL_MAJOR_VERSION > 1
++ fType->gradient(fSolver->state, fVec);
++#else
+ gsl_multifit_gradient(fSolver->J, fSolver->f,fVec);
++#endif
+ return fVec->data;
+ }
+
+@@ -154,7 +159,14 @@ public:
+ unsigned int npar = fSolver->fdf->p;
+ fCov = gsl_matrix_alloc( npar, npar );
+ static double kEpsrel = 0.0001;
++#if GSL_MAJOR_VERSION > 1
++ gsl_matrix* J = gsl_matrix_alloc(npar,npar);
++ gsl_multifit_fdfsolver_jac (fSolver, J);
++ int ret = gsl_multifit_covar(J, kEpsrel, fCov);
++ gsl_matrix_free(J);
++#else
+ int ret = gsl_multifit_covar(fSolver->J, kEpsrel, fCov);
++#endif
+ if (ret != GSL_SUCCESS) return 0;
+ return fCov->data;
+ }
diff --git a/sci-physics/root/files/root-6.04.06-prop-flags.patch b/sci-physics/root/files/root-6.04.06-prop-flags.patch
new file mode 100644
index 000000000000..90db15e21f6d
--- /dev/null
+++ b/sci-physics/root/files/root-6.04.06-prop-flags.patch
@@ -0,0 +1,22 @@
+ config/Makefile.in | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/config/Makefile.in b/config/Makefile.in
+index 9243c90..a23a4d2 100644
+--- a/config/Makefile.in
++++ b/config/Makefile.in
+@@ -64,11 +64,11 @@ HOST := @host@
+ USECONFIG := @useconfig@
+ MKLIBOPTIONS := @mkliboption@
+
+-EXTRA_CFLAGS := -Iinclude @cflags@
++EXTRA_CFLAGS := -Iinclude @cflags@ $(CFLAGS)
+ USERCONF_CFLAGS:= @usercflags@
+-EXTRA_CXXFLAGS := -Iinclude @cflags@
++EXTRA_CXXFLAGS := -Iinclude @cflags@ $(CXXFLAGS)
+ USERCONF_CXXFLAGS:= @usercxxflags@
+-EXTRA_LDFLAGS := @ldflags@
++EXTRA_LDFLAGS := @ldflags@ $(LDFLAGS)
+ WERROR := @werror@
+ WINRTDEBUG := @winrtdebug@
+ CTORSINITARRAY := @ctorsinitarray@
diff --git a/sci-physics/root/files/rootd.confd b/sci-physics/root/files/rootd.confd
new file mode 100644
index 000000000000..7516b8c9b6dd
--- /dev/null
+++ b/sci-physics/root/files/rootd.confd
@@ -0,0 +1,8 @@
+# conf.d file for root daemon
+
+# User to run as (default is `rootd')
+ROOTD_USER="rootd"
+
+# Please refer to the rootd(1) man(1) page for more information on
+# command line parameters.
+ROOTD_OPTS=""
diff --git a/sci-physics/root/files/rootd.initd b/sci-physics/root/files/rootd.initd
new file mode 100644
index 000000000000..f808259c3670
--- /dev/null
+++ b/sci-physics/root/files/rootd.initd
@@ -0,0 +1,27 @@
+#!/sbin/openrc-run
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+ use logger
+ provide root-file-server
+}
+
+start() {
+ ebegin "Starting ROOT file server"
+ pid=$(start-stop-daemon --start --quiet --user ${ROOTD_USER} \
+ --pidfile /var/run/rootd.pid \
+ --exec /usr/bin/rootd -- ${ROOTD_OPTS})
+ retval=$?
+ echo ${ROOTD_PID} > /var/run/rootd.pid
+ eend ${retval}
+}
+
+stop() {
+ ebegin "Stopping ROOT file server"
+ start-stop-daemon --stop --quiet \
+ --pidfile /var/run/rootd.pid \
+ --exec /usr/bin/rootd
+ eend $?
+}