summaryrefslogtreecommitdiff
path: root/sci-physics/qutip/qutip-4.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /sci-physics/qutip/qutip-4.2.0.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'sci-physics/qutip/qutip-4.2.0.ebuild')
-rw-r--r--sci-physics/qutip/qutip-4.2.0.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/sci-physics/qutip/qutip-4.2.0.ebuild b/sci-physics/qutip/qutip-4.2.0.ebuild
deleted file mode 100644
index 9bbf6fe19d2b..000000000000
--- a/sci-physics/qutip/qutip-4.2.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1 toolchain-funcs
-
-DESCRIPTION="Simulating dynamics of open quantum systems in Python."
-HOMEPAGE="http://qutip.org"
-SRC_URI="https://github.com/qutip/qutip/archive/v$PV.tar.gz -> $P.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="openmp test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/cython[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-python_prepare_all() {
- sed -i setup.py \
- -e 's/_compiler_flags = .*$/_compiler_flags = []/' || die
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- use openmp && mydistutilsargs=( --with-openmp )
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib* || die
- ${EPYTHON} -c "import qutip.testing as qt ; qt.run()" || die
-}