summaryrefslogtreecommitdiff
path: root/sci-physics/qmeq/qmeq-1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-03 05:19:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-03 05:19:36 +0100
commit155cc74ccaea367efa88c8acfadcf25cb7dfe89c (patch)
tree7c071f2c978804bd5ad135f096c2c1849d338b6f /sci-physics/qmeq/qmeq-1.1.ebuild
parentd288197c01703f58dbea0ff4f42b01e7c4c6f327 (diff)
gentoo auto-resync : 03:04:2023 - 05:19:36
Diffstat (limited to 'sci-physics/qmeq/qmeq-1.1.ebuild')
-rw-r--r--sci-physics/qmeq/qmeq-1.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-physics/qmeq/qmeq-1.1.ebuild b/sci-physics/qmeq/qmeq-1.1.ebuild
new file mode 100644
index 000000000000..f46bde1641b7
--- /dev/null
+++ b/sci-physics/qmeq/qmeq-1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2018-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{10,11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Quantum master equation package for Quantum dot transport calculations"
+HOMEPAGE="https://github.com/gedaskir/qmeq"
+SRC_URI="
+ https://github.com/gedaskir/qmeq/archive/refs/tags/${PV}.tar.gz -> ${P}.tgz
+ examples? ( https://github.com/gedaskir/${PN}-examples/archive/1.0.tar.gz -> ${PN}-examples-1.0.tgz )"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ examples? ( dev-python/jupyter[${PYTHON_USEDEP}] )"
+BDEPEND="${DEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+src_install() {
+ distutils-r1_src_install
+ docompress -x "/usr/share/doc/${PF}"
+ use examples && dodoc -r "${WORKDIR}/${PN}-examples-1.0"/.
+}