summaryrefslogtreecommitdiff
path: root/sci-physics/pythia/pythia-6.4.28-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-17 15:32:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-17 15:32:39 +0100
commitc74abf990d32765245eeb94b36ad4af642cae8c0 (patch)
treeb700660e782342b531312e3855b949f5b2fbbc60 /sci-physics/pythia/pythia-6.4.28-r2.ebuild
parent5a21cec0c36dba03507dcbd5e8ab6698d00b39bf (diff)
gentoo auto-resync : 17:08:2023 - 15:32:39
Diffstat (limited to 'sci-physics/pythia/pythia-6.4.28-r2.ebuild')
-rw-r--r--sci-physics/pythia/pythia-6.4.28-r2.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/sci-physics/pythia/pythia-6.4.28-r2.ebuild b/sci-physics/pythia/pythia-6.4.28-r2.ebuild
index 9d17582d521d..01ffdc71dd71 100644
--- a/sci-physics/pythia/pythia-6.4.28-r2.ebuild
+++ b/sci-physics/pythia/pythia-6.4.28-r2.ebuild
@@ -9,6 +9,7 @@ MV=$(ver_cut 1)
MY_PN=${PN}${MV}
DOC_PV=0613
EX_PV=6.4.18
+MY_PV=${PV//./}
PYR_P=pythia6-20160413
DESCRIPTION="Lund Monte Carlo high-energy physics event generator"
@@ -18,10 +19,11 @@ HOMEPAGE="http://pythia6.hepforge.org/"
# To produce a split version, replace the 6.4.x by the current version:
# svn export http://svn.hepforge.org/pythia6/tags/v_6_4_x/ pythia-6.4.x
# tar cJf pythia-6.4.x.tar.xz
+
SRC_URI="
- https://dev.gentoo.org/~bicatali/distfiles/${P}.tar.xz
+ https://pythia.org/download/pythia6/pythia${MY_PV}-split.tgz
https://root.cern.ch/download/pythia6.tar.gz -> ${PYR_P}.tar.gz
- doc? ( http://home.thep.lu.se/~torbjorn/pythia/lutp${DOC_PV}man2.pdf )
+ doc? ( https://pythia.org/download/pythia6/lutp${DOC_PV}man2.pdf )
examples? ( mirror://gentoo/${PN}-${EX_PV}-examples.tar.bz2 )"
SLOT="6"
@@ -31,6 +33,15 @@ IUSE="doc examples"
PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+# workaround to official pythia-split not having a pythia subdir
+src_unpack() {
+ mkdir -p "${S}" || die
+ cd "${S}" || die
+ unpack pythia${MY_PV}-split.tgz
+ cd "${WORKDIR}" || die
+ default
+}
+
src_prepare() {
cp ../pythia6/tpythia6_called_from_cc.F .
cp ../pythia6/pythia6_common_address.c .