summaryrefslogtreecommitdiff
path: root/sci-physics/lightspeed
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-16 16:47:37 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-16 16:47:37 +0100
commit8aebb228036d5e2863b7eaa6e319ab41c1669269 (patch)
tree00f4b90ce32462dc8e99ae54a31d6462ea2c3ac6 /sci-physics/lightspeed
parent76cba73c47c8694e74377004634daca18f2d9c08 (diff)
gentoo resync : 16.04.2018
Diffstat (limited to 'sci-physics/lightspeed')
-rw-r--r--sci-physics/lightspeed/Manifest1
-rw-r--r--sci-physics/lightspeed/lightspeed-1.2a-r3.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/sci-physics/lightspeed/Manifest b/sci-physics/lightspeed/Manifest
index b2948476845e..5e6f20c2c44a 100644
--- a/sci-physics/lightspeed/Manifest
+++ b/sci-physics/lightspeed/Manifest
@@ -5,4 +5,5 @@ DIST lightspeed_1.2a-7.diff.gz 379281 BLAKE2B 1cfae528d58b556cede1a2e8c3087f059c
DIST objects-1.tar.gz 767805 BLAKE2B cde889eae12913bd6c0f9f2c3206c49a2a946e8acef1080c19339dbad6bdd41a52abf108b052b0723cc43926395572eb9bc8ddc6548af06c6de9b5978a8d97b2 SHA512 cb8c2d5c323b92b87dfe2bfa8f7f37c46b381c4611d5ca2f645a16943339b90850615647f6edc21ae28a28792b0f071e8cac9779dbfdbf6bf928498cdd451231
EBUILD lightspeed-1.2a-r1.ebuild 1588 BLAKE2B 4840628cf40f3fb34a2086d00c9483b0d00c6b445522fb3f6494ea2504daccdea9bef77c50a0040e26b867134a6b5a758bd636ce4ee9a871a52a657a922c1221 SHA512 b9dd82e8c3b035c82bc0f5e835118d36de008a61985b27e4de010c0bab089f0f5c397290380f6d005057a897833081a52c27f9f2507f5f8053d8458bf4b3fc65
EBUILD lightspeed-1.2a-r2.ebuild 1524 BLAKE2B 03ad31c3c0c436944882a4dc08a87b9e7a6ce924b61289cf6374811fb503821794aa08094611d0e668271097feb08fbfda9f8d5d58fb930f8f9fe5e9ef0e15a3 SHA512 7e69381fa323b8e0689b749f0f77e720d3034d6de81b91178e543d83cd0e92dd1bdbf13b7272546a4a557fb6673f7ab4e01c8d19f82da58b86dc15fe78e6f909
+EBUILD lightspeed-1.2a-r3.ebuild 1524 BLAKE2B c1722a042ffae225ce22a88fcac9dc201d53bbfe418ef6e4913b80fedf38d50c9cec880b3a1b19c5fb742bb13ab81358e8be6e475accfb032427cee1645d5ab6 SHA512 563f45474a48542a85caaf3e3d0dbc973407907030dc5d16ab07a7ae17959bf740d7f7ecb05358e255fd7b27ddede14823cf4433adbfb2247422f4113b288a4e
MISC metadata.xml 763 BLAKE2B 896c0cda6875b7735977f4261e69e606bcfff6c384e7edddc28b01bb76e923c72dece79540ae5e60867f8954b0cf8c9ad3da4dee1200280c355add8650992422 SHA512 d33c67d677850f7eaf12b4086c66a49940259b5553470a9f3c9ca56279f06a99eec12384e75815e32e7953ac3275ce01e03582d35a9fa3de21e5b3380d02d08f
diff --git a/sci-physics/lightspeed/lightspeed-1.2a-r3.ebuild b/sci-physics/lightspeed/lightspeed-1.2a-r3.ebuild
new file mode 100644
index 000000000000..4f96026b6f0a
--- /dev/null
+++ b/sci-physics/lightspeed/lightspeed-1.2a-r3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools desktop readme.gentoo-r1
+
+DEB_PATCH="${PN}_${PV}-7"
+DESCRIPTION="OpenGL interactive relativistic simulator"
+HOMEPAGE="http://lightspeed.sourceforge.net/"
+SRC_URI="
+ mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://sourceforge/${PN}/objects-1.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${DEB_PATCH}.diff.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
+
+IUSE="nls truetype"
+
+RDEPEND="
+ media-libs/libpng:0=
+ media-libs/tiff:0
+ virtual/opengl
+ x11-libs/gtkglext
+ x11-libs/gtkglarea:2
+ x11-libs/gtk+:2
+ x11-libs/libXmu
+ truetype? ( media-libs/ftgl )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${WORKDIR}/${DEB_PATCH}.diff"
+ "${FILESDIR}"/${P}-autoconf.patch
+ "${FILESDIR}"/${P}-libpng15.patch
+)
+
+DOC_CONTENTS="
+ Some 3d models have been placed in /usr/share/${PN}
+ You can load them in Light Speed! from the File menu.
+"
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-gtk=2 \
+ $(use_enable nls) \
+ $(use_with truetype ftgl)
+}
+
+src_install() {
+ default
+
+ newicon src/icon.xpm lightspeed.xpm
+ make_desktop_entry ${PN} "Light Speed! Relativistic Simulator"
+
+ readme.gentoo_create_doc
+ newdoc debian/changelog ChangeLog.Debian
+ cd "${WORKDIR}/objects" || die
+ newdoc README objects-README
+
+ insinto /usr/share/${PN}
+ doins *.3ds *.lwo
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}