summaryrefslogtreecommitdiff
path: root/sci-physics/herwig++/herwig++-2.7.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sci-physics/herwig++/herwig++-2.7.1-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sci-physics/herwig++/herwig++-2.7.1-r1.ebuild')
-rw-r--r--sci-physics/herwig++/herwig++-2.7.1-r1.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/sci-physics/herwig++/herwig++-2.7.1-r1.ebuild b/sci-physics/herwig++/herwig++-2.7.1-r1.ebuild
deleted file mode 100644
index 33fcc97e82f2..000000000000
--- a/sci-physics/herwig++/herwig++-2.7.1-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-inherit autotools-utils eutils flag-o-matic multilib
-
-MYP=Herwig++-${PV}
-
-DESCRIPTION="High-Energy Physics event generator"
-HOMEPAGE="http://herwig.hepforge.org/"
-SRC_URI="http://www.hepforge.org/archive/herwig/${MYP}.tar.bz2"
-
-SLOT="0/15"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="c++11 fastjet static-libs"
-
-# >sci-physics/looptools-2.8 leads to misoperation
-# and failing tests (it lacks some symbols)
-RDEPEND="
- dev-libs/boost:0=
- sci-libs/gsl:0=
- <=sci-physics/looptools-2.8:0=
- ~sci-physics/thepeg-1.9.2:0=
- fastjet? ( sci-physics/fastjet:0= )"
-DEPEND="${RDEPEND}
- >=sys-devel/boost-m4-0.4_p20160328"
-
-S="${WORKDIR}/${MYP}"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-2.6.3-looptools.patch \
- "${FILESDIR}"/${PN}-2.7.1-fix-boost-1.67.patch
- # fixes bug 570458, which is due to an outdated bundled boost.m4
- rm m4/boost.m4 || die
- find -name 'Makefile.am' -exec \
- sed -i -e '1ipkgdatadir=$(datadir)/herwig++' {} \; || die
- autotools-utils_src_prepare
-}
-
-src_configure() {
- use prefix && \
- append-ldflags -Wl,-rpath,"${EPREFIX}"/usr/$(get_libdir)/ThePEG
- local myeconfargs=(
- --with-boost="${EPREFIX}"/usr
- --with-thepeg="${EPREFIX}"/usr
- $(use_enable c++11 stdcxx11)
- $(use_with fastjet fastjet "${EPREFIX}"/usr)
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
- sed -i -e "s|${ED}||g" "${ED}"/usr/share/herwig++/defaults/PDF.in || die
- sed -i -e "s|${ED}||g" "${ED}"/usr/share/herwig++/HerwigDefaults.rpo || die
-}