summaryrefslogtreecommitdiff
path: root/sci-physics/h2o-gtk/h2o-gtk-0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-17 22:49:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-17 22:49:47 +0100
commit30c53e395853f5bfe805a1e429fcf26666eed8f8 (patch)
treea0670eaf9babda7b83503f7d36806a944bb49752 /sci-physics/h2o-gtk/h2o-gtk-0.1-r1.ebuild
parentd302a5d7fc9caafba5c8a404f2891bb6ccdec311 (diff)
gentoo resync : 17.05.2018
Diffstat (limited to 'sci-physics/h2o-gtk/h2o-gtk-0.1-r1.ebuild')
-rw-r--r--sci-physics/h2o-gtk/h2o-gtk-0.1-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sci-physics/h2o-gtk/h2o-gtk-0.1-r1.ebuild b/sci-physics/h2o-gtk/h2o-gtk-0.1-r1.ebuild
new file mode 100644
index 000000000000..ec3885a327dc
--- /dev/null
+++ b/sci-physics/h2o-gtk/h2o-gtk-0.1-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="GTK+ UI for libh2o -- water & steam properties"
+HOMEPAGE="https://github.com/mgorny/h2o-gtk/"
+SRC_URI="https://github.com/mgorny/h2o-gtk/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-cpp/gtkmm:2.4=
+ sci-libs/libh2oxx:0=
+ sci-libs/plotmm:0="
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local -x CXXFLAGS="${CXXFLAGS} -std=c++11"
+ default
+}