summaryrefslogtreecommitdiff
path: root/sci-physics/geant/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-physics/geant/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-physics/geant/files')
-rw-r--r--sci-physics/geant/files/geant-4.10.0-TrackingNavigator.patch60
-rw-r--r--sci-physics/geant/files/geant-4.10.0-no-examples.patch22
-rw-r--r--sci-physics/geant/files/geant-4.10.02-std-isnan.patch17
-rw-r--r--sci-physics/geant/files/geant-4.10.2-no-examples.patch18
-rw-r--r--sci-physics/geant/files/geant-4.9.4-zlib.patch35
5 files changed, 152 insertions, 0 deletions
diff --git a/sci-physics/geant/files/geant-4.10.0-TrackingNavigator.patch b/sci-physics/geant/files/geant-4.10.0-TrackingNavigator.patch
new file mode 100644
index 000000000000..e3cc8d6594a5
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.10.0-TrackingNavigator.patch
@@ -0,0 +1,60 @@
+accepted upstream. to be removed in the next minor release.
+
+https://bugs.gentoo.org/show_bug.cgi?id=496678
+http://bugzilla-geant4.kek.jp/show_bug.cgi?id=1537
+
+diff -Naur geant4.10.00/source/geometry/navigation/include/G4TransportationManager.hh geant4.10.00-mod/source/geometry/navigation/include/G4TransportationManager.hh
+--- geant4.10.00/source/geometry/navigation/include/G4TransportationManager.hh 2013-12-05 10:28:54.000000000 +0100
++++ geant4.10.00-mod/source/geometry/navigation/include/G4TransportationManager.hh 2013-12-12 01:40:12.341428809 +0100
+@@ -68,7 +68,7 @@
+ // Accessors for field handling
+
+ inline G4Navigator* GetNavigatorForTracking() const;
+- inline void SetNavigatorForTracking( G4Navigator* newNavigator );
++ void SetNavigatorForTracking( G4Navigator* newNavigator );
+ // Accessors for the navigator for tracking
+
+ inline void SetWorldForTracking(G4VPhysicalVolume* theWorld);
+diff -Naur geant4.10.00/source/geometry/navigation/include/G4TransportationManager.icc geant4.10.00-mod/source/geometry/navigation/include/G4TransportationManager.icc
+--- geant4.10.00/source/geometry/navigation/include/G4TransportationManager.icc 2013-12-05 10:28:54.000000000 +0100
++++ geant4.10.00-mod/source/geometry/navigation/include/G4TransportationManager.icc 2013-12-12 01:40:12.341428809 +0100
+@@ -59,6 +59,7 @@
+ fNavigators[0]->SetWorldVolume(theWorld);
+ }
+
++/*
+ // ----------------------------------------------------------------------------
+ // SetNavigatorForTracking()
+ //
+@@ -70,6 +71,7 @@
+ {
+ fNavigators[0] = newNavigator;
+ }
++*/
+
+ // ----------------------------------------------------------------------------
+ // GetPropagatorInField()
+diff -Naur geant4.10.00/source/geometry/navigation/src/G4TransportationManager.cc geant4.10.00-mod/source/geometry/navigation/src/G4TransportationManager.cc
+--- geant4.10.00/source/geometry/navigation/src/G4TransportationManager.cc 2013-12-05 10:28:56.000000000 +0100
++++ geant4.10.00-mod/source/geometry/navigation/src/G4TransportationManager.cc 2013-12-12 01:40:12.345428679 +0100
+@@ -124,6 +124,20 @@
+ }
+ }
+
++
++// ----------------------------------------------------------------------------
++// SetNavigatorForTracking()
++//
++// Set the active navigator for tracking, always
++// the first in the collection of registered navigators.
++//
++void G4TransportationManager::SetNavigatorForTracking(G4Navigator* newNavigator)
++{
++ fNavigators[0] = newNavigator;
++ fActiveNavigators[0] = newNavigator;
++ fPropagatorInField->SetNavigatorForPropagating(newNavigator);
++}
++
+ // ----------------------------------------------------------------------------
+ // ClearNavigators()
+ //
diff --git a/sci-physics/geant/files/geant-4.10.0-no-examples.patch b/sci-physics/geant/files/geant-4.10.0-no-examples.patch
new file mode 100644
index 000000000000..99aaca546f49
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.10.0-no-examples.patch
@@ -0,0 +1,22 @@
+do not install examples automatically, we do this explictly with dodoc.
+
+Index: geant4.10.00/CMakeLists.txt
+===================================================================
+--- geant4.10.00.orig/CMakeLists.txt
++++ geant4.10.00/CMakeLists.txt
+@@ -136,15 +136,6 @@ if(GEANT4_BUILD_EXAMPLES)
+ add_subdirectory(examples)
+ endif()
+
+-# - Install example code to datarootdir
+-install(DIRECTORY examples
+- DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/Geant4-${Geant4_VERSION}
+- COMPONENT Examples
+- PATTERN "CVS" EXCLUDE
+- PATTERN ".svn" EXCLUDE
+- )
+-
+-
+ #-----------------------------------------------------------------------------
+ # Provide packaging with CPack.
+ include(Geant4CPackBase)
diff --git a/sci-physics/geant/files/geant-4.10.02-std-isnan.patch b/sci-physics/geant/files/geant-4.10.02-std-isnan.patch
new file mode 100644
index 000000000000..6d26a6c2c0d0
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.10.02-std-isnan.patch
@@ -0,0 +1,17 @@
+Fully qualify isnan:
+* /var/tmp/portage/sci-physics/geant-4.10.02/work/geant4.10.02/source/processes/hadronic/models/lend/src/nf_utilities.cc:61:22: error: ‘isnan’ was not declared in this scope
+* return( isnan( d ) );
+See also:
+https://bugs.gentoo.org/show_bug.cgi?id=581322
+
+--- geant4.10.02/source/processes/hadronic/models/lend/src/nf_utilities.cc
++++ geant4.10.02/source/processes/hadronic/models/lend/src/nf_utilities.cc
+@@ -58,7 +58,7 @@
+ */
+ int nfu_isNAN( double d ) {
+
+- return( isnan( d ) );
++ return( std::isnan( d ) );
+ }
+ /*
+ ************************************************************
diff --git a/sci-physics/geant/files/geant-4.10.2-no-examples.patch b/sci-physics/geant/files/geant-4.10.2-no-examples.patch
new file mode 100644
index 000000000000..767547896c99
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.10.2-no-examples.patch
@@ -0,0 +1,18 @@
+diff -ur geant4.10.02.orig/CMakeLists.txt geant4.10.02/CMakeLists.txt
+--- geant4.10.02.orig/CMakeLists.txt 2016-01-13 15:00:07.009259839 -0200
++++ geant4.10.02/CMakeLists.txt 2016-01-13 15:01:00.369257669 -0200
+@@ -134,14 +134,6 @@
+ add_subdirectory(examples)
+ endif()
+
+-# - Install example code to datarootdir
+-install(DIRECTORY examples
+- DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/Geant4-${Geant4_VERSION}
+- COMPONENT Examples
+- PATTERN "CVS" EXCLUDE
+- PATTERN ".svn" EXCLUDE
+- )
+-
+ #-----------------------------------------------------------------------
+ # - CPack-aging
+ include(Geant4CPackBase)
diff --git a/sci-physics/geant/files/geant-4.9.4-zlib.patch b/sci-physics/geant/files/geant-4.9.4-zlib.patch
new file mode 100644
index 000000000000..f0429695ce38
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.9.4-zlib.patch
@@ -0,0 +1,35 @@
+force use of system zlib instead of bundled G4zlib
+--- source/visualization/HepRep/sources.cmake.orig 2011-12-02 15:07:49.000000000 +0000
++++ source/visualization/HepRep/sources.cmake 2011-12-18 06:21:22.000000000 +0000
+@@ -91,7 +91,7 @@
+ G4specsolids
+ G4tracking
+ G4vis_management
+- G4zlib
++ ${ZLIB_LIBRARIES}
+ GLOBAL_DEPENDENCIES
+ G4digits_hits
+ G4geometry
+@@ -102,7 +102,7 @@
+ G4modeling
+ G4tracking
+ G4vis_management
+- G4zlib
++ ${ZLIB_LIBRARIES}
+ LINK_LIBRARIES
+ )
+
+--- source/visualization/externals/gl2ps/sources.cmake.orig 2011-12-02 16:07:56.000000000 +0100
++++ source/visualization/externals/gl2ps/sources.cmake 2012-03-09 14:09:26.965148002 +0100
+@@ -49,9 +49,9 @@
+ G4OpenGL2PSAction.cc
+ gl2ps.cc
+ GRANULAR_DEPENDENCIES
+- G4zlib
++ ${ZLIB_LIBRARIES}
+ GLOBAL_DEPENDENCIES
+- G4zlib
++ ${ZLIB_LIBRARIES}
+ LINK_LIBRARIES
+ ${OPENGL_LIBRARIES}
+ )