summaryrefslogtreecommitdiff
path: root/sci-physics/geant-vmc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-03 20:56:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-03 20:56:28 +0100
commitfbda87924e6faa7a1919f1a2b4182490bde5ec5c (patch)
treef3114a4ed212a754756adce027aeef3a4a1a2e2a /sci-physics/geant-vmc
parent3b08f674e3f771b49370edb144dab0958c8cf721 (diff)
gentoo resync : 03.09.2021
Diffstat (limited to 'sci-physics/geant-vmc')
-rw-r--r--sci-physics/geant-vmc/Manifest4
-rw-r--r--sci-physics/geant-vmc/geant-vmc-4.5.3-r1.ebuild82
-rw-r--r--sci-physics/geant-vmc/geant-vmc-9999.ebuild82
-rw-r--r--sci-physics/geant-vmc/metadata.xml25
4 files changed, 0 insertions, 193 deletions
diff --git a/sci-physics/geant-vmc/Manifest b/sci-physics/geant-vmc/Manifest
deleted file mode 100644
index 15b5ef95cf5a..000000000000
--- a/sci-physics/geant-vmc/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-DIST geant-vmc-4.5.3.tar.gz 7411643 BLAKE2B 31a486aa32f879093753aab09798eabf1a936f0aa246bb97c7f055eefb789c9c5a5097c14ce47b05a99f3cc2b46bea6edeba2af80ee362bb8fee039ee711eddc SHA512 918ce3ca4a4fb329f00000fce00dae3d4a4c9f348553f31bf474f727c1e67242b5ff28fe7dc5d3ab12d1174663b1dd96b654b5baf7edfa662ab3f66687792e94
-EBUILD geant-vmc-4.5.3-r1.ebuild 1874 BLAKE2B fa0e232458dfc7d59af9f7a62c2942ae22a03fa147ea14f8a8900e13312774f5388bee1628aaa286679fada73cdde19e73d712f6c44e26fb9a12cadb8d187885 SHA512 e7457e29a2e926f047cb93f8482b9cbb8c57eee6b62639ee274ba4f0aad373ab23ede717c10b1a73335c04e43b6d64d6c8213cdee5dd2ead284b7c9c43a0c0ab
-EBUILD geant-vmc-9999.ebuild 1868 BLAKE2B 5246269e28aa9b3d095d903c7631e2a8be66d29690f6c870ae613dc234b019ee9bce43fa595eb2a28c41ddef53069e76657ca6a2256954d58c6c34681fced575 SHA512 8633771142324a02ed12f26debadb4c16c8d3004358777d78fa64e14f5100b04e84b456f1f73cb452a23386536f96f498585a926295c410156f6bd846a514eb9
-MISC metadata.xml 1005 BLAKE2B d370c3503ad6ba194476ba98fa6991db2ff0ab6bb9f64bc5a23836a9051cc9bd2376421cb383073ac0901e6c3edc34e7ab3b1fa4316869862b7d0fe24dccf8a1 SHA512 a593301917edd0de886bb966ef5d9802d306827cc4fbe0f5507f1a67fcff68ec504237827ecaa194ebb7f2232aba311a9f8a6773b8225355bf8ea36c2d7324a5
diff --git a/sci-physics/geant-vmc/geant-vmc-4.5.3-r1.ebuild b/sci-physics/geant-vmc/geant-vmc-4.5.3-r1.ebuild
deleted file mode 100644
index cafdbf75e099..000000000000
--- a/sci-physics/geant-vmc/geant-vmc-4.5.3-r1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/vmc-project/geant4_vmc.git"
-else
- MY_PV=$(ver_rs 1-2 - $(ver_cut 2-))
- SRC_URI="https://github.com/vmc-project/geant4_vmc/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/geant4_vmc-${MY_PV}"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="Virtual Monte Carlo Geant4 implementation"
-HOMEPAGE="https://github.com/vmc-project/geant4_vmc"
-
-LICENSE="GPL-3"
-SLOT="4"
-IUSE="doc examples geant3 +g4root +mtroot vgm test"
-
-RDEPEND="
- <sci-physics/geant-4.11[c++17,opengl,geant3?]
- sci-physics/root:=[c++17,-vmc]
- sci-physics/vmc:=[c++17]
- vgm? ( sci-physics/vgm:= )"
-DEPEND="${RDEPEND}"
-BDEPEND="doc? ( app-doc/doxygen )"
-RESTRICT="
- !examples? ( test )
- !geant3? ( test )
- !g4root? ( test )
- !mtroot? ( test )
- !test? ( test )
- !vgm? ( test )"
-
-DOCS=(history README.md)
-
-src_configure() {
- local mycmakeargs=(
- -DGeant4VMC_USE_VGM="$(usex vgm)"
- -DGeant4VMC_USE_GEANT4_G3TOG4="$(usex geant3)"
- -DGeant4VMC_USE_G4Root="$(usex g4root)"
- -DGeant4VMC_BUILD_MTRoot="$(usex mtroot)"
- -DGeant4VMC_BUILD_EXAMPLES="$(usex test)"
- -DGeant4VMC_INSTALL_EXAMPLES="$(usex examples)"
- )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- if use doc ; then
- local dirs=(
- source
- $(usev g4root)
- $(usev mtroot)
- $(usev examples)
- )
- local d
- for d in "${dirs[@]}"; do
- pushd "${d}" > /dev/null || die
- doxygen || die
- popd > /dev/null || die
- done
- fi
-}
-
-src_test() {
- cd examples || die
- ./test_suite.sh --debug --g3=off --garfield=off --builddir="${BUILD_DIR}" || die
- ./test_suite_exe.sh --g3=off --garfield=off --garfield=off --builddir="${BUILD_DIR}" || die
-}
-
-src_install() {
- cmake_src_install
- use doc && local HTML_DOCS=(doc/.)
- einstalldocs
-}
diff --git a/sci-physics/geant-vmc/geant-vmc-9999.ebuild b/sci-physics/geant-vmc/geant-vmc-9999.ebuild
deleted file mode 100644
index b22fc0afcbf8..000000000000
--- a/sci-physics/geant-vmc/geant-vmc-9999.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/vmc-project/geant4_vmc.git"
-else
- MY_PV=$(ver_rs 1-2 - $(ver_cut 2-))
- SRC_URI="https://github.com/vmc-project/geant4_vmc/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/geant4_vmc-${MY_PV}"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="Virtual Monte Carlo Geant4 implementation"
-HOMEPAGE="https://github.com/vmc-project/geant4_vmc"
-
-LICENSE="GPL-3"
-SLOT="4"
-IUSE="doc examples geant3 +g4root +mtroot vgm test"
-
-RDEPEND="
- sci-physics/geant[c++17,opengl,geant3?]
- sci-physics/root:=[c++17,-vmc]
- sci-physics/vmc:=[c++17]
- vgm? ( sci-physics/vgm:= )"
-DEPEND="${RDEPEND}"
-BDEPEND="doc? ( app-doc/doxygen )"
-RESTRICT="
- !examples? ( test )
- !geant3? ( test )
- !g4root? ( test )
- !mtroot? ( test )
- !test? ( test )
- !vgm? ( test )"
-
-DOCS=(history README.md)
-
-src_configure() {
- local mycmakeargs=(
- -DGeant4VMC_USE_VGM="$(usex vgm)"
- -DGeant4VMC_USE_GEANT4_G3TOG4="$(usex geant3)"
- -DGeant4VMC_USE_G4Root="$(usex g4root)"
- -DGeant4VMC_BUILD_MTRoot="$(usex mtroot)"
- -DGeant4VMC_BUILD_EXAMPLES="$(usex test)"
- -DGeant4VMC_INSTALL_EXAMPLES="$(usex examples)"
- )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- if use doc ; then
- local dirs=(
- source
- $(usev g4root)
- $(usev mtroot)
- $(usev examples)
- )
- local d
- for d in "${dirs[@]}"; do
- pushd "${d}" > /dev/null || die
- doxygen || die
- popd > /dev/null || die
- done
- fi
-}
-
-src_test() {
- cd examples || die
- ./test_suite.sh --debug --g3=off --garfield=off --builddir="${BUILD_DIR}" || die
- ./test_suite_exe.sh --g3=off --garfield=off --garfield=off --builddir="${BUILD_DIR}" || die
-}
-
-src_install() {
- cmake_src_install
- use doc && local HTML_DOCS=(doc/.)
- einstalldocs
-}
diff --git a/sci-physics/geant-vmc/metadata.xml b/sci-physics/geant-vmc/metadata.xml
deleted file mode 100644
index 7fc023bcb29a..000000000000
--- a/sci-physics/geant-vmc/metadata.xml
+++ /dev/null
@@ -1,25 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person" proxied="yes">
- <email>o.freyermuth@googlemail.com</email>
- <name>Oliver Freyermuth</name>
- </maintainer>
- <maintainer type="person">
- <email>amadio@gentoo.org</email>
- <name>Guilherme Amadio</name>
- </maintainer>
- <maintainer type="project" proxied="proxy">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
- <upstream>
- <remote-id type="github">vmc-project/geant4_vmc</remote-id>
- </upstream>
- <use>
- <flag name="vgm">Enable the Virtual Geometry Model (<pkg>sci-physics/vgm</pkg>)</flag>
- <flag name="g4root">Build G4Root (interface for GEANT4 simulation with a ROOT geometry)</flag>
- <flag name="geant3">Build with Geant4 G3toG4 library</flag>
- <flag name="mtroot">Build MTRoot (provides ROOT IO manager classes with multi-threading support)</flag>
- </use>
-</pkgmetadata>