summaryrefslogtreecommitdiff
path: root/sci-physics/fastjet/fastjet-3.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-22 14:46:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-22 14:46:57 +0100
commit614dee2f9d146b148d9c54dd480e7df81ba2f3a7 (patch)
tree43d363dcd2170608ea58bd156435bf2d29daa66c /sci-physics/fastjet/fastjet-3.4.0.ebuild
parent593b66fb6ac6aa53bd2016d7409fc12a22a10214 (diff)
gentoo auto-resync : 22:07:2022 - 14:46:57
Diffstat (limited to 'sci-physics/fastjet/fastjet-3.4.0.ebuild')
-rw-r--r--sci-physics/fastjet/fastjet-3.4.0.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/sci-physics/fastjet/fastjet-3.4.0.ebuild b/sci-physics/fastjet/fastjet-3.4.0.ebuild
new file mode 100644
index 000000000000..f114cdf358f0
--- /dev/null
+++ b/sci-physics/fastjet/fastjet-3.4.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+FORTRAN_NEEDED=plugins
+PYTHON_COMPAT=( python3_{8..11} )
+DOCS_BUILDER="doxygen"
+DOCS_DEPEND="
+ media-gfx/graphviz
+ media-libs/freetype
+"
+
+inherit autotools docs flag-o-matic fortran-2 python-single-r1
+
+DESCRIPTION="A software package for jet finding in pp and e+e- collisions"
+HOMEPAGE="https://fastjet.fr/"
+SRC_URI="https://fastjet.fr/repo/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="cgal examples python +plugins"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ cgal? ( <sci-mathematics/cgal-5.3:=[shared(+)] )
+ plugins? ( sci-physics/siscone:= )
+ python? ( ${PYTHON_DEPS} )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/fortran"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-system-siscone.patch
+ "${FILESDIR}"/${P}-gfortran.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ use cgal && \
+ has_version 'sci-mathematics/cgal[gmp]' && append-libs -lgmp
+
+ econf \
+ $(use_enable cgal) \
+ $(use_enable plugins allplugins) \
+ $(use_enable plugins allcxxplugins) \
+ --enable-shared \
+ --enable-static=no \
+ --disable-static \
+ --disable-auto-ptr \
+ $(use_enable python pyext)
+}
+
+src_compile() {
+ default
+ docs_compile
+}
+
+src_install() {
+ default
+ if use examples; then
+ emake -C example maintainer-clean
+ find example -iname 'makefile*' -delete || die
+
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ find "${ED}" -name '*.la' -delete || die
+}