summaryrefslogtreecommitdiff
path: root/sci-physics/fastjet/fastjet-3.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-19 19:49:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-19 19:49:08 +0000
commitf287ecad888abdeb38e617d0485de282cd6819db (patch)
tree874d56500040734c4dbb9e437e0d5ed80a0a1886 /sci-physics/fastjet/fastjet-3.4.0.ebuild
parent844ae757702c53a56ee57056873a8204d256d47e (diff)
gentoo auto-resync : 19:12:2022 - 19:49:08
Diffstat (limited to 'sci-physics/fastjet/fastjet-3.4.0.ebuild')
-rw-r--r--sci-physics/fastjet/fastjet-3.4.0.ebuild76
1 files changed, 0 insertions, 76 deletions
diff --git a/sci-physics/fastjet/fastjet-3.4.0.ebuild b/sci-physics/fastjet/fastjet-3.4.0.ebuild
deleted file mode 100644
index a190b2a60f8f..000000000000
--- a/sci-physics/fastjet/fastjet-3.4.0.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-FORTRAN_NEEDED=plugins
-PYTHON_COMPAT=( python3_{8..11} )
-DOCS_BUILDER="doxygen"
-DOCS_DEPEND="
- media-gfx/graphviz
- media-libs/freetype
- virtual/latex-base
-"
-
-inherit autotools docs flag-o-matic fortran-2 python-single-r1
-
-DESCRIPTION="A software package for jet finding in pp and e+e- collisions"
-HOMEPAGE="https://fastjet.fr/"
-SRC_URI="https://fastjet.fr/repo/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="cgal examples python +plugins"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="
- cgal? ( <sci-mathematics/cgal-5.3:=[shared(+)] )
- plugins? ( sci-physics/siscone:= )
- python? ( ${PYTHON_DEPS} )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="virtual/fortran"
-
-PATCHES=(
- "${FILESDIR}"/${P}-system-siscone.patch
- "${FILESDIR}"/${P}-gfortran.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- use cgal && \
- has_version 'sci-mathematics/cgal[gmp]' && append-libs -lgmp
-
- econf \
- $(use_enable cgal) \
- $(use_enable plugins allplugins) \
- $(use_enable plugins allcxxplugins) \
- --enable-shared \
- --enable-static=no \
- --disable-static \
- --disable-auto-ptr \
- $(use_enable python pyext)
-}
-
-src_compile() {
- default
- docs_compile
-}
-
-src_install() {
- default
- if use examples; then
- emake -C example maintainer-clean
- find example -iname 'makefile*' -delete || die
-
- docinto examples
- dodoc -r example/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
- find "${ED}" -name '*.la' -delete || die
-}