summaryrefslogtreecommitdiff
path: root/sci-physics/espresso++/espresso++-2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:09:35 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:09:35 +0100
commit963e79dcc85b2d1ff6167b5558b885d19cb0a6ad (patch)
treefc27f7984ca9e329255af0408d2a14313b1b6468 /sci-physics/espresso++/espresso++-2.0.ebuild
parent6260b15e6431fe568f4e548f696e150d467cd7f2 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'sci-physics/espresso++/espresso++-2.0.ebuild')
-rw-r--r--sci-physics/espresso++/espresso++-2.0.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/sci-physics/espresso++/espresso++-2.0.ebuild b/sci-physics/espresso++/espresso++-2.0.ebuild
new file mode 100644
index 000000000000..3bae0551d9b2
--- /dev/null
+++ b/sci-physics/espresso++/espresso++-2.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit cmake-utils python-r1
+
+DESCRIPTION="A Modern Multiscale Simulation Package for Soft Matter Systems"
+HOMEPAGE="https://www.espresso-pp.de"
+
+MY_PN="${PN//+/p}"
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/${MY_PN}/${MY_PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ virtual/mpi
+ dev-libs/boost:=[python,mpi,${PYTHON_USEDEP}]
+ sci-libs/fftw:3.0
+ >=dev-python/mpi4py-2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ src_configure_internal() {
+ local mycmakeargs=(
+ -DEXTERNAL_BOOST=ON
+ -DEXTERNAL_MPI4PY=ON
+ -DWITH_RC_FILES=OFF
+ )
+ cmake-utils_src_configure
+ }
+ python_foreach_impl src_configure_internal
+}
+
+src_compile() {
+ python_foreach_impl cmake-utils_src_make
+}
+
+src_test() {
+ python_foreach_impl cmake-utils_src_test
+}
+
+src_install() {
+ python_foreach_impl cmake-utils_src_install
+}