summaryrefslogtreecommitdiff
path: root/sci-misc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-23 01:00:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-23 01:00:42 +0000
commit6c169675dd21d25ad82ab0560f3d5b1e714219b6 (patch)
treeed786201c471d4535a5eca3a754866a856812bcb /sci-misc
parent7fe6984499f95d52b3c32af6ab771aa8f08c2dd4 (diff)
gentoo auto-resync : 23:03:2024 - 01:00:42
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/Manifest.gzbin2571 -> 2574 bytes
-rw-r--r--sci-misc/jupyterlab-desktop-bin/Manifest2
-rw-r--r--sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-4.1.5.1.ebuild110
3 files changed, 112 insertions, 0 deletions
diff --git a/sci-misc/Manifest.gz b/sci-misc/Manifest.gz
index 39c233cde1bd..8ac8933d4cb9 100644
--- a/sci-misc/Manifest.gz
+++ b/sci-misc/Manifest.gz
Binary files differ
diff --git a/sci-misc/jupyterlab-desktop-bin/Manifest b/sci-misc/jupyterlab-desktop-bin/Manifest
index a9cd24abbe30..3948faeb98ab 100644
--- a/sci-misc/jupyterlab-desktop-bin/Manifest
+++ b/sci-misc/jupyterlab-desktop-bin/Manifest
@@ -1,3 +1,5 @@
DIST jupyterlab-desktop-bin-4.1.4.1.rpm 333180169 BLAKE2B 21b0f79ba9d0feebb1554ab0e11559e7c4b8898da59face94bb422bef0673ffbb6036ab24956b1e88a0387da903b0008aa24ff5905e44b3a594c19282da749b2 SHA512 725b082a664826c25f6e7c6564be5bf8df2dccb32a34623da4e82c8a961a52a2360be44f2b185048000a9fe7e1c02b0564ef519e6d4a8f0389e94b4447415d9c
+DIST jupyterlab-desktop-bin-4.1.5.1.rpm 333125797 BLAKE2B 3aa27180799a28c6363730ce48333270f1e817dac1fc1c0b088a85b80bc35ce49b15e407c4b21bed480a09050449ad3032e77ab5985459572268970f2bbd1cd9 SHA512 0df094201fb4ee84c483306c3fb90daa32ca4ea3e2b461b8709b5e829513918d719b89de4c75eb3f63956345bbcac19aeb7c714201eded390de971dcb3173093
EBUILD jupyterlab-desktop-bin-4.1.4.1.ebuild 2824 BLAKE2B 42e86fdabfc1b671214482449a2fed5004d7f34d265a95258e90cb747ba73f95afcf2a224c3e52122bc6482a943cd775dfeae455712bc0a83ea0d0040cee2a62 SHA512 0f92bf77ce285a989f91df5a1e44c065259f3844176b3b809a10ea2f871ebacc03be8ffc47649af665e564d06cdf052408d46b776a0bf199ad99d20d717b3a69
+EBUILD jupyterlab-desktop-bin-4.1.5.1.ebuild 2824 BLAKE2B 42e86fdabfc1b671214482449a2fed5004d7f34d265a95258e90cb747ba73f95afcf2a224c3e52122bc6482a943cd775dfeae455712bc0a83ea0d0040cee2a62 SHA512 0f92bf77ce285a989f91df5a1e44c065259f3844176b3b809a10ea2f871ebacc03be8ffc47649af665e564d06cdf052408d46b776a0bf199ad99d20d717b3a69
MISC metadata.xml 430 BLAKE2B 1bd3f621bb4d25086cc80c5b44a7eef4a61f58c1f56c7cb91ca4e39b8a5e7d5fdd37e912e48d99ee6ba6a19de1c61252b4ebe3afd554d487c549d22597c376fc SHA512 b99b088cb0bdcfdaa9d584fb580b12a754f30a378fdede655f7723075e81948fc57f9aad11a59944b164eb8c9c24f6f0828e95c5a227766e985778900ea08079
diff --git a/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-4.1.5.1.ebuild b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-4.1.5.1.ebuild
new file mode 100644
index 000000000000..fba316a220ed
--- /dev/null
+++ b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-4.1.5.1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHROMIUM_LANGS="
+ af am ar bg bn ca cs da de el en-GB en-US es es-419 et fa fi fil fr gu he hi
+ hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr sv
+ sw ta te th tr uk ur vi zh-CN zh-TW
+"
+
+inherit chromium-2 desktop rpm xdg
+
+DESCRIPTION="JupyterLab desktop application, based on Electron"
+HOMEPAGE="https://jupyter.org/"
+SRC_URI="https://github.com/jupyterlab/${PN%%-bin}/releases/download/v$(ver_rs 3 -)/JupyterLab-Setup-Fedora-x64.rpm -> ${P}.rpm"
+S="${WORKDIR}"
+
+KEYWORDS="-* ~amd64"
+# Electron bundles a bunch of things
+LICENSE="
+ MIT BSD BSD-2 BSD-4 AFL-2.1 Apache-2.0 Ms-PL GPL-2 LGPL-2.1 APSL-2
+ unRAR OFL CC-BY-SA-3.0 MPL-2.0 android public-domain all-rights-reserved
+"
+SLOT="0"
+RESTRICT="bindist mirror"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ >=dev-python/jupyterlab-$(ver_cut 1-3)
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/JupyterLab/*"
+
+pkg_pretend() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_prepare() {
+ default
+ # cleanup languages
+ pushd "opt/JupyterLab/locales" || die
+ chromium_remove_language_paks
+ popd || die
+}
+
+src_configure() {
+ chromium_suid_sandbox_check_kernel_config
+ default
+}
+
+src_install() {
+ local size=512
+ doicon -s ${size} "usr/share/icons/hicolor/${size}x${size}/apps/jupyterlab-desktop.png"
+
+ domenu usr/share/applications/jupyterlab-desktop.desktop
+
+ local DESTDIR="/opt/JupyterLab"
+ pushd "opt/JupyterLab" || die
+
+ exeinto "${DESTDIR}"
+ doexe chrome-sandbox chrome_crashpad_handler jupyterlab-desktop *.so*
+
+ insinto "${DESTDIR}"
+ doins *.pak *.bin *.json *.dat
+ insopts -m0755
+ doins -r locales resources
+
+ # Chrome-sandbox requires the setuid bit to be specifically set.
+ # see https://github.com/electron/electron/issues/17972
+ fperms 4755 "${DESTDIR}"/chrome-sandbox
+
+ dosym "${DESTDIR}"/jupyterlab-desktop /opt/bin/jupyterlab-desktop
+ popd || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog ""
+ elog "On initial startup you will be prompted to select the python environment of"
+ elog "your choice. Either select a specific python version, e.g. /usr/bin/pythonX.Y,"
+ elog "or choose /usr/bin/python to follow the system wide setting in"
+ elog "/etc/python-exec/python-exec.conf."
+ elog "Please note that only python environments corresponding to the enabled"
+ elog "PYTHON_TARGETS on dev-python/jupyterlab will work."
+ elog ""
+}