summaryrefslogtreecommitdiff
path: root/sci-misc/gato
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-misc/gato
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-misc/gato')
-rw-r--r--sci-misc/gato/Manifest5
-rw-r--r--sci-misc/gato/gato-1.2.2.ebuild37
-rw-r--r--sci-misc/gato/metadata.xml15
3 files changed, 57 insertions, 0 deletions
diff --git a/sci-misc/gato/Manifest b/sci-misc/gato/Manifest
new file mode 100644
index 000000000000..82cd63f13c9b
--- /dev/null
+++ b/sci-misc/gato/Manifest
@@ -0,0 +1,5 @@
+DIST Gato-1.2.2.tar.gz 274369 SHA256 d353b8af72ad780f0301912f101ea528822d616bea717c7ca84eaeb0609fa42f SHA512 a628827b989f28817bcd427903d09f6571b3c2e571b57242d7c41562e558a00b278e87699565d16bf2584a0c8d33c07bf0a3c5113c9feeff417546a0a712c0c9 WHIRLPOOL 5eb369c6195ecff405e851a8e777a2b9469333031bc849ea03ad957d1370a99940e1887a6b4940a3fbf07968f8c4bed07e93e3c4ac835d72bb33000e9631b76a
+EBUILD gato-1.2.2.ebuild 807 SHA256 c74029e7b5aa6fc626efa8a416b1ac3f4ffb72afb7902b71de551f2f7b7405bc SHA512 a1335b105404cb9730470b9429dfa7ebc8a3aab4dce1d48422e74b2c2621ee5f010cda485688a06b1958b1b342802f421df55f6cb0396e49199ea10c6e7ac125 WHIRLPOOL 600b0ae9f344a629523b3dddda8cd69ccdaab21dd1bb72a81d1bf062a7c3e2472b8b351199f0b0258a20bd0516c2d06ec73be561e61b4f51206f0d6d5cc5841b
+MISC ChangeLog 2819 SHA256 fba43fabc1d3137d0c7bfe7b148ce7d436a3d10e4663adb919fae228190674f6 SHA512 94ed35659ada2a9287ba5ccfe88c95a39b65cb563ac9c78b45e7e1d5966c5d8df267555da7878d692061d8e4d737bc0743a0a4d57aa9c5e013274395b4735d73 WHIRLPOOL 54bc4ce42fb8d80f27466b47ec3d902c5092f44b009534be1d0dcced0d93ecc3262681abb880c256adf95f4f010e28e6d8f1d3d8d0d84d839b7b5b32f24cdbef
+MISC ChangeLog-2015 2619 SHA256 dc08c16228f25ec8b258c407a53af08d1306afdf41105e38436579d329e0e805 SHA512 4eb1ec75a81e8b651ff28bd71d77c61e353cd27c5c91dc765f4bc5052f42566b2eacc5d17ec25c57b51b64fd781067260dc2b1c52809b4e5dfdcbd025370516e WHIRLPOOL 586aa7fcf7a05c7376eb3d5312d44897d786df3e8995b5fb35c996eb6543723a736b0849b6048617c95b07360df4be5ca93d6630d228010b31c73f3a9b4453d6
+MISC metadata.xml 498 SHA256 3f386e72a67648889e0616af36c798261ae879533f3747c5799a14c43147ca1c SHA512 49f44f43996e2c7187ed56a032a9f8dd7c36714181ba9b30fda6cb10aec97b1aee5f8a1bcfbe9d150f4864fb09d07a3130746bd938a75006624acba42ac16e51 WHIRLPOOL a6b62d12281092546140800d5b47eb7178189ccd7a6ca5b0114837698c640a415f1c8522487ac2b656258bb7ce9c2f44064f6e025e3fdf4f7c32b4773bb1267a
diff --git a/sci-misc/gato/gato-1.2.2.ebuild b/sci-misc/gato/gato-1.2.2.ebuild
new file mode 100644
index 000000000000..e78b0e32d1d0
--- /dev/null
+++ b/sci-misc/gato/gato-1.2.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Graph Animation Toolbox"
+HOMEPAGE="http://gato.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P^}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}/${P^}"
+
+python_prepare_all() {
+ # change TKinter call to avoid crashing of X
+ sed -i \
+ -e 's:self.overrideredirect(1):self.overrideredirect(0):' \
+ "${S}"/GatoDialogs.py || die "failed to patch GatoDialogs.py"
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # install data files
+ insinto /usr/share/${PN}
+ doins BFS.* DFS.* sample.cat
+}
diff --git a/sci-misc/gato/metadata.xml b/sci-misc/gato/metadata.xml
new file mode 100644
index 000000000000..fecf4f0d6626
--- /dev/null
+++ b/sci-misc/gato/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Gato - the Graph Animation Toolbox - is a software which visualizes
+ algorithms on mathematical graphs.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">gato</remote-id>
+ </upstream>
+</pkgmetadata>