summaryrefslogtreecommitdiff
path: root/sci-misc/apertium/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-18 09:41:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-18 09:41:23 +0000
commitd93ba9788a6ad1e5da2bf47e804456ded6d5c65c (patch)
treee01c10bcfe477cecf1770c8a8186e4a5344057b9 /sci-misc/apertium/files
parent7bf32644d8b70a318475609992d8e4853ec4ec0e (diff)
gentoo auto-resync : 18:12:2022 - 09:41:22
Diffstat (limited to 'sci-misc/apertium/files')
-rw-r--r--sci-misc/apertium/files/apertium-3.8.3-bashism.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-misc/apertium/files/apertium-3.8.3-bashism.patch b/sci-misc/apertium/files/apertium-3.8.3-bashism.patch
new file mode 100644
index 000000000000..ca479d9cc134
--- /dev/null
+++ b/sci-misc/apertium/files/apertium-3.8.3-bashism.patch
@@ -0,0 +1,30 @@
+https://github.com/apertium/apertium/pull/181
+
+From 08578745ba3988ece9596eaca734d08e64bae4e1 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 18 Dec 2022 03:39:58 +0000
+Subject: [PATCH] configure.ac: fix bashism
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+configure scripts need to be runnable with a POSIX-compliant /bin/sh.
+
+On many (but not all!) systems, /bin/sh is provided by Bash, so errors
+like this aren't spotted. Notably Debian defaults to /bin/sh provided
+by dash which doesn't tolerate such bashisms as '=='.
+
+This retains compatibility with bash.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/configure.ac
++++ b/configure.ac
+@@ -95,7 +95,7 @@ for version in 23 2b 20 2a 17; do
+ version_flag="-std=c++${version}"
+ AX_CHECK_COMPILE_FLAG([${version_flag}], [break], [version_flag=none])
+ done
+-AS_IF([test "$version_flag" == none], [
++AS_IF([test "$version_flag" = none], [
+ AC_MSG_ERROR([Could not enable at least C++17 - upgrade your compiler])
+ ])
+ CXXFLAGS="$CXXFLAGS ${version_flag}"