summaryrefslogtreecommitdiff
path: root/sci-mathematics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-06 19:22:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-06 19:22:30 +0100
commit744892aecb5cdf9ca0bbe504f7bbcdfb87b518fc (patch)
tree0b99b178b866e693a85d013eb47de3d1236e35b8 /sci-mathematics
parent275074c50dca7b941cc7cd7966a2ace71c29ecae (diff)
gentoo auto-resync : 06:10:2022 - 19:22:30
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/Manifest.gzbin16202 -> 16197 bytes
-rw-r--r--sci-mathematics/cadabra/Manifest2
-rw-r--r--sci-mathematics/cadabra/cadabra-2.4.0.2.ebuild104
-rw-r--r--sci-mathematics/dataplot/Manifest2
-rw-r--r--sci-mathematics/dataplot/dataplot-20131220.ebuild3
5 files changed, 109 insertions, 2 deletions
diff --git a/sci-mathematics/Manifest.gz b/sci-mathematics/Manifest.gz
index 590acd1f2790..f9e279005fb5 100644
--- a/sci-mathematics/Manifest.gz
+++ b/sci-mathematics/Manifest.gz
Binary files differ
diff --git a/sci-mathematics/cadabra/Manifest b/sci-mathematics/cadabra/Manifest
index b6e3517e5fe5..28e8b3f0e589 100644
--- a/sci-mathematics/cadabra/Manifest
+++ b/sci-mathematics/cadabra/Manifest
@@ -1,4 +1,6 @@
AUX cadabra2-CMake.patch 3184 BLAKE2B afa702834d5eb82a8056307b419fc20bbc2d45b0474994328b70fee383dff415ea37ef2e70c83e9cb7776e06f9295cf5cb9afddddaf857227f7a72f362b61726 SHA512 ddd6b451f81e465d4fef9401340808922bcb1074895173d83d699614e0c967024863848fabdd207f7124ff6396e8c2c75d2ed1425ba73d7bb6d5ac6fe56a87f1
DIST cadabra-2.3.9.3.tar.gz 24685603 BLAKE2B eb76f65898be499eb5abbbaf8ac478a056ffe5801bcf7124be60d1b034f4e88e9999d76354f03e7a2de9b7f7561a32e82699c882be135fb5966614da37526933 SHA512 9a5cdc6a7d824350ef3929c9f21647588891c1376103a57d231c2f5160971e3373b0efb9e050c574ebd51921a3f7d9f230f533a88a44e0dd8e645bf2395a95fe
+DIST cadabra-2.4.0.2.tar.gz 24688084 BLAKE2B 4bc1e00ab87bbdc43dae261e1948b41a6372f90ad394e5208b65b993210ff42e84ed098ad4fcf6d056fc42947b75f970f18a92b67859fd69c8ea3cc18ffb2e9a SHA512 2545f7ba3238944902b413bfbed91d87594d87afe99d1fb61061115b354a6fa29ffb7b71017d790e54080da33aa905d0f9afe0546fb1397144fe7b135e906274
EBUILD cadabra-2.3.9.3.ebuild 2339 BLAKE2B 9f37b9ff707ff93a4ffe6560a8e82eda1b0e776f235983b2d9f968a42361f575f5a9f50a20f9a17fc113c1763002abec4fdec091d54491066f0d5cd4ec4e9379 SHA512 dd5577c563207ccb7d903cd1b64b51518c1e665772d1f8f6ab15e2ddf22b51013936d349a07284d775c861c542b99b5caaf7ef0b3ab0b1bf4c1269996fa1ce80
+EBUILD cadabra-2.4.0.2.ebuild 2366 BLAKE2B c9422fb15e1f2893e314203e638adba06322fefe27cc64b836eb019b61d3a8b6b0d6507c0bb727690beecc5108bde9278e14f3508c4b461203600f6510ab2d38 SHA512 0269554029c028cb97d6bcbd9d8cb65e45d178fe57b7d69ac0ec0b7ac91b472e6c782c7d661a0196e156f7c61c7015053c02fe5578f309090491931915c62f2d
MISC metadata.xml 1342 BLAKE2B 2f34aae73fc01d4b8fd4326505b7b0785663c62593641d1d0a01f64adc12cbc8676271612ce91258927ac22957a8d5aba53dd2627130582c744bc32c28e0e207 SHA512 41dffbcfae16f8f0702df5a1837b225100761d48817a2d70fa03aca6246b9d3184d60989cf265282286b02a77a126ac82695c2d74c6de91da45e8f64fcb91811
diff --git a/sci-mathematics/cadabra/cadabra-2.4.0.2.ebuild b/sci-mathematics/cadabra/cadabra-2.4.0.2.ebuild
new file mode 100644
index 000000000000..c3b86c9b872e
--- /dev/null
+++ b/sci-mathematics/cadabra/cadabra-2.4.0.2.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MAJOR=$(ver_cut 1)
+CADABRA=${PN}${MAJOR}
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit xdg-utils python-single-r1 cmake
+
+DESCRIPTION="Field-theory motivated approach to computer algebra"
+HOMEPAGE="https://cadabra.science/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kpeeters/${CADABRA}.git"
+else
+ SRC_URI="https://github.com/kpeeters/${CADABRA}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${CADABRA}-${PV}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0/${MAJOR}"
+IUSE="gtk +jupyter test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-text/dvipng
+ dev-cpp/glibmm:2
+ dev-db/sqlite:3=
+ dev-libs/boost:=
+ dev-libs/gmp:=[cxx]
+ dev-libs/jsoncpp:=
+ dev-libs/libsigc++:2
+ dev-texlive/texlive-basic
+ $(python_gen_cond_dep '
+ dev-python/gmpy:2[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ jupyter? ( dev-python/jupyter[${PYTHON_USEDEP}] )
+ ')
+ gtk? ( dev-cpp/gtkmm:3.0 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="$(python_gen_cond_dep 'dev-python/pybind11[${PYTHON_USEDEP}]')"
+
+PATCHES=( "${FILESDIR}"/${CADABRA}-CMake.patch )
+
+DOCS=( CODE_OF_CONDUCT.md CONTRIBUTING.md JUPYTER.rst README.rst )
+
+# Because we do not want to pull in "_XDG_DEPEND" dependencies with USE="-gtk"
+xdg_update() {
+ if use gtk ; then
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ fi
+}
+
+src_prepare() {
+ # Clean postinst script which calls libtool and icon-cache update
+ echo '#!/bin/sh' > "${S}"/config/postinst.in || die
+
+ # Fix "PYTHON_EXECUTABLE" in Jupyter kernel
+ sed -i "s|@PYTHON_EXECUTABLE@|${EPYTHON}|" \
+ "${S}"/jupyterkernel/kernelspec/kernel.json.in || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_SYSTEM_JSONCPP=ON
+ -DPACKAGING_MODE=ON
+ -DUSE_PYTHON_3=ON
+ -DBUILD_AS_CPP_LIBRARY=OFF
+ -DENABLE_JUPYTER=OFF # special Xeus Jupyter kernel (uses xtl)
+ -DENABLE_MATHEMATICA=OFF
+ -DINSTALL_TARGETS_ONLY=OFF
+ -DBUILD_TESTS=$(usex test)
+ -DENABLE_FRONTEND=$(usex gtk)
+ -DENABLE_PY_JUPYTER=$(usex jupyter)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ python_optimize
+}
+
+pkg_postinst() {
+ xdg_update
+}
+
+pkg_postrm() {
+ xdg_update
+}
diff --git a/sci-mathematics/dataplot/Manifest b/sci-mathematics/dataplot/Manifest
index fcfa73016580..44c6502ca8de 100644
--- a/sci-mathematics/dataplot/Manifest
+++ b/sci-mathematics/dataplot/Manifest
@@ -4,5 +4,5 @@ AUX configure.ac.20131220 2282 BLAKE2B 1ee098443f8aaba696b93948d62b6ed31fae8d14e
AUX dataplot-20090821-opengl.patch 1678 BLAKE2B 9b45ca716ba2ad053eac04942ee174a9ac6a5e6f6d451eedee03e18e6ebc0b13de866827a16eb9dce7de00881b1d7e53e61c99e8630c25c8eb0005696f9b8cf1 SHA512 cff8c08458c6d7ae57faa9e32ccf42b42adb9797b6b514aa597c34d5067935fefb5d1da9abf14ea2a74c17d3862d6b844f2e244895fb167fbce0b7b352f5dc07
DIST dplib.2009_07_15.tar.gz 7507367 BLAKE2B 5eec49feb1e90d479547955e5717e8e49eed18f78bae5942881511becf517986c8ba8e2f7513000c52fbb1686cc31fadf38ac61fb1f0822283f6b4fa9dd6431b SHA512 5e4e6c866a5690c3f67b322d53b6bf1bec33c488a99c95f360ce74785a57286541945fdcab5cbbacb04039046f5ba94aeaf8112b80aa34ed2c2cf04abc6f7d40
DIST dpsrc_2013_12_20.tar.gz 6761551 BLAKE2B 029d278ebc025d0e902b2b37743f0ad53c567463d7929d69c7c1fe291b9355c29766035b9747f184ca28035eac2954ad391a7039da7151e7a5391ba123c6ac3f SHA512 a62df14f3ec59ccae4ead52b34adfc6e881ade1397e5a31b8a73c9740e7a2245317fef4f9756224c8d2fb57799c2247b15f6c4d65777de6302553fd138bb4083
-EBUILD dataplot-20131220.ebuild 2198 BLAKE2B 8fe1b659e1ffc212c78dea11658987556cd9a65824154205513111251beca56bf97854d8451f99899576c95c5fb9ac07ef85fae9a8cd73437fe649f4383bd72d SHA512 a7a1d49b106bdfd0279642e0e54c3da7ab9a834ec260421df93fcc8a5c056fec62de1eb6badb7e4c7ad3fd267a0f32144ed45299e55bf8d3849181da3031085e
+EBUILD dataplot-20131220.ebuild 2222 BLAKE2B b094eb844a98dc3b4e766d9e5aa4458246a2931b156fe93870a1954d45ca804791643be302ce2109d577d1b9447e37db513ce12cbb14ab381d198f7ba810265c SHA512 48e06de0c9d4f2a7d9d8c4da9b093d7cfb3575b6e2f437e70eb166cefb4f9ea01efecb12d611ce2072219e86f43064dd60629ff86c0d7344c2b83dd1a24792f4
MISC metadata.xml 730 BLAKE2B a5c1bc4bf354cd3ee9efae0c4e835c0611980896716292e6b61e825f86ac41c703a1dc7a3759f90a54422fa4c69a7b4bd63fb1ab88c3c6ba1eb7aaa11226d592 SHA512 441750c0e236f88bcca298ba30117c6ce3bb82e6fd3fc5ff750740ff16e54d7a570c83729f237eb300c84832b715a696e021b711bab572b5f1bb7f2b4377ae42
diff --git a/sci-mathematics/dataplot/dataplot-20131220.ebuild b/sci-mathematics/dataplot/dataplot-20131220.ebuild
index ea559f7ade99..ddad933a3c40 100644
--- a/sci-mathematics/dataplot/dataplot-20131220.ebuild
+++ b/sci-mathematics/dataplot/dataplot-20131220.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -34,6 +34,7 @@ DEPEND="${COMMON_DEPEND}
virtual/pkgconfig"
RDEPEND="${COMMON_DEPEND}
X? ( x11-misc/xdg-utils )"
+BDEPEND="media-libs/gd"
S_AUX="${WORKDIR}/${MY_P_AUX}"