summaryrefslogtreecommitdiff
path: root/sci-mathematics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-11 00:08:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-11 00:08:05 +0100
commit65ff3cc3bd9c3f8e718a67dfecf1f8215bf5d1d4 (patch)
tree541cbae0eb51d2fdb39d64b3d135d1a6f7994dc8 /sci-mathematics
parent0aad4cd3e3fe3db90904ffc51b35e4ff160b53c5 (diff)
gentoo auto-resync : 11:06:2024 - 00:08:04
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/Manifest.gzbin19329 -> 19328 bytes
-rw-r--r--sci-mathematics/coq/Manifest2
-rw-r--r--sci-mathematics/coq/coq-8.19.2.ebuild122
3 files changed, 124 insertions, 0 deletions
diff --git a/sci-mathematics/Manifest.gz b/sci-mathematics/Manifest.gz
index 33f16d90afcf..ff940966f0e7 100644
--- a/sci-mathematics/Manifest.gz
+++ b/sci-mathematics/Manifest.gz
Binary files differ
diff --git a/sci-mathematics/coq/Manifest b/sci-mathematics/coq/Manifest
index a1a6a757171c..2f46c0eaff51 100644
--- a/sci-mathematics/coq/Manifest
+++ b/sci-mathematics/coq/Manifest
@@ -1,5 +1,7 @@
DIST coq-8.19.0.tar.gz 7674352 BLAKE2B 195040c01797ac9ce67611e0c96a4601e0a48966e094e868b9f3644aa9f75fa85adf0e2e6340a14ae0a0598b746f5ad989d8f10736cd2d3852a449f6f79d2c93 SHA512 02fb5b4fb575af79e092492cbec6dc0d15a1d74a07f827f657a72d4e6066532630e5a6d15be4acdb73314bd40b9a321f9ea0584e0ccfe51fd3a56353bd30db9b
DIST coq-8.19.1.tar.gz 7675945 BLAKE2B 62ee346f50d0a22ab217a8e689c3078347519d159619b75f20a8decace356b49c60bcd5b2cec5fbcaffc758a8944f8a7940298df1c0ddddfbd858ed9269c12f3 SHA512 ec8379df34ba6e72bcf0218c66fef248b0e4c5c436fb3f2d7dd83a2c5f349dd0874a67484fcf9c0df3e5d5937d7ae2b2a79274725595b4b0065a381f70769b42
+DIST coq-8.19.2.tar.gz 7678311 BLAKE2B 5f9617fbe0127b0c8357c63f331ba3e9fb5a931be9a4a8e8de2e27820a0d986bf99ed9a512740a0f721c742504225ae56e240af893510aa0e449931499d10aab SHA512 91bc81530fa4f6498961583ad51eac5001f139881788b88e360a866ad8e2a6e2c5bce86d1a580ab4cd4782bf49d48318767df82471ce33ba3ac143e5569ad33c
EBUILD coq-8.19.0.ebuild 2491 BLAKE2B ee610273d5294b25e7aa48cfb048b99af86aef21fb8d3c21019da509c82912b4f6624ae5076a694d98eb3679e9eba7ef138cb12a8ba0f938ce7ecbe4aacf6027 SHA512 498a461e9bc69016aab3abc5578bbd2367322dc14f8c2db9293a246022a4d8065dd06966741db3ae45365b3c1049703f85a9cef42416a8be3ed469dc4d80233e
EBUILD coq-8.19.1.ebuild 2492 BLAKE2B 1c1d296a61f57bf8e5120aa8e70dce382548cc55a8c1365c1e85b33080e3fd346ea1b904e9440af465c67416b83f4b4e538ec558ce0b8c10ec42a94efee7e0f8 SHA512 9783ef6098d6028dd207a239796916ed90d8eab01429c4fded5e25f0a1c776f1c9dc0bac9f15e4d0847ad5d915bb69760937347cb6f295806f61af95cec2199b
+EBUILD coq-8.19.2.ebuild 2484 BLAKE2B 54de05ac84bb2df76e6defa2f96014d3488a78129a6e1b480857ea04ccf1ca1d0c96deacbe544aec0dfffd53c51fc490bef2c9d22c64fdbe7cddd99833f63f75 SHA512 5a236fd48123fd32fe3f13ce964f0effca8ab3ef8a27d025c75bcdd10d7afd511cd506347eb889c59b3ac3fbe8838d6a3757f4c0fa82c277d6669cb926a2bdc4
MISC metadata.xml 1047 BLAKE2B 9f6defdf213139ee6549bc8f3b36ce5e8f53ea73bd5aad9262932cbaea7e90bd97c9ffc9dbbd03ac50097c5a6f19f5ddf00dd2b74cc6a5349faf1b597244fb67 SHA512 0f5bfbdd9ffd6f64379e697ed7cf90c2d9257cd1815e520aa14235f1cb399d20fc863221a0cae803cc88e5975be964b9debc3d750a6378ea157146f2e567c5dc
diff --git a/sci-mathematics/coq/coq-8.19.2.ebuild b/sci-mathematics/coq/coq-8.19.2.ebuild
new file mode 100644
index 000000000000..f61b2d0f54da
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.19.2.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="${PV/_p/pl}"
+MY_P="${PN}-${MY_PV}"
+
+inherit check-reqs desktop dune edo
+
+DESCRIPTION="Proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/
+ https://github.com/coq/coq/"
+SRC_URI="https://github.com/coq/coq/archive/V${MY_PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc gui +ocamlopt test"
+
+# TODO: Lots of failing tests. Maybe investigate later.
+# RESTRICT="!test? ( test )"
+RESTRICT="test"
+
+RDEPEND="
+ dev-ml/num:=
+ dev-ml/zarith:=
+ gui? (
+ >=dev-ml/lablgtk-3.1.2:3=[sourceview,ocamlopt?]
+ >=dev-ml/lablgtk-sourceview-3.1.2:3=[ocamlopt?]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-ml/findlib
+ doc? (
+ >=dev-java/antlr-4.7:4
+ dev-python/antlr4-python3-runtime
+ dev-python/beautifulsoup4
+ dev-python/pexpect
+ dev-python/sphinx-rtd-theme
+ dev-python/sphinxcontrib-bibtex
+ dev-tex/latexmk
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-xetex
+ media-fonts/freefont
+ )
+ test? (
+ dev-ml/ounit2
+ )
+"
+
+CHECKREQS_DISK_BUILD="2G"
+
+DOCS=( CODE_OF_CONDUCT.md CONTRIBUTING.md CREDITS INSTALL.md README.md )
+DUNE_PACKAGES=()
+
+src_prepare() {
+ # Remove failing tests. bug #904186
+ rm -r test-suite/coq-makefile/timing || die
+
+ default
+}
+
+src_configure() {
+ export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
+
+ DUNE_PACKAGES=(
+ coq-core
+ coq-stdlib
+ coqide-server
+ coq
+ )
+ use gui && DUNE_PACKAGES+=( coqide )
+
+ emake clean
+
+ local -a myconf=(
+ -prefix /usr
+ -libdir "/usr/$(get_libdir)/coq"
+ -mandir /usr/share/man
+ -docdir "/usr/share/doc/${PF}"
+ -datadir /usr/share/coq
+ -configdir "/etc/xdg/${PN}"
+ -native-compiler "$(usex ocamlopt yes no)"
+ )
+ use debug && myconf+=( -debug )
+ edo sh ./configure "${myconf[@]}"
+}
+
+src_compile() {
+ emake DUNEOPT="--display=short --profile release" VERBOSE=1 dunestrap
+
+ dune-compile "${DUNE_PACKAGES[@]}"
+
+ use doc && emake refman-html
+}
+
+src_install() {
+ dune-install "${DUNE_PACKAGES[@]}"
+
+ if use gui ; then
+ make_desktop_entry coqide "Coq IDE" "${EPREFIX}/usr/share/coq/coq.png"
+ fi
+
+ local ocamlc_where
+ ocamlc_where="$(ocamlc -where)"
+
+ # Dune installs into /usr/<libdir>/ocaml/<coq> but
+ # Coq wants /usr/<libdir>/<coq> ; symlink those directories
+ local sym
+ for sym in "${DUNE_PACKAGES[@]}" ; do
+ dosym "${ocamlc_where}/${sym}" "/usr/$(get_libdir)/${sym}"
+ done
+
+ einstalldocs
+}