summaryrefslogtreecommitdiff
path: root/sci-mathematics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-27 00:07:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-27 00:07:23 +0100
commit3c1648a0749c1d66b300d857e6b417c1162890da (patch)
tree2b13f04c2c10d472e5bb7cc40fe6048bf8bc549d /sci-mathematics
parent994fe442814c4d169bb0f1ee9745604928006b39 (diff)
gentoo auto-resync : 27:05:2024 - 00:07:23
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/Manifest.gzbin19322 -> 19322 bytes
-rw-r--r--sci-mathematics/mathmod/Manifest4
-rw-r--r--sci-mathematics/mathmod/mathmod-11.1.ebuild38
-rw-r--r--sci-mathematics/mathmod/metadata.xml1
4 files changed, 42 insertions, 1 deletions
diff --git a/sci-mathematics/Manifest.gz b/sci-mathematics/Manifest.gz
index 62fc186bb2d3..1782148b63c8 100644
--- a/sci-mathematics/Manifest.gz
+++ b/sci-mathematics/Manifest.gz
Binary files differ
diff --git a/sci-mathematics/mathmod/Manifest b/sci-mathematics/mathmod/Manifest
index 4b80cbee8f93..171da2721a18 100644
--- a/sci-mathematics/mathmod/Manifest
+++ b/sci-mathematics/mathmod/Manifest
@@ -1,3 +1,5 @@
+DIST mathmod-11.1.tar.gz 7934535 BLAKE2B ccb5ba1ee74b0e6f2d605bf76f107ce43f695f2dc81fe0ef8498fdb29978f3da214178ed433eea9536f3ee801c24887988e0c1064833a6a1069e0349fb209a05 SHA512 50485094a5c0f08077a27215d4189ba28085ad9d6cc3323043955d63723271adf80ba2c8a75afd0b50ea7443a55f5d4efd8f8d5eae32a9c0718450784ff728ab
DIST mathmod-4.1.src.zip 974709 BLAKE2B f7fa5579b670b2512eab4fd7b706a0ca2282fb63356ea44ea2ddc6204b73ae2b7cd6f837d7622ebf0e51ba2b0127437b1836b59780df6c4b8e704fcb92e8680e SHA512 e7a170f5b57384cca4e755a0bb3691ec3fe29e9b22027534f1e84ed656905495c70eea8c69262f31a937ca508c34177d33adc23f5a8a3c91db1eceb2aa283a6d
+EBUILD mathmod-11.1.ebuild 987 BLAKE2B 8a268805b9c413c0b30016636d76b6027ee4062fd7e05b25971bac1c4c1c087031dbb4032e1867dfa83d21e0fd4ebedb8513dd8135adec30da35aa455bbaef81 SHA512 61e29fcea7f87dd831de30bfc9afc496dc007ba9bcca9645d3aa671ebeaffc0322aadd71d6f6bfa73e82912fe656d396bf77b848065bbecf1984943a1706b582
EBUILD mathmod-4.1-r1.ebuild 1075 BLAKE2B 6158857a1a07f9c95d7739fda3af1e49c6e2a9d54a1d1f8f1c2f377e36f66d320b90585e7920cb5b56cc48e2444fb0aeabe36d5c8cecc1a5ac0c614281d129a2 SHA512 9f65d0014e99e6fd3b0bcd56ba07c8b060b433f09a5390ac23ea7e3af1baf211d7eb71a5dcaa95e875ca93c28ecbd24918b1520a8896e71793eacb6d8703e7f2
-MISC metadata.xml 684 BLAKE2B e50783402f79d0390edd2d617e006a31174c889231e16445baa80beaaa68e3bd3e97cbade9f1e5a9e7f6f4cc11e6118608eb948241abf01e518ae9beb0017710 SHA512 298c94aeb31d7a6c8fe4498337af9aaf2ea12f53149577b93077c032a17b7c1c67e70ad3a9f3ec53d4338f472c2e16610fdf1f633009503ef1069993ca3f9958
+MISC metadata.xml 741 BLAKE2B a4c1d87fbd5b528cd93a9b3d0ce7464ff635965d6a981dfd65421e3407110c10bf9211293a2494329ad281f9f3672df96096b9adab73c8187665dd270032b3d6 SHA512 a904fbfac085f23da922b771c775206aae44a0d78e0fb4aa91812c9643b0ac22c9b9cb7458e6cdaa6a10311d3c8b179aa091dead0474129839a535fb6c8e28de
diff --git a/sci-mathematics/mathmod/mathmod-11.1.ebuild b/sci-mathematics/mathmod/mathmod-11.1.ebuild
new file mode 100644
index 000000000000..54833f046640
--- /dev/null
+++ b/sci-mathematics/mathmod/mathmod-11.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop qmake-utils xdg
+
+DESCRIPTION="Plot parametric and implicit surfaces"
+HOMEPAGE="https://github.com/parisolab/mathmod
+ https://sourceforge.net/projects/mathmod/
+ https://www.facebook.com/parisolab"
+SRC_URI="https://github.com/parisolab/mathmod/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+ GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ eqmake5 MathMod.pro
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe MathMod
+ insinto /usr/share/${P}
+ doins mathmodconfig.js mathmodcollection.js advancedmodels.js
+ newicon -s 16 images/icon/catenoid_mini_16x16.png catenoid.png
+ newicon -s 32 images/icon/catenoid_mini_32x32.png catenoid.png
+ newicon -s 64 images/icon/catenoid_mini_64x64.png catenoid.png
+ make_desktop_entry MathMod MathMod catenoid
+}
diff --git a/sci-mathematics/mathmod/metadata.xml b/sci-mathematics/mathmod/metadata.xml
index 15e285da2df2..2198e5722238 100644
--- a/sci-mathematics/mathmod/metadata.xml
+++ b/sci-mathematics/mathmod/metadata.xml
@@ -14,5 +14,6 @@
</longdescription>
<upstream>
<remote-id type="sourceforge">mathmod</remote-id>
+ <remote-id type="github">parisolab/mathmod</remote-id>
</upstream>
</pkgmetadata>