summaryrefslogtreecommitdiff
path: root/sci-mathematics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-10 06:19:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-10 06:19:57 +0000
commit30f491533785a455cdfbd05bb57f1f869a8e41bb (patch)
tree231d01a9349dfa1f56a7235017f5201a7382c652 /sci-mathematics
parenta96f1a2ca235a5eb9e7c498636cd1291be76cb09 (diff)
gentoo auto-resync : 10:01:2023 - 06:19:57
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/Manifest.gzbin17721 -> 17883 bytes
-rw-r--r--sci-mathematics/kissat/Manifest3
-rw-r--r--sci-mathematics/kissat/kissat-3.0.0.ebuild37
-rw-r--r--sci-mathematics/kissat/metadata.xml19
-rw-r--r--sci-mathematics/z3/Manifest2
-rw-r--r--sci-mathematics/z3/metadata.xml18
6 files changed, 78 insertions, 1 deletions
diff --git a/sci-mathematics/Manifest.gz b/sci-mathematics/Manifest.gz
index 7a587be2e2e2..3fc404920159 100644
--- a/sci-mathematics/Manifest.gz
+++ b/sci-mathematics/Manifest.gz
Binary files differ
diff --git a/sci-mathematics/kissat/Manifest b/sci-mathematics/kissat/Manifest
new file mode 100644
index 000000000000..e6ffc5abf9bc
--- /dev/null
+++ b/sci-mathematics/kissat/Manifest
@@ -0,0 +1,3 @@
+DIST kissat-3.0.0.tar.gz 466704 BLAKE2B 453f894884e80cfd0ee7022adbde0439d64e31a402c4bfa92f022ad41699cc5c11682d5b9069cf33f8a779afa255f103987519bc9412b49f54480bd688fbc4eb SHA512 2a5b7b9c9bb74ca8395399425519c138e135eb9adfb6e802ce8d7544c9d53e0b7687f86e6a032fcdff1c6fc01770dd7e7449e488e0ddf3e4ee1199e1448a0862
+EBUILD kissat-3.0.0.ebuild 772 BLAKE2B 80d43e118bd7f2877db6df72e38a71212965b65aca5eb6ca2bd407bd110cc9aa431f65a4fd4c3fc1e535fce4d1c2c01d7f1a96cde0aa2d7b058e445fdbd44b90 SHA512 6f40a9b420e5f6a9433abb5278d081a52b7dfd9d4f490f8934153314ca0652eff8bacbb3bef75485a1e47cde6555ae340c0324056b8e51e37818f144637d79e9
+MISC metadata.xml 762 BLAKE2B 95fefd93903442e9c5c6881127d734899535b35ffcef1e9082502774849d5b04aeb7f5f5d53b2dfc899f9b503fce0785ec5f3e8fab580965636bbb17775b10e5 SHA512 441d510f122197141ce7a4140023d858c6dbb41bd8f8ea5b8466aaa4864b51df019d0759cdf54de51eb89bf4f421fbdf8937e6349b2100cb1e92d5b8f9556c26
diff --git a/sci-mathematics/kissat/kissat-3.0.0.ebuild b/sci-mathematics/kissat/kissat-3.0.0.ebuild
new file mode 100644
index 000000000000..3c36cf0cd9ef
--- /dev/null
+++ b/sci-mathematics/kissat/kissat-3.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Keep-it-simple and clean bare metal SAT solver written in C"
+HOMEPAGE="http://fmv.jku.at/kissat/
+ https://github.com/arminbiere/kissat/"
+SRC_URI="https://github.com/arminbiere/${PN}/archive/rel-${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-rel-${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_configure() {
+ local myopts=(
+ CC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}"
+ --kitten
+ --statistics
+ )
+ sh ./configure "${myopts[@]}" || die
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ dolib.a build/libkissat.a
+ exeinto /usr/bin/
+ doexe build/{kissat,kitten}
+ dodoc CONTRIBUTING NEWS.md README.md
+}
diff --git a/sci-mathematics/kissat/metadata.xml b/sci-mathematics/kissat/metadata.xml
new file mode 100644
index 000000000000..89067a2c8952
--- /dev/null
+++ b/sci-mathematics/kissat/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription>
+ Kissat is a "keep it simple and clean bare metal SAT solver" written in C.
+ It is a port of CaDiCaL back to C with improved data structures, better
+ scheduling of inprocessing and optimized algorithms and implementation.
+ Coincidentally "kissat" also means "cats" in Finnish.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/arminbiere/kissat//issues/</bugs-to>
+ <remote-id type="github">arminbiere/kissat</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-mathematics/z3/Manifest b/sci-mathematics/z3/Manifest
index 965b0a1fb993..a3edce1f0378 100644
--- a/sci-mathematics/z3/Manifest
+++ b/sci-mathematics/z3/Manifest
@@ -1,3 +1,3 @@
DIST z3-4.11.2.tar.gz 5428273 BLAKE2B 85fe5b94c5bfaeaca5b1dfe42fe9763a278c414955a9aed45abbb3e60c366a86bcdcd7c3bdcf27cc67bc10c76700069d548cb1e27ccf3286c8c6eccfa9d492d1 SHA512 be2573d38c0e50b46fcb025d50335e016769fdeab3c26f5dc2a13102fae889d23039258ea8d38de3f53daa4cf073704d8639ac291e781a74633194adedaae21a
EBUILD z3-4.11.2.ebuild 2598 BLAKE2B a7ed4afbff24bf7f001fd883f9844f8fe837ff4623499475199b3eca33dc52d57490c61820bf22ff27b72044d51bd53cd6f36203aaac2c41b37d807e15e0f1b7 SHA512 233c06d48697b3795c3e071703d16458c688773d9523fe5b8b16efba315a67efd03d5b6ac478611dbdde6d8e7e28af72db39a26cbebf45341873d4aa192db84f
-MISC metadata.xml 617 BLAKE2B f940ac3d7c159dadf4398164b749eaded84c12af5553a154d97fd9bfb939c72e3122e08e11c1c9764514f59a87695534daff6628bd15be4de834c7cfdb65d7f9 SHA512 758df481a60606de12c5a450162ee89fd2f68f842675b3bf280f024fcd61232228476ac889e60c09e42ebae01ad855b32ad77793ba7fa5714861ccc5ca52bfc7
+MISC metadata.xml 1800 BLAKE2B 26b4fd829e8daf66cfb19f61afffe9535099260732b3856c400881e68dbc4c2ffe88ff57f3a23449a2259696f23969c6502d4f3432b9cafc2e89e99167c94b90 SHA512 92f05bb1617630c16801ae5ea4215436c4d5dde6890d1a9e90c81f8ce1cddf101b73e016d1ec67eb41ccb4b59753547e6d08ac6a70a5b2d3dc792dc9fba13166
diff --git a/sci-mathematics/z3/metadata.xml b/sci-mathematics/z3/metadata.xml
index b0bebabc397e..5ab7254e6517 100644
--- a/sci-mathematics/z3/metadata.xml
+++ b/sci-mathematics/z3/metadata.xml
@@ -11,11 +11,29 @@
<email>sci@gentoo.org</email>
<name>Gentoo Science Project</name>
</maintainer>
+ <longdescription>
+ Z3 is an efficient Satisfiability Modulo Theories (SMT) solver from
+ Microsoft Research. Z3 is a solver for symbolic logic, a foundation for
+ many software engineering tools. SMT solvers rely on a tight integration of
+ specialized engines of proof. Each engine owns a piece of the global puzzle
+ and implements specialized algorithms. For example, Z3’s engine for
+ arithmetic integrates Simplex, cuts and polynomial reasoning, while an
+ engine for strings are regular expressions integrate methods for symbolic
+ derivatives of regular languages. A theme shared among many of the
+ algorithms is how they exploit a duality between finding satisfying
+ solutions and finding refutation proofs. The solver also integrates engines
+ for global and local inferences and global propagation. Z3 is used in a
+ wide range of software engineering applications, ranging from program
+ verification, compiler validation, testing, fuzzing using dynamic symbolic
+ execution, model-based software development, network verification, and
+ optimization.
+ </longdescription>
<use>
<flag name="isabelle">Add integration support for the Isabelle/HOL
theorem prover.</flag>
</use>
<upstream>
+ <bugs-to>https://github.com/Z3Prover/z3/issues/</bugs-to>
<remote-id type="github">Z3Prover/z3</remote-id>
</upstream>
</pkgmetadata>