summaryrefslogtreecommitdiff
path: root/sci-mathematics/z3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /sci-mathematics/z3
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'sci-mathematics/z3')
-rw-r--r--sci-mathematics/z3/Manifest2
-rw-r--r--sci-mathematics/z3/z3-4.8.13.ebuild103
2 files changed, 105 insertions, 0 deletions
diff --git a/sci-mathematics/z3/Manifest b/sci-mathematics/z3/Manifest
index bd5a04b1bcea..c3422162c44f 100644
--- a/sci-mathematics/z3/Manifest
+++ b/sci-mathematics/z3/Manifest
@@ -1,3 +1,5 @@
DIST z3-4.8.11b.tar.gz 4801435 BLAKE2B 903a04246fe4dedc96fda653fa9e3a57a80b951d20b992306bd07bc778cf0a94cf36fe4ed3f178bb26196a1ca294834c784a117fe906d52b82f874a43869d110 SHA512 dfcfc85209dd00aa5f07de0a7e7186a33442b72b94b05c01f53350b9281551be2a2c21ad5e7814bc2c52a3329be8df578e6be8c387cbfdc3a9d3bef0611d6613
+DIST z3-4.8.13.tar.gz 5103999 BLAKE2B 5500bbc71e7a863092a36bdd2bc04f5a4435e9d8fdc62c7956aa2546ffa9e39344c9528bf802f6e4c211c799e873f2673dbf8b113599dcbb694ac040ada2e9a0 SHA512 c5e8f34525ed3b6b2935d7f01ce2f90f5dd99b4cdd035664b36c967fb1c7f3b05abed45c7288e2261723e73d68728ee91a0f67d92012d86b04598d7b54369c30
EBUILD z3-4.8.11b.ebuild 2610 BLAKE2B 62e0920d9e4ba69c65fff37bdc74c70f7177853f3b8ff61b2f4a50dd09d72d0f42ffcf71da152e2c5b80d1ff4e26b96d683f10a439c8a8270cc8f6dc50fb3faf SHA512 457a93cfee6bb224e5d1987a7ecaeba18f3f478ac26a222ed4c93e249225c46834d07800e9049931833e01d8ce1e5fadca09ab24df261fbc4b1165e1290845f9
+EBUILD z3-4.8.13.ebuild 2599 BLAKE2B 7d4b057cf1b8a9853db7d5f482a7457cd55fe1e4c3bdaa727db86fa69d0d144ccb2de9e25e51f34c7edb7c3487e6b0f4a51a76890dc309820e8096e39d7d9f01 SHA512 3c40f3b590e1d46defc757c6133136693e5ee5129949dfd1f7dbf49bc7e0634c591c2ba6e0758b0a0e9b979425c9501864020e4e12cc685ce963d74d5b2b6889
MISC metadata.xml 617 BLAKE2B f940ac3d7c159dadf4398164b749eaded84c12af5553a154d97fd9bfb939c72e3122e08e11c1c9764514f59a87695534daff6628bd15be4de834c7cfdb65d7f9 SHA512 758df481a60606de12c5a450162ee89fd2f68f842675b3bf280f024fcd61232228476ac889e60c09e42ebae01ad855b32ad77793ba7fa5714861ccc5ca52bfc7
diff --git a/sci-mathematics/z3/z3-4.8.13.ebuild b/sci-mathematics/z3/z3-4.8.13.ebuild
new file mode 100644
index 000000000000..488e59de75e0
--- /dev/null
+++ b/sci-mathematics/z3/z3-4.8.13.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake-multilib java-pkg-opt-2 python-single-r1
+
+DESCRIPTION="An efficient theorem prover"
+HOMEPAGE="https://github.com/Z3Prover/z3/"
+SRC_URI="https://github.com/Z3Prover/z3/archive/${P}.tar.gz"
+S=${WORKDIR}/z3-${P}
+
+SLOT="0/4.8"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="doc examples gmp isabelle java python"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ gmp? ( dev-libs/gmp:0=[cxx(+),${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ java? ( >=virtual/jdk-1.8 )"
+BDEPEND="
+ doc? ( app-doc/doxygen )"
+
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+src_prepare() {
+ cmake_src_prepare
+ java-pkg-opt-2_src_prepare
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${P}"
+ -DZ3_USE_LIB_GMP=$(usex gmp)
+ -DZ3_ENABLE_EXAMPLE_TARGETS=OFF
+ -DZ3_BUILD_DOCUMENTATION=$(multilib_native_usex doc)
+ -DZ3_BUILD_PYTHON_BINDINGS=$(multilib_native_usex python)
+ -DZ3_BUILD_JAVA_BINDINGS=$(multilib_native_usex java)
+ -DZ3_INCLUDE_GIT_DESCRIBE=OFF
+ -DZ3_INCLUDE_GIT_HASH=OFF
+ )
+
+ multilib_is_native_abi && use java && mycmakeargs+=( -DJAVA_HOME="$(java-config -g JAVA_HOME )" )
+
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build test-z3
+ set -- "${BUILD_DIR}"/test-z3 /a
+ echo "${@}" >&2
+ "${@}" || die
+}
+
+multilib_src_install_all() {
+ dodoc README.md RELEASE_NOTES
+ use examples && dodoc -r examples
+ use python && python_optimize
+
+ if use isabelle; then
+ insinto /usr/share/Isabelle/contrib/${P}/etc
+ newins - settings <<-EOF
+ Z3_COMPONENT="\$COMPONENT"
+ Z3_HOME="${EPREFIX}/usr/bin"
+ Z3_SOLVER="${EPREFIX}/usr/bin/z3"
+ Z3_REMOTE_SOLVER="z3"
+ Z3_VERSION="${PV}"
+ Z3_INSTALLED="yes"
+ Z3_NON_COMMERCIAL="yes"
+ EOF
+ fi
+}
+
+pkg_postinst() {
+ if use isabelle; then
+ if [[ -f ${ROOT}/etc/isabelle/components ]]; then
+ sed -e "/contrib\/${PN}-[0-9.]*/d" \
+ -i "${ROOT}/etc/isabelle/components" || die
+ cat <<-EOF >> "${ROOT}/etc/isabelle/components" || die
+ contrib/${P}
+ EOF
+ fi
+ fi
+}
+
+pkg_postrm() {
+ if use isabelle; then
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ if [[ -f "${ROOT}/etc/isabelle/components" ]]; then
+ # Note: this sed should only match the version of this ebuild
+ # Which is what we want as we do not want to remove the line
+ # of a new Isabelle component being installed during an upgrade.
+ sed -e "/contrib\/${P}/d" \
+ -i "${ROOT}/etc/isabelle/components" || die
+ fi
+ fi
+ fi
+}