summaryrefslogtreecommitdiff
path: root/sci-mathematics/z3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /sci-mathematics/z3
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'sci-mathematics/z3')
-rw-r--r--sci-mathematics/z3/Manifest2
-rw-r--r--sci-mathematics/z3/z3-4.8.11.ebuild96
2 files changed, 98 insertions, 0 deletions
diff --git a/sci-mathematics/z3/Manifest b/sci-mathematics/z3/Manifest
index b309dd9d7303..52dc2747dbe8 100644
--- a/sci-mathematics/z3/Manifest
+++ b/sci-mathematics/z3/Manifest
@@ -1,3 +1,5 @@
DIST z3-4.8.10.tar.gz 4731869 BLAKE2B 92487f71a0c8d961949dc23032d8fa3ff157fe7acc29b41d0d79326f8b59c60e19f43527cccf4e51872c0f0664598f9063876b04cc581f918aa48c37a13c4f3f SHA512 d2741d7ad3e1d5ee3fec92095b061a96a700c3327b2eb2090d4162bdcaeaebca8c072ef79c5daac1f6de3456165c2cc38e13f1045bc707779d1027b943837c5b
+DIST z3-4.8.11.tar.gz 4799940 BLAKE2B 5478f9f45f2dc8ea5d2b781e79d886e77eed5ae034498b434dae349aa76f05836d8fd3134a08b381830b57acb3896ac51337d5bbe480dcce4770f2cd4fbee841 SHA512 ceab703d0413d0135e0f4e6c3ba2bb58d6a4823385edb0bf7ecc96949a3073b687d415a2674c86c9f876adb52823f98f9fbbc107d799ed756dc16292f9864894
EBUILD z3-4.8.10.ebuild 2425 BLAKE2B 23db5049ead16c9323773aa20d487b76cfb6d2126f1b93f7e507b5db93db490daf5a6a03b9a090404bd48182c0bf4a92aa3452bb9278b13cff89e235661f7e88 SHA512 3f69ea5e9b9de7dbf99ac2886791dc7947e12c9542fab93b9da9a82c8fb2273f07f5441ac54a1f5e8bc839c9f62815f95ea049e2c50e060eb11befbe676fd7ed
+EBUILD z3-4.8.11.ebuild 2430 BLAKE2B ecfd9ccb8df8578e7f2f18ebed60e95476bb7f67c95825c51d19fb50db5562bf3de65b8cbac8f868ea2bb0c1a33c4a4e3fe800800d02086b3ab76ee91261239e SHA512 7e9fea4bf7c6818f8c8035eb9ff59f1c59731f73da90dc5661709495363b1c474f8e0267fd5967a956aba7643995150b960a9d67cbf8e7568e880c4dc4c35061
MISC metadata.xml 616 BLAKE2B c35cac6f5810148c69a612d6b04ed4cacdbf066e61951ea1433336f14b2b058c4dd50530b547021007489122f5e94407b30641dc9ccf3b59a345e7a09e5fdd28 SHA512 eaf72a29601e96d5312120a1fc01a0b3dd2b7d8dbee70f6052e8ff7a7e07ae8b768d1417b7f4b523e755e5569092f2685bba77beaf3d7c455ccbd057cc9b670a
diff --git a/sci-mathematics/z3/z3-4.8.11.ebuild b/sci-mathematics/z3/z3-4.8.11.ebuild
new file mode 100644
index 000000000000..fdef20fc1775
--- /dev/null
+++ b/sci-mathematics/z3/z3-4.8.11.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit cmake-multilib python-single-r1 toolchain-funcs
+
+DESCRIPTION="An efficient theorem prover"
+HOMEPAGE="https://github.com/Z3Prover/z3/"
+SRC_URI="https://github.com/Z3Prover/z3/archive/${P}.tar.gz"
+S=${WORKDIR}/z3-${P}
+
+SLOT="0/4.8"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="doc examples gmp isabelle java python"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ gmp? ( dev-libs/gmp:0=[cxx,${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ java? ( >=virtual/jdk-1.8 )"
+BDEPEND="
+ doc? ( app-doc/doxygen )"
+
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${P}"
+ -DZ3_USE_LIB_GMP=$(usex gmp)
+ -DZ3_ENABLE_EXAMPLE_TARGETS=OFF
+ -DZ3_BUILD_DOCUMENTATION=$(multilib_native_usex doc)
+ -DZ3_BUILD_PYTHON_BINDINGS=$(multilib_native_usex python)
+ -DZ3_BUILD_JAVA_BINDINGS=$(multilib_native_usex java)
+ -DZ3_INCLUDE_GIT_DESCRIBE=OFF
+ -DZ3_INCLUDE_GIT_HASH=OFF
+ )
+
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build test-z3
+ set -- "${BUILD_DIR}"/test-z3 /a
+ echo "${@}" >&2
+ "${@}" || die
+}
+
+multilib_src_install_all() {
+ dodoc README.md RELEASE_NOTES
+ use examples && dodoc -r examples
+ use python && python_optimize
+
+ if use isabelle; then
+ insinto /usr/share/Isabelle/contrib/${P}/etc
+ newins - settings <<-EOF
+ Z3_COMPONENT="\$COMPONENT"
+ Z3_HOME="${EPREFIX}/usr/bin"
+ Z3_SOLVER="${EPREFIX}/usr/bin/z3"
+ Z3_REMOTE_SOLVER="z3"
+ Z3_VERSION="${PV}"
+ Z3_INSTALLED="yes"
+ Z3_NON_COMMERCIAL="yes"
+ EOF
+ fi
+}
+
+pkg_postinst() {
+ if use isabelle; then
+ if [[ -f ${ROOT}/etc/isabelle/components ]]; then
+ sed -e "/contrib\/${PN}-[0-9.]*/d" \
+ -i "${ROOT}/etc/isabelle/components" || die
+ cat <<-EOF >> "${ROOT}/etc/isabelle/components" || die
+ contrib/${P}
+ EOF
+ fi
+ fi
+}
+
+pkg_postrm() {
+ if use isabelle; then
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ if [[ -f "${ROOT}/etc/isabelle/components" ]]; then
+ # Note: this sed should only match the version of this ebuild
+ # Which is what we want as we do not want to remove the line
+ # of a new Isabelle component being installed during an upgrade.
+ sed -e "/contrib\/${P}/d" \
+ -i "${ROOT}/etc/isabelle/components" || die
+ fi
+ fi
+ fi
+}