summaryrefslogtreecommitdiff
path: root/sci-mathematics/z3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /sci-mathematics/z3
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'sci-mathematics/z3')
-rw-r--r--sci-mathematics/z3/Manifest2
-rw-r--r--sci-mathematics/z3/z3-4.8.9.ebuild96
2 files changed, 98 insertions, 0 deletions
diff --git a/sci-mathematics/z3/Manifest b/sci-mathematics/z3/Manifest
index 644d2eb9eccb..d189667f5fe4 100644
--- a/sci-mathematics/z3/Manifest
+++ b/sci-mathematics/z3/Manifest
@@ -1,3 +1,5 @@
DIST z3-4.8.8.tar.gz 4520119 BLAKE2B 8d3d9fac61ac7d5a9d8c44323db9f67a7b24ee510b12e67867b249062cbcfe9a3bd0fa3b24c03c9eccd2aaf90451083ff5e9a9253a87c3e8e943fc5cf08a1893 SHA512 a6823cadb7cdad11b8f0db1530676c0ec4853886dfb3c4dbc5b798c5dbd445afb0c61675f81cb7f99c1b1734d9cd0ec96a07c68a948da3c25801fc6767fea47f
+DIST z3-4.8.9.tar.gz 4624159 BLAKE2B ff97a688ef3f977cd1204ddafaf6b4ef5824fc8f9f38f0ce9a31657b99b8cb08ee5834893ac67056eb4d7f7df67585933029292eed41d140a93c10b9daa8e100 SHA512 a50da5c3f9e27d3e804c1b71f648a3dbd5a55223b7344d66f191a1b34a4d787810abd976840d3ab3878aaf5c96d89f5a517cac0781b82aa927a9d8d54836d54f
EBUILD z3-4.8.8.ebuild 2414 BLAKE2B f20a02f52a68dcc203acaa79b39efac293b45e142798c0ed362845b4897e4400be4816fd37f26f7fb54d7a824b7d7da074bf9824f76e8a8b305a789d8dfec263 SHA512 f4feff2c7c64feefa4a54c65d1c135cd2924daeb4c5276d34d3c4f2e1b4224aad0a45abf9fe4a56eea6947679938fe1e0a77b47e34d11448ddb629fc9a195f0f
+EBUILD z3-4.8.9.ebuild 2418 BLAKE2B 9d3b018ddedad2d1161fa998a783c23f1fdd385f001a963899d8a7e89827ed427dcfe6dc00b9657ecce8e7c18b39b6c246cccf0d9c222359e994b7c54ff2e266 SHA512 dc0f5b4fec387fff0d8471b11fc18d6fceb47245cbc91b8b5b0299475123a9a1ccf33f638986d309d48cb62f815922ebf28248592e1ad51b69cc641a9a60d923
MISC metadata.xml 616 BLAKE2B aeef1be6d9c4a94062310c6e2c3ac7fb1efe39bb608d96c143a01e9a01585f11ee25aa56d8f67d0a96d880b543882f2cb781247c034eda75e7f6f030767bf660 SHA512 aed4bbc517cc4f9e78ad3f5d50af5837757efa2985aa61a3faf40e39203179d356830a1d6fd4712422257eb244a67ae5eb5c4b2db76ab75769f5fe5e6d045a0c
diff --git a/sci-mathematics/z3/z3-4.8.9.ebuild b/sci-mathematics/z3/z3-4.8.9.ebuild
new file mode 100644
index 000000000000..3570ae1f1e49
--- /dev/null
+++ b/sci-mathematics/z3/z3-4.8.9.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit cmake-multilib python-single-r1 toolchain-funcs
+
+DESCRIPTION="An efficient theorem prover"
+HOMEPAGE="https://github.com/Z3Prover/z3/"
+SRC_URI="https://github.com/Z3Prover/z3/archive/${P}.tar.gz"
+S=${WORKDIR}/z3-${P}
+
+SLOT="0/4.8"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="doc examples gmp isabelle java python"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ gmp? ( dev-libs/gmp:0=[cxx,${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ java? ( >=virtual/jdk-1.8 )"
+BDEPEND="
+ doc? ( app-doc/doxygen )"
+
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${P}"
+ -DZ3_USE_LIB_GMP=$(usex gmp)
+ -DZ3_ENABLE_EXAMPLE_TARGETS=OFF
+ -DZ3_BUILD_DOCUMENTATION=$(multilib_native_usex doc)
+ -DZ3_BUILD_PYTHON_BINDINGS=$(multilib_native_usex python)
+ -DZ3_BUILD_JAVA_BINDINGS=$(multilib_native_usex java)
+ -DZ3_INCLUDE_GIT_DESCRIBE=OFF
+ -DZ3_INCLUDE_GIT_HASH=OFF
+ )
+
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build test-z3
+ set -- "${BUILD_DIR}"/test-z3 /a
+ echo "${@}" >&2
+ "${@}" || die
+}
+
+multilib_src_install_all() {
+ dodoc README.md RELEASE_NOTES
+ use examples && dodoc -r examples
+ use python && python_optimize
+
+ if use isabelle; then
+ insinto /usr/share/Isabelle/contrib/${P}/etc
+ newins - settings <<-EOF
+ Z3_COMPONENT="\$COMPONENT"
+ Z3_HOME="${EPREFIX}/usr/bin"
+ Z3_SOLVER="${EPREFIX}/usr/bin/z3"
+ Z3_REMOTE_SOLVER="z3"
+ Z3_VERSION="${PV}"
+ Z3_INSTALLED="yes"
+ Z3_NON_COMMERCIAL="yes"
+ EOF
+ fi
+}
+
+pkg_postinst() {
+ if use isabelle; then
+ if [[ -f ${ROOT}/etc/isabelle/components ]]; then
+ sed -e "/contrib\/${PN}-[0-9.]*/d" \
+ -i "${ROOT}/etc/isabelle/components" || die
+ cat <<-EOF >> "${ROOT}/etc/isabelle/components" || die
+ contrib/${P}
+ EOF
+ fi
+ fi
+}
+
+pkg_postrm() {
+ if use isabelle; then
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ if [[ -f "${ROOT}/etc/isabelle/components" ]]; then
+ # Note: this sed should only match the version of this ebuild
+ # Which is what we want as we do not want to remove the line
+ # of a new Isabelle component being installed during an upgrade.
+ sed -e "/contrib\/${P}/d" \
+ -i "${ROOT}/etc/isabelle/components" || die
+ fi
+ fi
+ fi
+}