summaryrefslogtreecommitdiff
path: root/sci-mathematics/z3/z3-4.12.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-04 05:43:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-04 05:43:10 +0000
commit57e2174dcd454b41778b7b437f88d0a9f1a6e428 (patch)
treee6f528c74cef8bdfdf1b07fbba3a70acbae6af25 /sci-mathematics/z3/z3-4.12.5.ebuild
parent0a648c5255c22a6092b8de20ffba9e235299a293 (diff)
gentoo auto-resync : 04:03:2024 - 05:43:09
Diffstat (limited to 'sci-mathematics/z3/z3-4.12.5.ebuild')
-rw-r--r--sci-mathematics/z3/z3-4.12.5.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/sci-mathematics/z3/z3-4.12.5.ebuild b/sci-mathematics/z3/z3-4.12.5.ebuild
index 646bf2695514..64ffaff192f5 100644
--- a/sci-mathematics/z3/z3-4.12.5.ebuild
+++ b/sci-mathematics/z3/z3-4.12.5.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake-multilib java-pkg-opt-2 python-single-r1
+inherit cmake-multilib flag-o-matic java-pkg-opt-2 python-single-r1
DESCRIPTION="An efficient theorem prover"
HOMEPAGE="https://github.com/Z3Prover/z3/"
@@ -37,6 +37,18 @@ src_prepare() {
java-pkg-opt-2_src_prepare
}
+src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/879327
+ # https://github.com/Z3Prover/z3/issues/7143
+ #
+ # Do not trust it with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ cmake-multilib_src_configure
+}
+
multilib_src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${PF}"