summaryrefslogtreecommitdiff
path: root/sci-mathematics/yices2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-19 01:47:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-19 01:47:04 +0000
commit8bb75334c4b9f91e9f95784e986ed31b4bc11f92 (patch)
tree8abc434e6b84ebe89eee2e7ae9687354cdf8d2c8 /sci-mathematics/yices2
parentf74222a7b6daa24caf124c66a7ce05c7ea773b08 (diff)
gentoo auto-resync : 19:12:2022 - 01:47:04
Diffstat (limited to 'sci-mathematics/yices2')
-rw-r--r--sci-mathematics/yices2/Manifest3
-rw-r--r--sci-mathematics/yices2/metadata.xml26
-rw-r--r--sci-mathematics/yices2/yices2-2.6.4.ebuild47
3 files changed, 76 insertions, 0 deletions
diff --git a/sci-mathematics/yices2/Manifest b/sci-mathematics/yices2/Manifest
new file mode 100644
index 000000000000..8203107f8a07
--- /dev/null
+++ b/sci-mathematics/yices2/Manifest
@@ -0,0 +1,3 @@
+DIST Yices-2.6.4.tar.gz 10186909 BLAKE2B 1c4b6297fd59924e9d99b9e17eb4b42e9bfbc24dcd56631beb9b72103c91578eb72b90cb9e228a5e9d489efc520a2e1d41185e9c3f4a8c43fc93f8dabba7414d SHA512 d8102c41fda0e200fd1336ae317b516d2797d10c187b8f7aecf0c9b08b4b487b90bef8c358099b2da51c0367326939f9610fd4e6d5a41a392cf1114bd04b8763
+EBUILD yices2-2.6.4.ebuild 741 BLAKE2B e1d7f1a4032bbd2d1079dc03817c87493da9ed284de22e3cfab9873ee975257eb005a395175d20acbfe4e76047da3598b082b502baf8510e067acc9d484d9f62 SHA512 f955e611c3394cb6773ec7172dfe1c2628247fee7ee3d77d4255914783eda78f1c16cf82422889db366714d6c82511610d231d5eef9059e4fb2bee5a9b0d00f1
+MISC metadata.xml 1103 BLAKE2B 1efa78a55c94698f41966873f4aaf9dc8b065fad8ddbb4d9cdec62490440f22179793edf602e26ffe84ad0bc983de9c11e22d8c75e5b4fe29bc0fb947d6040c6 SHA512 d785ee9807971857aa800896036e9a24035a17096f322ccc197cb924a61e2cc5982b4c913794e2edf0295672ce854b04dd686abc956cf625783a5a2b5aaab15d
diff --git a/sci-mathematics/yices2/metadata.xml b/sci-mathematics/yices2/metadata.xml
new file mode 100644
index 000000000000..0b8f70011239
--- /dev/null
+++ b/sci-mathematics/yices2/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription>
+ Yices 2 is an SMT solver that decides the satisfiability of formulas
+ containing uninterpreted function symbols with equality, real and integer
+ arithmetic, bitvectors, scalar types, and tuples. Yices 2 supports both
+ linear and nonlinear arithmetic. Yices 2 can process input written in the
+ SMT-LIB notation (both versions 2.0 and 1.2 are supported). Alternatively,
+ you can write specifications using Yices 2's own specification language,
+ which includes tuples and scalar types. You can also use Yices 2 as a
+ library in your software.
+ </longdescription>
+ <use>
+ <flag name="mcsat">Enable support for MCSAT</flag>
+ </use>
+ <upstream>
+ <bugs-to>https://github.com/SRI-CSL/yices2/issues/</bugs-to>
+ <remote-id type="github">SRI-CSL/yices2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-mathematics/yices2/yices2-2.6.4.ebuild b/sci-mathematics/yices2/yices2-2.6.4.ebuild
new file mode 100644
index 000000000000..8fcf3fcb619b
--- /dev/null
+++ b/sci-mathematics/yices2/yices2-2.6.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="SMT Solver supporting SMT-LIB and Yices specification language"
+HOMEPAGE="https://github.com/SRI-CSL/yices2/"
+SRC_URI="https://github.com/SRI-CSL/${PN}/archive/Yices-${PV}.tar.gz"
+S="${WORKDIR}"/${PN}-Yices-${PV}
+
+LICENSE="GPL-3+"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mcsat"
+
+RDEPEND="
+ dev-libs/gmp:=
+ mcsat? (
+ sci-mathematics/libpoly:=
+ sci-mathematics/cudd:=
+ )
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( FAQ.md README.md )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable mcsat)
+}
+
+src_compile() {
+ emake STRIP=echo
+}
+
+src_install() {
+ default
+
+ doman doc/*.1
+}