summaryrefslogtreecommitdiff
path: root/sci-mathematics/why3-for-spark/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /sci-mathematics/why3-for-spark/files
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'sci-mathematics/why3-for-spark/files')
-rw-r--r--sci-mathematics/why3-for-spark/files/why3-for-spark-2019-flags.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-mathematics/why3-for-spark/files/why3-for-spark-2019-flags.patch b/sci-mathematics/why3-for-spark/files/why3-for-spark-2019-flags.patch
new file mode 100644
index 000000000000..b562bb02cd84
--- /dev/null
+++ b/sci-mathematics/why3-for-spark/files/why3-for-spark-2019-flags.patch
@@ -0,0 +1,28 @@
+--- a/Makefile.in 2020-06-12 21:03:33.375534124 +0200
++++ b/Makefile.in 2020-06-12 21:03:48.623283408 +0200
+@@ -96,7 +96,7 @@
+
+ WARNINGS = A-4-9-41-44-45-50-52@5@8@48
+
+-OFLAGS = -w $(WARNINGS) -safe-string -keep-locs -bin-annot -dtypes -g $(INCLUDES)
++OFLAGS = -w $(WARNINGS) -safe-string -keep-locs -bin-annot -dtypes -g $(INCLUDES) -cclib "$(LDFLAGS)" -ccopt "$(CFLAGS)"
+ BFLAGS = -w $(WARNINGS) -safe-string -keep-locs -bin-annot -dtypes -g $(INCLUDES)
+
+ OLINKFLAGS = -linkall $(EXTCMXA)
+@@ -664,13 +664,13 @@
+ all: $(TOOLS)
+
+ lib/why3server$(EXE): $(SERVER_O)
+- $(CC) -Wall -o $@ $^
++ $(CC) -Wall $(CFLAGS) -o $@ $^ $(LDFLAGS)
+
+ lib/why3cpulimit$(EXE): $(CPULIM_O)
+- $(CC) -Wall -o $@ $^
++ $(CC) -Wall $(CFLAGS) -o $@ $^ $(LDFLAGS)
+
+ %.o: %.c
+- $(CC) -Wall -O -g -o $@ -c $<
++ $(CC) -Wall -O -g $(CFLAGS) -o $@ -c $<
+
+ uninstall-bin::
+ rm -f $(LIBDIR)/why3/why3server$(EXE) $(LIBDIR)/why3/why3cpulimit$(EXE)