summaryrefslogtreecommitdiff
path: root/sci-mathematics/verit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
commit0f15659d48c193027158492acb726297501202c5 (patch)
tree5502ba879a78b759da28441d418dbbfe08bd8f03 /sci-mathematics/verit
parent93a93e9a3b53c1a73142a305ea1f8136846942ee (diff)
gentoo xmass resync : 25.12.2021
Diffstat (limited to 'sci-mathematics/verit')
-rw-r--r--sci-mathematics/verit/Manifest3
-rw-r--r--sci-mathematics/verit/metadata.xml16
-rw-r--r--sci-mathematics/verit/verit-2021.06.2.ebuild26
3 files changed, 45 insertions, 0 deletions
diff --git a/sci-mathematics/verit/Manifest b/sci-mathematics/verit/Manifest
new file mode 100644
index 000000000000..33bd4ca29d74
--- /dev/null
+++ b/sci-mathematics/verit/Manifest
@@ -0,0 +1,3 @@
+DIST verit-2021.06.2-rmx.tar.gz 683775 BLAKE2B e7488ef11f37c4312dc3bb7809c8f4a134c70e0cb893a9127235e5bd660e3cf88648d5af598f650d25aed02eb864c171479a570b4e47b96ab2bb5f6aba3e6926 SHA512 4dfdbcf12fefaba13f5540a08a520e15666ca3bb923483b86eac708cf23bd5d8441d9a687487ae38f9bbdbc023beedf3e503800e99622cb71fb086329c047a4d
+EBUILD verit-2021.06.2.ebuild 508 BLAKE2B 6ac727f550f8fa0c81b70e509e2381e26eee8745b3c16f7626b0f02408bac78b0b2cd88b11c99f815f9439e0454d714254c0b3fa56ec0a063369e74048ba422a SHA512 60e00146bf88f2d93b9a5ec476568700154df6a70b67b85fe3c37bee495546cddc6942b3d5a1659c4252e1a22073d5c776452548cf1bc6d2812834d92faae80f
+MISC metadata.xml 628 BLAKE2B a23cb8e317e25706a6aef22a09639ab69d5255d624dee52234070050ce571bf41d6ad14c06808905c59632fc3fab429c4b6cabb7e06dfec08a7ebf7ff538b5bb SHA512 7d612a0cf762d81799fe3954bedd02c6d7392d20fff12bf1f515723889fec0aa59d4494c6f939c4166ad72f6ec6202b62fa9c8ff91695bc28d9d26f447c6b229
diff --git a/sci-mathematics/verit/metadata.xml b/sci-mathematics/verit/metadata.xml
new file mode 100644
index 000000000000..cd0a6cfe1019
--- /dev/null
+++ b/sci-mathematics/verit/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ veriT is a SMT (Satisfiability Modulo Theories) solver. It is open-source,
+ proof-producing, and complete for quantifier-free formulas with
+ uninterpreted functions and linear arithmetic on real numbers and integers.
+ It also offers good support for quantifiers.
+ The input format is the SMT-LIB 2.0 language and DIMACS.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-mathematics/verit/verit-2021.06.2.ebuild b/sci-mathematics/verit/verit-2021.06.2.ebuild
new file mode 100644
index 000000000000..bd4092215917
--- /dev/null
+++ b/sci-mathematics/verit/verit-2021.06.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="An open, trustable and efficient SMT-prover"
+HOMEPAGE="https://verit.loria.fr/"
+SRC_URI="https://verit.loria.fr/download/${PV}/${P}-rmx.tar.gz"
+S="${WORKDIR}/${P}-rmx"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/gmp:="
+DEPEND="${RDEPEND}"
+
+src_install() {
+ default
+
+ mv example examples || die
+ insinto /usr/share/${PN}
+ doins -r examples
+}