summaryrefslogtreecommitdiff
path: root/sci-mathematics/unuran/unuran-1.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-03 08:59:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-03 08:59:05 +0000
commite6ba529df30e3fc9dfdf55ec5797f2f764df6e54 (patch)
tree6b38c918c796f792ef4b18b57437c05a1fd46ae8 /sci-mathematics/unuran/unuran-1.9.0.ebuild
parentfbe7acf59ebf6dc3f04a6ef108ff3887fa5d7972 (diff)
gentoo auto-resync : 03:12:2022 - 08:59:05
Diffstat (limited to 'sci-mathematics/unuran/unuran-1.9.0.ebuild')
-rw-r--r--sci-mathematics/unuran/unuran-1.9.0.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sci-mathematics/unuran/unuran-1.9.0.ebuild b/sci-mathematics/unuran/unuran-1.9.0.ebuild
new file mode 100644
index 000000000000..971d2638952a
--- /dev/null
+++ b/sci-mathematics/unuran/unuran-1.9.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools out-of-source
+
+DESCRIPTION="Universal Non-Uniform Random number generator"
+HOMEPAGE="https://statmath.wu.ac.at/unuran/"
+SRC_URI="https://statmath.wu.ac.at/unuran/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples gsl prng +rngstreams"
+
+DEPEND="
+ gsl? ( sci-libs/gsl:= )
+ prng? ( sci-mathematics/prng )
+ rngstreams? ( sci-mathematics/rngstreams:= )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.9.0-configure-clang16.patch
+)
+
+src_prepare() {
+ default
+
+ # Clang 16
+ eautoreconf
+}
+
+my_src_configure() {
+ local udefault=builtin
+ use rngstreams && udefault=rngstream
+
+ CONFIG_SHELL="${BROOT}"/bin/bash econf \
+ --enable-shared \
+ --disable-static \
+ --with-urng-default="${udefault}" \
+ $(use_with gsl urng-gsl) \
+ $(use_with prng urng-prng) \
+ $(use_with rngstreams urng-rngstream)
+}
+
+my_src_install_all() {
+ use doc && dodoc doc/${PN}.pdf
+ einstalldocs
+
+ if use examples; then
+ rm examples/Makefile* || die
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}