summaryrefslogtreecommitdiff
path: root/sci-mathematics/rw/rw-0.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /sci-mathematics/rw/rw-0.9.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'sci-mathematics/rw/rw-0.9.ebuild')
-rw-r--r--sci-mathematics/rw/rw-0.9.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-mathematics/rw/rw-0.9.ebuild b/sci-mathematics/rw/rw-0.9.ebuild
new file mode 100644
index 000000000000..17031e1789f4
--- /dev/null
+++ b/sci-mathematics/rw/rw-0.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Compute rank-width decompositions of graphs"
+HOMEPAGE="https://sourceforge.net/projects/rankwidth/"
+SRC_URI="https://downloads.sourceforge.net/project/rankwidth/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE=""
+
+# We have a file collision (librw.so) with xpaint, bug 560210.
+RDEPEND="!media-gfx/xpaint"
+
+src_configure() {
+ # The executable depends on igraph, which has gone off the rails
+ # upstream and has copy/pasted ~10 libraries into its src/ directory.
+ econf --disable-executable --disable-static
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete \
+ || die 'failed to delete libtool archives'
+}