summaryrefslogtreecommitdiff
path: root/sci-mathematics/rstudio/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /sci-mathematics/rstudio/files
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'sci-mathematics/rstudio/files')
-rw-r--r--sci-mathematics/rstudio/files/rstudio-1.0.44-systemd.patch8
-rw-r--r--sci-mathematics/rstudio/files/rstudio-1.2.1335-boost-1.72-filesystem.patch31
-rw-r--r--sci-mathematics/rstudio/files/rstudio-1.2.5033-pandoc.patch32
-rw-r--r--sci-mathematics/rstudio/files/rstudio-1.2.5033-paths.patch118
-rw-r--r--sci-mathematics/rstudio/files/rstudio-1.2.5033-prefs.patch83
5 files changed, 268 insertions, 4 deletions
diff --git a/sci-mathematics/rstudio/files/rstudio-1.0.44-systemd.patch b/sci-mathematics/rstudio/files/rstudio-1.0.44-systemd.patch
index 7eafd4386abd..56601de5341c 100644
--- a/sci-mathematics/rstudio/files/rstudio-1.0.44-systemd.patch
+++ b/sci-mathematics/rstudio/files/rstudio-1.0.44-systemd.patch
@@ -1,7 +1,7 @@
---- rstudio-1.0.44-orig/src/cpp/server/CMakeLists.txt 2016-10-19 08:32:41.000000000 +1100
-+++ rstudio-1.0.44/src/cpp/server/CMakeLists.txt 2016-12-02 11:11:45.259050839 +1100
-@@ -203,17 +203,12 @@
- DESTINATION ${RSERVER_UPSTART_DIR})
+--- a/src/cpp/server/CMakeLists.txt
++++ b/src/cpp/server/CMakeLists.txt
+@@ -232,17 +232,12 @@
+ DESTINATION ${DISTRO_SHARE}/${RSERVER_UPSTART_DIR})
# install configured systemd profile
- set(RSERVER_SYSTEMD_DIR "extras/systemd")
diff --git a/sci-mathematics/rstudio/files/rstudio-1.2.1335-boost-1.72-filesystem.patch b/sci-mathematics/rstudio/files/rstudio-1.2.1335-boost-1.72-filesystem.patch
new file mode 100644
index 000000000000..b2c4d2392f6a
--- /dev/null
+++ b/sci-mathematics/rstudio/files/rstudio-1.2.1335-boost-1.72-filesystem.patch
@@ -0,0 +1,31 @@
+From a11d0454e5fe9c50005a03b9d9de84355df5c7fd Mon Sep 17 00:00:00 2001
+From: Kevin Ushey <kevinushey@gmail.com>
+Date: Fri, 15 Nov 2019 14:54:02 -0800
+Subject: [PATCH] avoid use of deprecated APIs
+
+---
+ src/cpp/core/FilePath.cpp | 4 +---
+ 1 file changed, 1 insertion(+), 3 deletions(-)
+
+diff --git a/src/cpp/shared_core/FilePath.cpp b/src/cpp/shared_core/FilePath.cpp
+index 088366a9d6..495289e7fc 100644
+--- a/src/cpp/core/FilePath.cpp
++++ b/src/cpp/core/FilePath.cpp
+@@ -22,8 +22,6 @@
+ #include <windows.h>
+ #endif
+
+-#define BOOST_FILESYSTEM_NO_DEPRECATED
+-
+ #define BOOST_NO_CXX11_SCOPED_ENUMS
+ #include <boost/filesystem.hpp>
+ #undef BOOST_NO_CXX11_SCOPED_ENUMS
+@@ -1032,7 +1030,7 @@
+ {
+ // NOTE: The path gets round-tripped through toString/fromString, would
+ // be nice to have a direct constructor
+- if (!iterationFunction(itr.level(),
++ if (!iterationFunction(itr.depth(),
+ FilePath(BOOST_FS_PATH2STR(itr->path()))))
+ {
+ // end the iteration if requested
diff --git a/sci-mathematics/rstudio/files/rstudio-1.2.5033-pandoc.patch b/sci-mathematics/rstudio/files/rstudio-1.2.5033-pandoc.patch
new file mode 100644
index 000000000000..b4f611063e17
--- /dev/null
+++ b/sci-mathematics/rstudio/files/rstudio-1.2.5033-pandoc.patch
@@ -0,0 +1,32 @@
+--- rstudio-1.2.5033-orig/src/cpp/session/CMakeLists.txt 2019-12-04 17:22:17.000000000 +1100
++++ rstudio-1.2.5033/src/cpp/session/CMakeLists.txt 2020-01-07 12:29:20.174304185 +1100
+@@ -25,9 +25,6 @@
+ if(NOT EXISTS "${RSTUDIO_DEPENDENCIES_DIR}/common/mathjax-26")
+ message(FATAL_ERROR "Mathjax 2.6 not found (re-run install-dependencies script to install)")
+ endif()
+-if(NOT EXISTS "${RSTUDIO_DEPENDENCIES_DIR}/common/pandoc")
+- message(FATAL_ERROR "pandoc not found (re-run install-dependencies script to install)")
+-endif()
+
+ # we often install embedded versions of these packages but don't do so currently
+
+@@ -490,19 +487,6 @@
+ install(DIRECTORY "resources/connections"
+ DESTINATION ${RSTUDIO_INSTALL_SUPPORTING}/resources)
+
+- # install pandoc
+- if(WIN32)
+- set(PANDOC_VERSION "2.7.2" CACHE INTERNAL "Pandoc version")
+- else()
+- set(PANDOC_VERSION "2.3.1" CACHE INTERNAL "Pandoc version")
+- endif()
+-
+- set(PANDOC_BIN "${RSTUDIO_DEPENDENCIES_DIR}/common/pandoc/${PANDOC_VERSION}")
+- file(GLOB PANDOC_FILES "${PANDOC_BIN}/pandoc*")
+- install(FILES ${PANDOC_FILES}
+- PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+- DESTINATION ${RSTUDIO_INSTALL_BIN}/pandoc)
+-
+ # install rmarkdown package
+ # file(GLOB RMARKDOWN_PACKAGE "${RSTUDIO_DEPENDENCIES_DIR}/common/rmarkdown*.tar.gz")
+ # install(FILES ${RMARKDOWN_PACKAGE}
diff --git a/sci-mathematics/rstudio/files/rstudio-1.2.5033-paths.patch b/sci-mathematics/rstudio/files/rstudio-1.2.5033-paths.patch
new file mode 100644
index 000000000000..aa6a9b23fdec
--- /dev/null
+++ b/sci-mathematics/rstudio/files/rstudio-1.2.5033-paths.patch
@@ -0,0 +1,118 @@
+--- rstudio-1.2.5033-orig/CMakeGlobals.txt 2019-12-04 17:22:17.000000000 +1100
++++ rstudio-1.2.5033/CMakeGlobals.txt 2020-01-07 12:20:19.115307754 +1100
+@@ -175,7 +175,7 @@
+ else()
+ set(RSTUDIO_INSTALL_BIN bin)
+ endif()
+- set(RSTUDIO_INSTALL_SUPPORTING .)
++ set(RSTUDIO_INSTALL_SUPPORTING ${DISTRO_SHARE})
+ endif()
+
+ # if the install prefix is /usr/local then tweak as appropriate
+--- rstudio-1.2.5033-orig/src/cpp/server/CMakeLists.txt 2019-12-04 17:22:17.000000000 +1100
++++ rstudio-1.2.5033/src/cpp/server/CMakeLists.txt 2020-01-07 12:17:32.736309024 +1100
+@@ -194,7 +194,7 @@
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_INITD_DEBIAN_SCRIPT}.in
+ ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_DEBIAN_SCRIPT})
+ install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_DEBIAN_SCRIPT}
+- DESTINATION ${RSERVER_INITD_DEBIAN_DIR})
++ DESTINATION ${DISTRO_SHARE}/${RSERVER_INITD_DEBIAN_DIR})
+
+ # install configured redhat init.d script
+ set(RSERVER_INITD_REDHAT_DIR "extras/init.d/redhat")
+@@ -202,7 +202,7 @@
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_INITD_REDHAT_SCRIPT}.in
+ ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_REDHAT_SCRIPT})
+ install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_REDHAT_SCRIPT}
+- DESTINATION ${RSERVER_INITD_REDHAT_DIR})
++ DESTINATION ${DISTRO_SHARE}/${RSERVER_INITD_REDHAT_DIR})
+
+ # install configured suse init.d script
+ set(RSERVER_INITD_SUSE_DIR "extras/init.d/suse")
+@@ -210,13 +210,13 @@
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_INITD_SUSE_SCRIPT}.in
+ ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_SUSE_SCRIPT})
+ install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_SUSE_SCRIPT}
+- DESTINATION ${RSERVER_INITD_SUSE_DIR})
++ DESTINATION ${DISTRO_SHARE}/${RSERVER_INITD_SUSE_DIR})
+
+ # install pam profile
+ set(RSERVER_PAM_DIR "extras/pam")
+ set(RSERVER_PAM_PROFILE "${RSERVER_PAM_DIR}/rstudio")
+ install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_PAM_PROFILE}
+- DESTINATION ${RSERVER_PAM_DIR})
++ DESTINATION ${DISTRO_SHARE}/${RSERVER_PAM_DIR})
+
+ # install configured upstart profile
+ set(RSERVER_UPSTART_DIR "extras/upstart")
+@@ -224,12 +224,12 @@
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_UPSTART_PROFILE}.in
+ ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_UPSTART_PROFILE})
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_UPSTART_PROFILE}
+- DESTINATION ${RSERVER_UPSTART_DIR})
++ DESTINATION ${DISTRO_SHARE}/${RSERVER_UPSTART_DIR})
+ set(RSERVER_UPSTART_PROFILE_REDHAT "${RSERVER_UPSTART_DIR}/rstudio-server.redhat.conf")
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_UPSTART_PROFILE_REDHAT}.in
+ ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_UPSTART_PROFILE_REDHAT})
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_UPSTART_PROFILE_REDHAT}
+- DESTINATION ${RSERVER_UPSTART_DIR})
++ DESTINATION ${DISTRO_SHARE}/${RSERVER_UPSTART_DIR})
+
+ # install configured systemd profile
+ set(RSERVER_SYSTEMD_DIR "extras/systemd")
+--- rstudio-1.2.5033-orig/src/cpp/server/ServerOptions.cpp 2019-12-04 17:22:17.000000000 +1100
++++ rstudio-1.2.5033/src/cpp/server/ServerOptions.cpp 2020-01-07 12:17:32.773309023 +1100
+@@ -389,8 +389,8 @@
+
+ // convert relative paths by completing from the system installation
+ // path (this allows us to be relocatable)
+- resolvePath(resourcePath, &wwwLocalPath_);
+- resolvePath(resourcePath, &wwwSymbolMapsPath_);
++ resolvePath(resourcePath.childPath(DISTRO_SHARE), &wwwLocalPath_);
++ resolvePath(resourcePath.childPath(DISTRO_SHARE), &wwwSymbolMapsPath_);
+ resolvePath(binaryPath, &authPamHelperPath_);
+ resolvePath(binaryPath, &rsessionPath_);
+ resolvePath(binaryPath, &rldpathPath_);
+--- rstudio-1.2.5033-orig/src/cpp/session/SessionOptions.cpp 2019-12-04 17:22:17.000000000 +1100
++++ rstudio-1.2.5033/src/cpp/session/SessionOptions.cpp 2020-01-07 12:17:32.774309023 +1100
+@@ -53,7 +53,7 @@
+ namespace session {
+
+ namespace {
+-const char* const kDefaultPandocPath = "bin/pandoc";
++const char* const kDefaultPandocPath = "bin";
+ const char* const kDefaultPostbackPath = "bin/postback/rpostback";
+ const char* const kDefaultRsclangPath = "bin/rsclang";
+
+@@ -571,14 +571,14 @@
+ }
+
+ // convert relative paths by completing from the app resource path
+- resolvePath(resourcePath_, &rResourcesPath_);
+- resolvePath(resourcePath_, &agreementFilePath_);
+- resolvePath(resourcePath_, &wwwLocalPath_);
+- resolvePath(resourcePath_, &wwwSymbolMapsPath_);
+- resolvePath(resourcePath_, &coreRSourcePath_);
+- resolvePath(resourcePath_, &modulesRSourcePath_);
+- resolvePath(resourcePath_, &sessionLibraryPath_);
+- resolvePath(resourcePath_, &sessionPackageArchivesPath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &rResourcesPath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &agreementFilePath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &wwwLocalPath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &wwwSymbolMapsPath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &coreRSourcePath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &modulesRSourcePath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &sessionLibraryPath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &sessionPackageArchivesPath_);
+ resolvePostbackPath(resourcePath_, &rpostbackPath_);
+ #ifdef _WIN32
+ resolvePath(resourcePath_, &consoleIoPath_);
+@@ -611,7 +611,7 @@
+ }
+ winptyPath_ = pty.complete(completion).absolutePath();
+ #endif // _WIN32
+- resolvePath(resourcePath_, &hunspellDictionariesPath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &hunspellDictionariesPath_);
+ resolvePath(resourcePath_, &mathjaxPath_);
+ resolvePath(resourcePath_, &libclangHeadersPath_);
+ resolvePandocPath(resourcePath_, &pandocPath_);
diff --git a/sci-mathematics/rstudio/files/rstudio-1.2.5033-prefs.patch b/sci-mathematics/rstudio/files/rstudio-1.2.5033-prefs.patch
new file mode 100644
index 000000000000..034eba37a8b9
--- /dev/null
+++ b/sci-mathematics/rstudio/files/rstudio-1.2.5033-prefs.patch
@@ -0,0 +1,83 @@
+--- rstudio-1.2.5033-orig/src/gwt/build.xml 2019-12-04 17:22:17.000000000 +1100
++++ rstudio-1.2.5033/src/gwt/build.xml 2020-01-10 18:35:29.913030923 +1100
+@@ -28,17 +28,35 @@
+ classname="com.google.javascript.jscomp.ant.CompileTask"
+ classpath="${tools.dir}/compiler/compiler.jar"/>
+
++ <!-- Configure path to aopalliance -->
++ <property name="aopalliance.sdk" value="@GENTOO_PORTAGE_EPREFIX@/usr/share/aopalliance-1/lib"/>
++
++ <!-- Configure path to javax-inject -->
++ <property name="javax.inject" value="@GENTOO_PORTAGE_EPREFIX@/usr/share/javax-inject/lib"/>
++
++ <!-- Configure path to validation-api -->
++ <property name="validation.api" value="@GENTOO_PORTAGE_EPREFIX@/usr/share/validation-api-1.0/lib"/>
++ <property name="validation.api.sources" value="@GENTOO_PORTAGE_EPREFIX@/usr/share/validation-api-1.0/sources"/>
++
+ <!-- Configure path to GWT SDK -->
+- <property name="gwt.sdk" value="${lib.dir}/gwt/2.8.1"/>
++ <property name="gwt.sdk" value="@GENTOO_PORTAGE_EPREFIX@/usr/share/gwt-2.8/lib"/>
++
++ <!-- Configure path to Google Gin -->
++ <property name="gin.sdk" value="@GENTOO_PORTAGE_EPREFIX@/usr/share/gin-2.1/lib"/>
+
+ <property name="gwt.extra.args" value=""/>
+ <property name="gwt.main.module" value="org.rstudio.studio.RStudio"/>
+ <property name="ace.bin" value="${src.dir}/org/rstudio/studio/client/workbench/views/source/editors/text/ace"/>
++ <property environment="env"/>
+
+ <path id="project.class.path">
+ <pathelement location="${build.dir}"/>
++ <fileset dir="${aopalliance.sdk}" includes="*.jar"/>
++ <fileset dir="${javax.inject}" includes="*.jar"/>
++ <fileset dir="${validation.api}" includes="*.jar"/>
++ <fileset dir="${validation.api.sources}" includes="*.zip"/>
+ <fileset dir="${gwt.sdk}" includes="*.jar"/>
+- <fileset dir="${lib.dir}/gin/2.1.2" includes="*.jar"/>
++ <fileset dir="${gin.sdk}" includes="*.jar"/>
+ </path>
+
+ <path id="test.class.path">
+@@ -112,8 +130,10 @@
+ <pathelement location="${src.dir}"/>
+ <path refid="project.class.path"/>
+ </classpath>
++ <jvmarg value="-Duser.home=${env.T}"/>
+ <!-- add jvmarg -Xss16M or similar if you see a StackOverflowError -->
+ <jvmarg value="-Xmx1536M"/>
++ <jvmarg value="-Djava.util.prefs.userRoot=${env.T}"/>
+ <arg value="-war"/>
+ <arg value="${www.dir}"/>
+ <arg value="-localWorkers"/>
+@@ -154,6 +174,7 @@
+ <pathelement location="${src.dir}"/>
+ <path refid="project.class.path"/>
+ </classpath>
++ <jvmarg value="-Duser.home=${env.T}"/>
+ <jvmarg value="-Xmx2048M"/>
+ <arg value="-style"/>
+ <arg value="PRETTY"/>
+@@ -176,6 +197,7 @@
+ <pathelement location="src"/>
+ <path refid="project.class.path"/>
+ </classpath>
++ <jvmarg value="-Duser.home=${env.T}"/>
+ <jvmarg value="-Xmx2048M"/>
+ <arg value="-style"/>
+ <arg value="PRETTY"/>
+@@ -202,6 +224,7 @@
+ <pathelement location="src"/>
+ <path refid="project.class.path"/>
+ </classpath>
++ <jvmarg value="-Duser.home=${env.T}"/>
+ <jvmarg value="-Xmx2048M"/>
+ <arg value="-src"/>
+ <arg value = "src"/>
+@@ -237,6 +260,7 @@
+ <pathelement location="${test.dir}"/>
+ <pathelement location="${src.dir}"/>
+ </classpath>
++ <jvmarg value="-Duser.home=${env.T}"/>
+ <classpath refid="project.class.path"/>
+ <classpath refid="unittest.class.path"/>
+ <arg value="org.rstudio.studio.client.RStudioUnitTestSuite"/>