summaryrefslogtreecommitdiff
path: root/sci-mathematics/relational
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
commit53cba99042fa967e2a93da9f8db806fe2d035543 (patch)
tree9780d3b87dfc6bdebc6b7b7d15af1ecb813c6853 /sci-mathematics/relational
parent71deace00d1a2b091313fe137ab7092418c6f87c (diff)
gentoo resync : 17.02.2020
Diffstat (limited to 'sci-mathematics/relational')
-rw-r--r--sci-mathematics/relational/Manifest3
-rw-r--r--sci-mathematics/relational/files/relational-2.5-no-qtwebkit.patch67
-rw-r--r--sci-mathematics/relational/relational-2.5-r2.ebuild (renamed from sci-mathematics/relational/relational-2.5-r1.ebuild)15
3 files changed, 77 insertions, 8 deletions
diff --git a/sci-mathematics/relational/Manifest b/sci-mathematics/relational/Manifest
index c8874d38af75..3ffe6174750f 100644
--- a/sci-mathematics/relational/Manifest
+++ b/sci-mathematics/relational/Manifest
@@ -1,3 +1,4 @@
+AUX relational-2.5-no-qtwebkit.patch 3307 BLAKE2B d0a1c4aa6261e5f52017b73e6d3ab8d689d328cca2ce9af1af3ee916edd52f99a6f5782b5a5abc723589d8b11ab04c088e0d80a89306a105da55eb59941d6c78 SHA512 9ac91976ec18b87647767f6cff525fa32c0e35749a04ed9d280016ee3b0346f12fd341b22e36a8fa97650058c12b858dbbcdd0c3c1964f554342bc8ef6d059c2
DIST relational_2.5.orig.tar.gz 118776 BLAKE2B bec1a8c1a3c7973b9200f9a61e65aa144998558a9798e1e869d970ba15d2f7970be8dad865cfa779f05ee535638011851534a3be0c354d216eb35f38f135cb4d SHA512 588e35a57cf915e544d62749b76ed81927ac06fd88271f0d4d88ee5f221928c2c24e2a88165aae63c1b9b120ddaa20e15e21fe9c207eac3150b744274ae45a8a
-EBUILD relational-2.5-r1.ebuild 905 BLAKE2B b925e6d77fe89dc7519e8fa290754b363a838491e8e173a55895e8c4e08a12a3a7849aa31768cd54b4570e88262f40670ce90ba4c37ce3d4dfd71a1cb42d68ce SHA512 778b625db7a3ee0968d671c4d0689271d27df1a6a601d3717d2fb13ddf78ed3b6d1d6eb70ec4cbff47a1d46a825a44c085b67c8a566bbf8da87407a89089c50b
+EBUILD relational-2.5-r2.ebuild 954 BLAKE2B 61b017a58df97d872622fe205bf2c8e57a2c6760653bfd0330c3f650e24ad08beac4e3023db3a55d24686a59f2a7bceef1e0645a32d072041546869c31dcc22a SHA512 f98aecb3a83a37746c5dd4ccb22f805f52e0f59b46be3c8cdfd820c734c1c653a3e9b42daf765c49545db88d0746bb7b5176c1487763226298298155519e7940
MISC metadata.xml 329 BLAKE2B 72059e28c196f127a1c314ad5c63025937a9daf16e8457885da10c94c32ccffec36d4c5049f2dcf2faf9ae67fe934d334a7235bc0f2bec0836614362cd41d122 SHA512 18759433ae0bb33800dc14a9bd518bbd383b8bbdbf876b02dad81afcabe3f0eea7828bd6820989e13253d73c70528d2a3bb4637e5e28d2fa5aab28b84aecdf32
diff --git a/sci-mathematics/relational/files/relational-2.5-no-qtwebkit.patch b/sci-mathematics/relational/files/relational-2.5-no-qtwebkit.patch
new file mode 100644
index 000000000000..092b4a58e37e
--- /dev/null
+++ b/sci-mathematics/relational/files/relational-2.5-no-qtwebkit.patch
@@ -0,0 +1,67 @@
+From bcdf81cdcd7fe531e11cb1db55e63468b7d73d47 Mon Sep 17 00:00:00 2001
+From: Salvo 'LtWorf' Tomaselli <tiposchi@tiscali.it>
+Date: Sat, 26 Aug 2017 17:51:04 +0200
+Subject: [PATCH] Remove embedded browser with website
+
+---
+ relational_gui/about.py | 32 --------------------------------
+ 1 file changed, 32 deletions(-)
+
+diff --git a/relational_gui/about.py b/relational_gui/about.py
+index 4c03c99..55abfc9 100644
+--- a/relational_gui/about.py
++++ b/relational_gui/about.py
+@@ -18,12 +18,6 @@
+
+ from PyQt5 import QtCore, QtGui, QtWidgets
+
+-try: # If QtWebKit is available, uses it
+- from PyQt5 import QtWebKitWidgets
+- webk = True
+-except:
+- webk = False
+-
+ version = 0
+
+
+@@ -85,31 +79,7 @@ def setupUi(self, Dialog):
+ self.tab_2.setObjectName("tab_2")
+ self.verticalLayout_7 = QtWidgets.QVBoxLayout(self.tab_2)
+ self.verticalLayout_7.setObjectName("verticalLayout_7")
+- if (webk):
+- self.webView = QtWebKitWidgets.QWebView(self.tab_2)
+- self.webView.setUrl(
+- QtCore.QUrl("http://ltworf.github.io/relational/allowed_expressions.html"))
+- self.webView.setObjectName("webView")
+- self.verticalLayout_7.addWidget(self.webView)
+- else:
+- self.webLink = QtWidgets.QLabel(self.groupBox)
+- self.webLink.setFont(font)
+- self.webLink.setObjectName("lblLink")
+- self.webLink.setText(QtWidgets.QApplication.translate(
+- "Dialog", "<a href=\"http://ltworf.github.io/relational/\">Relational's website</a>", None,))
+- self.webLink.setOpenExternalLinks(True)
+- self.webLink.setTextFormat(QtCore.Qt.AutoText)
+- self.webLink.setTextInteractionFlags(
+- QtCore.Qt.LinksAccessibleByKeyboard |
+- QtCore.Qt.LinksAccessibleByMouse |
+- QtCore.Qt.TextBrowserInteraction |
+- QtCore.Qt.TextSelectableByKeyboard |
+- QtCore.Qt.TextSelectableByMouse
+- )
+-
+- self.verticalLayout_7.addWidget(self.webLink)
+
+- self.tabWidget.addTab(self.tab_2, "")
+ self.verticalLayout_2.addWidget(self.tabWidget)
+ self.buttonBox = QtWidgets.QDialogButtonBox(Dialog)
+ self.buttonBox.setOrientation(QtCore.Qt.Horizontal)
+@@ -294,8 +264,6 @@ def retranslateUi(self, Dialog):
+ "<p style=\" margin-top:12px; margin-bottom:12px; margin-left:0px; margin-right:0px; -qt-block-indent:0; text-indent:0px;\">The GNU General Public License does not permit incorporating your program into proprietary programs. If your program is a subroutine library, you may consider it more useful to permit linking proprietary applications with the library. If this is what you want to do, use the GNU Lesser General Public License instead of this License. But first, please read &lt;http://www.gnu.org/philosophy/why-not-lgpl.html&gt;. </p></body></html>", None))
+ self.tabWidget.setTabText(self.tabWidget.indexOf(self.License), QtWidgets.QApplication.translate(
+ "Dialog", "License", None))
+- self.tabWidget.setTabText(self.tabWidget.indexOf(self.tab_2), QtWidgets.QApplication.translate(
+- "Dialog", "Docs", None))
+
+
+ if __name__ == "__main__":
diff --git a/sci-mathematics/relational/relational-2.5-r1.ebuild b/sci-mathematics/relational/relational-2.5-r2.ebuild
index 5bb400c2b91d..0e073dfe0999 100644
--- a/sci-mathematics/relational/relational-2.5-r1.ebuild
+++ b/sci-mathematics/relational/relational-2.5-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit python-single-r1
@@ -16,17 +16,18 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="
- ${PYTHON_DEPS}
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
$(python_gen_cond_dep '
- dev-python/PyQt5[gui,webkit,widgets,${PYTHON_MULTI_USEDEP}]
+ dev-python/PyQt5[gui,widgets,${PYTHON_MULTI_USEDEP}]
')
"
RDEPEND="${DEPEND}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+S="${WORKDIR}/${PN}"
-S=${WORKDIR}/${PN}
+PATCHES=( "${FILESDIR}/${P}-no-qtwebkit.patch" )
src_prepare() {
default