summaryrefslogtreecommitdiff
path: root/sci-mathematics/pymc3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /sci-mathematics/pymc3
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'sci-mathematics/pymc3')
-rw-r--r--sci-mathematics/pymc3/Manifest3
-rw-r--r--sci-mathematics/pymc3/metadata.xml19
-rw-r--r--sci-mathematics/pymc3/pymc3-3.1-r1.ebuild58
3 files changed, 0 insertions, 80 deletions
diff --git a/sci-mathematics/pymc3/Manifest b/sci-mathematics/pymc3/Manifest
deleted file mode 100644
index b8c95da67934..000000000000
--- a/sci-mathematics/pymc3/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST pymc3-3.1.tar.gz 34553828 BLAKE2B 73c4d50f7d656322fa1a7384aefa1f46caacccc8055138fefc27a82d765866efb9d4853a842a2df312058c558edd66b37a40295904c86f023f8fec5503877206 SHA512 30799d9c1b670adbcf5cc1463029d71a87c7b917e83b1f6cb453d75553616da7173421e7ae6e31b332c85f8170daea735344ff83ba6605cf3b15cf79c5c4fb97
-EBUILD pymc3-3.1-r1.ebuild 1433 BLAKE2B efcce10b67f51d4379a3e15c458513b5c058371c148f4f879a5b2d45c3c6d7a87f5228da33ed5526bc65c270e02f161341ff1a39667a5f07bddf730c691145a7 SHA512 a4dd49af5c79fd3521e24f2750187693f1256d97267eb06803ecdcc83a0ab39eb027460a574fff959cec88e622dba3f682105f5555196d2279aa128fec9571ca
-MISC metadata.xml 740 BLAKE2B 2c56161497137f40e0e25e85299af90c361ddbcaccb4436747ba111e725c9a881fdf88944dd0208909275bf4013b9e1d5983b590ad7f46589f584549288aa02c SHA512 c75ed4b57479fef93c4b667792cb284212f859532697c4d4876e2dc23ab13d2c470143d3236de03e741a0797049a12d3a7e2f0d2ae4f07b2cfb0b7943c78526d
diff --git a/sci-mathematics/pymc3/metadata.xml b/sci-mathematics/pymc3/metadata.xml
deleted file mode 100644
index 4476cda6eeea..000000000000
--- a/sci-mathematics/pymc3/metadata.xml
+++ /dev/null
@@ -1,19 +0,0 @@
-<?xml version='1.0' encoding='UTF-8'?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci-mathematics@gentoo.org</email>
- <name>Gentoo Mathematics Project</name>
- </maintainer>
- <longdescription lang="en">
- PyMC3 is a Python package for Bayesian statistical modeling and
- Probabilistic Machine Learning which focuses on advanced Markov
- chain Monte Carlo and variational fitting algorithms. Its
- flexibility and extensibility make it applicable to a large suite
- of problems.
- </longdescription>
- <upstream>
- <remote-id type="github">pymc-devs/pymc3</remote-id>
- <remote-id type="pypi">pymc3</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/sci-mathematics/pymc3/pymc3-3.1-r1.ebuild b/sci-mathematics/pymc3/pymc3-3.1-r1.ebuild
deleted file mode 100644
index b631808b810e..000000000000
--- a/sci-mathematics/pymc3/pymc3-3.1-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1 virtualx xdg-utils
-
-MYP=${P/_}
-S="${WORKDIR}/${MYP}"
-
-DESCRIPTION="Bayesian Modeling and Probabilistic Machine Learning in Python"
-HOMEPAGE="http://pymc-devs.github.io/pymc3/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MYP}.tar.gz"
-
-SLOT=0
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-LICENSE="AFL-3.0"
-
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/joblib-0.9[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.11[${PYTHON_USEDEP},lapack]
- >=dev-python/matplotlib-1.5[${PYTHON_USEDEP}]
- dev-python/nbsphinx[${PYTHON_USEDEP}]
- dev-python/numpydoc[${PYTHON_USEDEP}]
- >=dev-python/pandas-0.18[${PYTHON_USEDEP}]
- >=dev-python/patsy-0.4[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/theano-0.9[${PYTHON_USEDEP}]
- >=dev-python/tqdm-4.8.4[${PYTHON_USEDEP}]
- >=sci-libs/scipy-0.12[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/nose-parameterized[${PYTHON_USEDEP}]
- )
-"
-
-DOCS=(CONTRIBUTING.md RELEASE-NOTES.md
- CONDUCT.md GOVERNANCE.md README.rst)
-
-python_prepare_all() {
- xdg_environment_reset
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- echo 'backend: agg' > matplotlibrc || die
- virtx esetup.py test
-}