summaryrefslogtreecommitdiff
path: root/sci-mathematics/primecount
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sci-mathematics/primecount
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sci-mathematics/primecount')
-rw-r--r--sci-mathematics/primecount/Manifest4
-rw-r--r--sci-mathematics/primecount/primecount-7.2-r1.ebuild7
-rw-r--r--sci-mathematics/primecount/primecount-7.3.ebuild54
3 files changed, 63 insertions, 2 deletions
diff --git a/sci-mathematics/primecount/Manifest b/sci-mathematics/primecount/Manifest
index 2f35f77542ca..625ec02d6d42 100644
--- a/sci-mathematics/primecount/Manifest
+++ b/sci-mathematics/primecount/Manifest
@@ -1,3 +1,5 @@
DIST primecount-7.2.tar.gz 340799 BLAKE2B 5ce3661e322be363e2fe79de1dd134b5c3009269cbb10d36dc69bee4c23c9f41d2117b3ed7aa4c5f852e494832573c84a8d9c37cbe92cf80a5024bdec9b22c69 SHA512 df14929012434eddfab94410ba9165642094327f8abd139a6a1ba87e508bba56df91cb0dc9411e873e90a9aa4aa3ba4007396c930d593f5954be8c715fa26e84
-EBUILD primecount-7.2-r1.ebuild 1162 BLAKE2B 3762ecc48997417bc29d95ce19559dba9f07480c842515193851502d648b7030520c883c9b0fe300491f7dafad58ee42dbdea200a50478dba51d9a745cf633ef SHA512 28c2dd35b0f7ef386fbe93ddf003b571abd43fe52735bf3fe7677ea207e1a874ad486501729fe7e228b487ed90c44df1583378658469a46482e92f7bfcf6b45f
+DIST primecount-7.3.tar.gz 360921 BLAKE2B 0d9ad7c791dba12b05e4c88703dc4bfc1f557a1443c8430f3921f1a6e99b740b437cb53f39e832d69c4148b597960b028e0f38e4f4d96e50434b1d020f4ea620 SHA512 56dcae60460c88368214e01f8e3618e6b61b13f2730bfd1f281721ef71d6136308ba6832e4bd25a1885e2c6142009c5772d6102f82c65e8522e990cb62c55e71
+EBUILD primecount-7.2-r1.ebuild 1277 BLAKE2B 92be849a95a336efd085be960af5ba8b6eceb1176db1e981f0c3f629767553a050e8e77bb966ab70930fc26b2df1ffa92537d1a2fcaebaa02221f68d7de6a656 SHA512 a7b515467366778defc734ae31fdea8cf32e2218ab85aa80f6bbbd082e9ff24056b3e9b01d232dbf76f4565c139f3f85f65ac6842dc8d9cae8cc08c9aa2bfcfc
+EBUILD primecount-7.3.ebuild 1278 BLAKE2B 6426ba4758d2551012983af953ca5235726d8d5c7b1c95fa9e2a7a1179077836a9fbe13a931308dcd17e20a6ebff1cbca9b8d1992217b01680d86cbd4795fb3b SHA512 0758650223b753382d87ce94943bfa152fc6f530cbe3870b8811e325075512ffda8e955e606430074f9c0d89064645c81e8b4114e2e1e3a9b4b21525387f39e5
MISC metadata.xml 674 BLAKE2B 2d8321166afee1e9d0a20723ae6849f17a7ef0d5d474dc3ec0b1650519b197ad5b1360641faa6985a60121501741a137812b8bcf03cd708766278a1b014615f7 SHA512 7a4fa0c1cae4880bdc230065c98ec46dfb5f1b1adae6ffa5eac275f6f04f38ce0c24042e62f5aac6117f9f816890244daec8fb1c920ec4b6a0a124385e5d7e33
diff --git a/sci-mathematics/primecount/primecount-7.2-r1.ebuild b/sci-mathematics/primecount/primecount-7.2-r1.ebuild
index f84b7b7ea831..617ab1e08c27 100644
--- a/sci-mathematics/primecount/primecount-7.2-r1.ebuild
+++ b/sci-mathematics/primecount/primecount-7.2-r1.ebuild
@@ -8,6 +8,7 @@ inherit cmake toolchain-funcs
DESCRIPTION="Highly optimized CLI and library to count primes"
HOMEPAGE="https://github.com/kimwalisch/primecount"
SRC_URI="https://github.com/kimwalisch/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
LICENSE="BSD-2"
SLOT="0/7" # subslot is first component of libprimecount.so version
KEYWORDS="amd64"
@@ -32,7 +33,11 @@ DOCS=(
)
pkg_pretend() {
- use openmp && tc-check-openmp
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_configure() {
diff --git a/sci-mathematics/primecount/primecount-7.3.ebuild b/sci-mathematics/primecount/primecount-7.3.ebuild
new file mode 100644
index 000000000000..eb88741f1621
--- /dev/null
+++ b/sci-mathematics/primecount/primecount-7.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake toolchain-funcs
+
+DESCRIPTION="Highly optimized CLI and library to count primes"
+HOMEPAGE="https://github.com/kimwalisch/primecount"
+SRC_URI="https://github.com/kimwalisch/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/7" # subslot is first component of libprimecount.so version
+KEYWORDS="~amd64"
+IUSE="cpu_flags_x86_popcnt +executable openmp test"
+RESTRICT="!test? ( test )"
+
+DEPEND="sci-mathematics/primesieve:="
+RDEPEND="${DEPEND}"
+
+DOCS=(
+ ChangeLog
+ README.md
+ doc/Credits.md
+ doc/Easy-Special-Leaves.md
+ doc/Hard-Special-Leaves.md
+ doc/Records.md
+ doc/References.md
+ doc/alpha-factor-dr.pdf
+ doc/alpha-factor-gourdon.pdf
+ doc/alpha-factor-lmo.pdf
+ doc/libprimecount.md
+)
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_LIBPRIMESIEVE="OFF"
+ -DBUILD_PRIMECOUNT="$(usex executable)"
+ -DBUILD_STATIC_LIBS="OFF"
+ -DBUILD_TESTS="$(usex test)"
+ -DWITH_OPENMP="$(usex openmp)"
+ -DWITH_POPCNT="$(usex cpu_flags_x86_popcnt)"
+ )
+
+ cmake_src_configure
+}