summaryrefslogtreecommitdiff
path: root/sci-mathematics/plfit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-23 02:57:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-23 02:57:53 +0100
commit24c53d42e0294f4f6e36fbb051891af86c9ae503 (patch)
treeb0af743b9df96807807fc6a16e77af239820b0c3 /sci-mathematics/plfit
parent351b26cfd42c558fa0f8eef51960c87bb0674026 (diff)
gentoo auto-resync : 23:05:2023 - 02:57:53
Diffstat (limited to 'sci-mathematics/plfit')
-rw-r--r--sci-mathematics/plfit/Manifest3
-rw-r--r--sci-mathematics/plfit/metadata.xml13
-rw-r--r--sci-mathematics/plfit/plfit-0.9.3.ebuild33
3 files changed, 49 insertions, 0 deletions
diff --git a/sci-mathematics/plfit/Manifest b/sci-mathematics/plfit/Manifest
new file mode 100644
index 000000000000..bda12d5b0023
--- /dev/null
+++ b/sci-mathematics/plfit/Manifest
@@ -0,0 +1,3 @@
+DIST plfit-0.9.3.tar.gz 178880 BLAKE2B 611c4d30fa39cb05f8324670c484fd504abf2b1638602f5fede31438bf831f8aa3d7f3a5c6f2edbab377c99bf5f67763149f288581778fdd2fe9a1596a0d4a23 SHA512 6ca0fab75f607b27801576ff6752002079e11c736d0c3f6a669f20bb2869a254aa3ba124a5f6df1ad1daed25c59c8b0952838478cd42570e6d399958f0796e84
+EBUILD plfit-0.9.3.ebuild 947 BLAKE2B dd78d8fe7937eca58a596b5ae3216f1053e60f587437cd9ae62e965bfe484bb9cdc57ff090ab4863a67b5cc1e076f5bcc18816bf1b154395feedc7a478eee57a SHA512 4ece313c32b3f2d250a546c6ca6c8c52fea9d8b0383ae03ed8384ae83b4693676b13f1b5f824db862fd1102c42697471c4d2032b4b89bd5bc7fa6cf3312cbc28
+MISC metadata.xml 392 BLAKE2B ed6840c2dcf1c2f20ff69f94c0926a82b7aef46af87cfe1161a59a85da16d7c304704e0dd8ba10dda031f8b7618fffa9b6f45ecd6af898b47e3c3abe06494b3f SHA512 dc2f5c8b458bb59b6f602507272aca5bb160f89f400b0cc9a77ae5b93b2c6e141eb2a4bcdb6a2162d1f994d21e31eb90367b129e1b019f4860658eb62647b1db
diff --git a/sci-mathematics/plfit/metadata.xml b/sci-mathematics/plfit/metadata.xml
new file mode 100644
index 000000000000..fad11365ac2d
--- /dev/null
+++ b/sci-mathematics/plfit/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ntamas/plfit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-mathematics/plfit/plfit-0.9.3.ebuild b/sci-mathematics/plfit/plfit-0.9.3.ebuild
new file mode 100644
index 000000000000..f5c15c46b845
--- /dev/null
+++ b/sci-mathematics/plfit/plfit-0.9.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Fit power-law distributions to empirical data"
+HOMEPAGE="https://github.com/ntamas/plfit"
+SRC_URI="https://github.com/ntamas/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
+# plfit is gpl-2 and its source headers say "or later." The upstream
+# doc/ directory contains MIT and BSD licenses for two components.
+LICENSE="BSD GPL-2+ MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cpu_flags_x86_sse cpu_flags_x86_sse2"
+
+DOCS=( CHANGELOG.md README.rst doc/THANKS )
+
+src_configure() {
+ local mycmakeargs=(
+ -DPLFIT_COMPILE_PYTHON_MODULE=OFF
+ -DPLFIT_USE_SSE=OFF
+ -DPLFIT_USE_OPENMP=OFF
+ )
+ if use cpu_flags_x86_sse || use cpu_flags_x86_sse2; then
+ # plfit chooses which to use at compile time based on the
+ # constants __SSE__ and __SSE2__.
+ mycmakeargs+=( -DPLFIT_USE_SSE=ON )
+ fi
+ cmake_src_configure
+}