summaryrefslogtreecommitdiff
path: root/sci-mathematics/octave/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /sci-mathematics/octave/files
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'sci-mathematics/octave/files')
-rw-r--r--sci-mathematics/octave/files/octave-4.2.0-imagemagick.patch139
-rw-r--r--sci-mathematics/octave/files/octave-4.2.0-pkgbuilddir.patch41
-rw-r--r--sci-mathematics/octave/files/octave-4.2.0-texi.patch11
-rw-r--r--sci-mathematics/octave/files/octave-4.2.0-zlib-underlinking.patch10
-rw-r--r--sci-mathematics/octave/files/octave-4.2.2-fix-qscintilla-detection.patch14
-rw-r--r--sci-mathematics/octave/files/octave-4.2.2-imagemagick-configure.patch16
-rw-r--r--sci-mathematics/octave/files/octave-4.4.0-imagemagick-configure.patch16
-rw-r--r--sci-mathematics/octave/files/octave-4.4.0-imagemagick.patch22
-rw-r--r--sci-mathematics/octave/files/octave-4.4.0-qt-5.11.patch10
9 files changed, 0 insertions, 279 deletions
diff --git a/sci-mathematics/octave/files/octave-4.2.0-imagemagick.patch b/sci-mathematics/octave/files/octave-4.2.0-imagemagick.patch
deleted file mode 100644
index 8fb786964c20..000000000000
--- a/sci-mathematics/octave/files/octave-4.2.0-imagemagick.patch
+++ /dev/null
@@ -1,139 +0,0 @@
---- a/libinterp/corefcn/__magick_read__.cc
-+++ b/libinterp/corefcn/__magick_read__.cc
-@@ -39,7 +39,15 @@
-
- #if defined (HAVE_MAGICK)
-
-+#define MAGICKCORE_EXCLUDE_DEPRECATED 1
- #include <Magick++.h>
-+#if !defined(QuantumRange) && defined(MaxRGB)
-+#define QuantumRange MaxRGB
-+#endif
-+#if !defined(MAGICKCORE_QUANTUM_DEPTH) && defined(QuantumDepth)
-+#define MAGICKCORE_QUANTUM_DEPTH QuantumDepth
-+#endif
-+
- #include <clocale>
-
- // In theory, it should be enough to check the class:
-@@ -121,6 +129,9 @@
- get_depth (Magick::Image& img)
- {
- octave_idx_type depth = img.depth ();
-+#if defined(MagickLibVersion) && (MagickLibVersion <= 0x686)
-+#define Magick MagickCore
-+#endif
- if (depth == 8
- && img.channelDepth (Magick::RedChannel) == 1
- && img.channelDepth (Magick::GreenChannel) == 1
-@@ -132,6 +143,9 @@
- && img.channelDepth (Magick::OpacityChannel) == 1
- && img.channelDepth (Magick::GrayChannel) == 1)
- depth = 1;
-+#if defined(MagickLibVersion) && (MagickLibVersion <= 0x686)
-+#undef Magick
-+#endif
-
- return depth;
- }
-@@ -355,7 +369,10 @@
- if (imvec[def_elem].depth () == 32)
- divisor = std::numeric_limits<uint32_t>::max ();
- else
-- divisor = MaxRGB / ((uint64_t (1) << imvec[def_elem].depth ()) - 1);
-+ {
-+ using namespace Magick;
-+ divisor = QuantumRange / ((uint64_t (1) << imvec[def_elem].depth ()) - 1);
-+ }
-
- // FIXME: this workaround should probably be fixed in GM by creating a
- // new ImageType BilevelMatteType
-@@ -489,7 +506,8 @@
- for (octave_idx_type row = 0; row < nRows; row++)
- {
- img_fvec[idx] = pix->red / divisor;
-- a_fvec[idx] = (MaxRGB - pix->opacity) / divisor;
-+ using namespace Magick;
-+ a_fvec[idx] = (QuantumRange - pix->opacity) / divisor;
- pix += row_shift;
- idx++;
- }
-@@ -568,7 +586,8 @@
- rbuf[idx] = pix->red / divisor;
- gbuf[idx] = pix->green / divisor;
- bbuf[idx] = pix->blue / divisor;
-- a_fvec[a_idx++] = (MaxRGB - pix->opacity) / divisor;
-+ using namespace Magick;
-+ a_fvec[a_idx++] = (QuantumRange - pix->opacity) / divisor;
- pix += row_shift;
- idx++;
- }
-@@ -655,7 +674,8 @@
- mbuf[idx] = pix->green / divisor;
- ybuf[idx] = pix->blue / divisor;
- kbuf[idx] = pix->opacity / divisor;
-- a_fvec[a_idx++] = (MaxRGB - *apix) / divisor;
-+ using namespace Magick;
-+ a_fvec[a_idx++] = (QuantumRange - *apix) / divisor;
- pix += row_shift;
- idx++;
- }
-@@ -732,10 +752,11 @@
- // depth is 8, there's a good chance that we will be limited. It
- // is also the GraphicsMagick recommended setting and the default
- // for ImageMagick.
-- if (QuantumDepth < 16)
-+ using namespace Magick;
-+ if (MAGICKCORE_QUANTUM_DEPTH < 16)
- warning_with_id ("Octave:GraphicsMagic-Quantum-Depth",
- "your version of %s limits images to %d bits per pixel\n",
-- MagickPackageName, QuantumDepth);
-+ MagickPackageName, MAGICKCORE_QUANTUM_DEPTH);
-
- initialized = true;
- }
-@@ -1094,8 +1115,9 @@
- // From GM documentation:
- // Color arguments are must be scaled to fit the Quantum size according to
- // the range of MaxRGB
-+ using namespace Magick;
- const double divisor = static_cast<double>((uint64_t (1) << bitdepth) - 1)
-- / MaxRGB;
-+ / QuantumRange;
-
- const P *img_fvec = img.fortran_vec ();
- const P *a_fvec = alpha.fortran_vec ();
-@@ -1147,8 +1169,9 @@
- for (octave_idx_type row = 0; row < nRows; row++)
- {
- double grey = octave::math::round (double (*img_fvec) / divisor);
-+ using namespace Magick;
- Magick::Color c (grey, grey, grey,
-- MaxRGB - octave::math::round (double (*a_fvec) / divisor));
-+ QuantumRange - octave::math::round (double (*a_fvec) / divisor));
- pix[GM_idx] = c;
- img_fvec++;
- a_fvec++;
-@@ -1216,10 +1239,11 @@
- {
- for (octave_idx_type row = 0; row < nRows; row++)
- {
-+ using namespace Magick;
- Magick::Color c (octave::math::round (double (*img_fvec) / divisor),
- octave::math::round (double (img_fvec[G_offset]) / divisor),
- octave::math::round (double (img_fvec[B_offset]) / divisor),
-- MaxRGB - octave::math::round (double (*a_fvec) / divisor));
-+ QuantumRange - octave::math::round (double (*a_fvec) / divisor));
- pix[GM_idx] = c;
- img_fvec++;
- a_fvec++;
-@@ -1297,7 +1321,8 @@
- octave::math::round (double (img_fvec[Y_offset]) / divisor),
- octave::math::round (double (img_fvec[K_offset]) / divisor));
- pix[GM_idx] = c;
-- ind[GM_idx] = MaxRGB - octave::math::round (double (*a_fvec) / divisor);
-+ using namespace Magick;
-+ ind[GM_idx] = QuantumRange - octave::math::round (double (*a_fvec) / divisor);
- img_fvec++;
- a_fvec++;
- GM_idx += nCols;
diff --git a/sci-mathematics/octave/files/octave-4.2.0-pkgbuilddir.patch b/sci-mathematics/octave/files/octave-4.2.0-pkgbuilddir.patch
deleted file mode 100644
index a72ac97c0a15..000000000000
--- a/sci-mathematics/octave/files/octave-4.2.0-pkgbuilddir.patch
+++ /dev/null
@@ -1,41 +0,0 @@
---- a/scripts/pkg/private/install.m
-+++ b/scripts/pkg/private/install.m
-@@ -62,7 +62,14 @@
- for i = 1:length (files)
- tgz = files{i};
-
-- if (exist (tgz, "file"))
-+ ## The filename pointed to an uncompressed package to begin with.
-+ if (exist (tgz, "dir"))
-+ if (tgz(1) == '/')
-+ packdir = tgz;
-+ else
-+ packdir = fullfile (pwd(), tgz);
-+ endif
-+ elseif (exist (tgz, "file"))
- ## Create a temporary directory.
- tmpdir = tempname ();
- tmpdirs{end+1} = tmpdir;
-@@ -89,20 +96,12 @@
- if (length (dirlist) > 3)
- error ("bundles of packages are not allowed");
- endif
-- endif
-
-- ## The filename pointed to an uncompressed package to begin with.
-- if (exist (tgz, "dir"))
-- dirlist = {".", "..", tgz};
-+ ## The two first entries of dirlist are "." and "..".
-+ packdir = fullfile (tmpdir, dirlist{3});
- endif
-
- if (exist (tgz, "file") || exist (tgz, "dir"))
-- ## The two first entries of dirlist are "." and "..".
-- if (exist (tgz, "file"))
-- packdir = fullfile (tmpdir, dirlist{3});
-- else
-- packdir = fullfile (pwd (), dirlist{3});
-- endif
- packdirs{end+1} = packdir;
-
- ## Make sure the package contains necessary files.
diff --git a/sci-mathematics/octave/files/octave-4.2.0-texi.patch b/sci-mathematics/octave/files/octave-4.2.0-texi.patch
deleted file mode 100644
index 1352ff5a1f75..000000000000
--- a/sci-mathematics/octave/files/octave-4.2.0-texi.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/doc/interpreter/module.mk
-+++ b/doc/interpreter/module.mk
-@@ -298,6 +298,8 @@
- $(AWK) -f $(srcdir)/doc/interpreter/mkcontrib.awk $(srcdir)/doc/interpreter/contributors.in > $@-t && \
- mv $@-t $@
-
-+doc/interpreter/preface.texi: doc/interpreter/contributors.texi
-+
- AUTHORS: doc/interpreter/preface.texi doc/interpreter/contributors.texi | doc/interpreter/$(octave_dirstamp)
- $(AM_V_MAKEINFO)rm -f $@-t $@ && \
- if [ "x$(srcdir)" != "x." ] && [ -f $(srcdir)/doc/interpreter/contributors.texi ] && [ ! -f doc/interpreter/contributors.texi ]; then \
diff --git a/sci-mathematics/octave/files/octave-4.2.0-zlib-underlinking.patch b/sci-mathematics/octave/files/octave-4.2.0-zlib-underlinking.patch
deleted file mode 100644
index 0c8736069d8e..000000000000
--- a/sci-mathematics/octave/files/octave-4.2.0-zlib-underlinking.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/libinterp/corefcn/module.mk
-+++ b/libinterp/corefcn/module.mk
-@@ -318,6 +318,7 @@
- $(HDF5_CPPFLAGS) \
- $(LLVM_CPPFLAGS) \
- $(Z_CPPFLAGS)
-+libinterp_corefcn_libcorefcn_la_LIBADD = $(Z_LIBS)
-
- libinterp_corefcn_libcorefcn_la_CFLAGS = $(AM_CFLAGS) $(WARN_CFLAGS)
-
diff --git a/sci-mathematics/octave/files/octave-4.2.2-fix-qscintilla-detection.patch b/sci-mathematics/octave/files/octave-4.2.2-fix-qscintilla-detection.patch
deleted file mode 100644
index 80fc28013239..000000000000
--- a/sci-mathematics/octave/files/octave-4.2.2-fix-qscintilla-detection.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-In Gentoo, QScintilla for Qt5 has the same library name
-as its Qt4 variant.
-
---- a/m4/acinclude.m4
-+++ b/m4/acinclude.m4
-@@ -1460,7 +1460,7 @@
- ;;
- 5)
- QT_MODULES="Qt5Core Qt5Gui Qt5Network Qt5OpenGL Qt5PrintSupport"
-- octave_qscintilla_libnames="qscintilla2-qt5 qscintilla2_qt5 qt5scintilla2"
-+ octave_qscintilla_libnames="qscintilla2_qt5 qscintilla2"
- ;;
- *)
- AC_MSG_ERROR([Unrecognized Qt version $qt_version])
diff --git a/sci-mathematics/octave/files/octave-4.2.2-imagemagick-configure.patch b/sci-mathematics/octave/files/octave-4.2.2-imagemagick-configure.patch
deleted file mode 100644
index d80c23ec4224..000000000000
--- a/sci-mathematics/octave/files/octave-4.2.2-imagemagick-configure.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -1560,11 +1560,11 @@ if test $check_magick = yes; then
- MAGICK_LIBS=
-
- PKG_CHECK_EXISTS([$magick++], [
-- ## Make sure we only get -I, -L, and -l flags. Some Graphics/ImageMagick++
-+ ## Make sure we only get -I, -D, -L, and -l flags. Some Graphics/ImageMagick++
- ## packages add extra flags that are useful when building
- ## Graphics/ImageMagick++ extentions. These extra flags break the
- ## Octave build.
-- MAGICK_CPPFLAGS="$($PKG_CONFIG --cflags-only-I $magick++ | $SED -e 's/^ *$//')"
-+ MAGICK_CPPFLAGS="$($PKG_CONFIG --cflags-only-I $magick++ | $SED -e 's/^ *$//' | $SED -e 's/\(-@<:@DI@:>@@<:@^ \t@:>@*\)\|\(-@<:@^ \t@:>@*\)/\1/g')"
- MAGICK_LDFLAGS="$($PKG_CONFIG --libs-only-L $magick++ | $SED -e 's/^ *$//')"
- MAGICK_LIBS="$($PKG_CONFIG --libs-only-l $magick++ | $SED -e 's/^ *$//')"
-
diff --git a/sci-mathematics/octave/files/octave-4.4.0-imagemagick-configure.patch b/sci-mathematics/octave/files/octave-4.4.0-imagemagick-configure.patch
deleted file mode 100644
index ce81b801d99c..000000000000
--- a/sci-mathematics/octave/files/octave-4.4.0-imagemagick-configure.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/configure.ac 2018-04-30 19:03:56.000000000 +0200
-+++ a/configure.ac.new 2018-05-22 12:23:30.371174341 +0200
-@@ -1946,11 +1946,11 @@
- MAGICK_LIBS=
-
- PKG_CHECK_EXISTS([$magick++], [
-- dnl Make sure we only get -I, -L, and -l flags.
-+ dnl Make sure we only get -I, -D, -L, and -l flags.
- dnl Some Graphics/ImageMagick++ dnl packages add extra flags that are
- dnl useful when building Graphics/ImageMagick++ extentions. These extra
- dnl flags break the Octave build.
-- MAGICK_CPPFLAGS="$($PKG_CONFIG --cflags-only-I $magick++ | $SED -e 's/^ *$//')"
-+ MAGICK_CPPFLAGS=`$PKG_CONFIG --cflags $magick++ | sed -e 's/\(-@<:@DI@:>@@<:@^ \t@:>@*\)\|\(-@<:@^ \t@:>@*\)/\1/g'`
- MAGICK_LDFLAGS="$($PKG_CONFIG --libs-only-L $magick++ | $SED -e 's/^ *$//')"
- MAGICK_LIBS="$($PKG_CONFIG --libs-only-l $magick++ | $SED -e 's/^ *$//')"
-
diff --git a/sci-mathematics/octave/files/octave-4.4.0-imagemagick.patch b/sci-mathematics/octave/files/octave-4.4.0-imagemagick.patch
deleted file mode 100644
index 2aa6e5b9d8c6..000000000000
--- a/sci-mathematics/octave/files/octave-4.4.0-imagemagick.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/libinterp/corefcn/__magick_read__.cc 2018-05-22 12:25:37.688173855 +0200
-+++ a/libinterp/corefcn/__magick_read__.cc.new 2018-05-22 12:32:51.475172200 +0200
-@@ -817,10 +817,19 @@
- // depth is 8, there's a good chance that we will be limited. It
- // is also the GraphicsMagick recommended setting and the default
- // for ImageMagick.
-+#ifdef QuantumDepth
- if (QuantumDepth < 16)
-+#else
-+ using namespace Magick;
-+ if (MAGICKCORE_QUANTUM_DEPTH < 16)
-+#endif
- warning_with_id ("Octave:GraphicsMagick-Quantum-Depth",
- "your version of %s limits images to %d bits per pixel\n",
-+#ifdef QuantumDepth
- MagickPackageName, QuantumDepth);
-+#else
-+ MagickPackageName, MAGICKCORE_QUANTUM_DEPTH);
-+#endif
-
- initialized = true;
- }
diff --git a/sci-mathematics/octave/files/octave-4.4.0-qt-5.11.patch b/sci-mathematics/octave/files/octave-4.4.0-qt-5.11.patch
deleted file mode 100644
index 70ffbb471992..000000000000
--- a/sci-mathematics/octave/files/octave-4.4.0-qt-5.11.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- octave-4.4.0-orig/libgui/src/settings-dialog.cc 2018-05-01 03:03:56.000000000 +1000
-+++ octave-4.4.0/libgui/src/settings-dialog.cc 2018-07-03 19:35:41.865149269 +1000
-@@ -41,6 +41,7 @@
- #include <QHash>
- #include <QMessageBox>
- #include <QTextCodec>
-+#include <QButtonGroup>
-
- #if defined (HAVE_QSCINTILLA)
- # include "octave-qscintilla.h"