summaryrefslogtreecommitdiff
path: root/sci-mathematics/nauty
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-17 17:57:35 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-17 17:57:35 +0100
commit7932d472a02d4c016ff7dff4b7a5479ab9d1883d (patch)
treed07709230f82777cae6ba7dab35aee31896060fb /sci-mathematics/nauty
parentd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (diff)
gentoo resync : 17.06.2021
Diffstat (limited to 'sci-mathematics/nauty')
-rw-r--r--sci-mathematics/nauty/Manifest1
-rw-r--r--sci-mathematics/nauty/nauty-2.6.7-r1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/sci-mathematics/nauty/Manifest b/sci-mathematics/nauty/Manifest
index 4fb5b5add61b..dbb4beab0ae2 100644
--- a/sci-mathematics/nauty/Manifest
+++ b/sci-mathematics/nauty/Manifest
@@ -1,5 +1,6 @@
DIST nauty-popcnt.patch 56034 BLAKE2B 838858a0decf9323217f6b8d7b200b0158db9a02efd278a5d3cf7392ac2201e901b36b963f3f30ca6070fd0ddfa70577a442b795b09fec0d457d33649c6e93c6 SHA512 4931440b6178cb668997539ac2991f0d04758b8750668d4477cb8a456640640c5bb71c2858e423a4ad812e3401151834366e04693bf9a5ecc5ccc211d2e4229c
DIST nauty26r7.tar.gz 1660659 BLAKE2B d1d6774dd65cbdb906727324b5008bb962d54d16f99afe68f643f62ab2e7fe297a7cb4ef59b5f50c72c7e59fa9ff8ef2c82f4a77764c7f076b90e8171c7f1370 SHA512 60a724264b43b48338c17240c3cf7156f408267f1b2df995ea7b5ab9fa48852cb11057e83178a364ca028d80dc9124ca9b38cdac34e150a995475140d07c8af6
DIST nauty_2.6r7+ds-1.debian.tar.xz 30328 BLAKE2B 009d64aa2042f814e55238ff83bde4d205925922c13a46213b933ec0f6364ed9a86aeabc7b4c22fdb717bd3ee7efdf794f3f2637cd08d7921e61cee99e73cf9a SHA512 fadde6a767e43048980842415207613ffeaa38d021fbf6a3f26a4bbe6877a92ddf5950094de517edd0f924deeacc8dec1d6a7334123c2a87d15befcc3876bc63
+EBUILD nauty-2.6.7-r1.ebuild 1526 BLAKE2B c3ffeaa04617b7d18d2c18c5264930b6cd3b67db184770cbc34dfaa1b63e8c3496bc2d45f3922965e041a3929e53443da15c84762ac8b4132c8f320d5971a7da SHA512 191f12019f2d3016b6154d9f41a652bdebcbc0ab1cfdc57bc17a77bba4876434dc1b0950777cf4ec556997c82b3897964cb9ff635b8b5b485350a86791e56be0
EBUILD nauty-2.6.7.ebuild 1469 BLAKE2B 31dbd03617b358b4881f866c7b0c0863aa808c58433120c215886f23439896fff8f05e4df3e635473a4400a54fea53084cc81a949bc9eb732397d73775e1c831 SHA512 b9d7e3d17636c716e53658b590d37aaf4ed09219fed46b975cbd9ee1d36c17c1c57c3ce430b13f6125baf094e8f748072313c53e63c1e9249f081afe3f535f9b
MISC metadata.xml 545 BLAKE2B dc773d4acdd458e7dbe5bc8744c847d9ae04eaedff901e4daa1f78cefcd261f158f54d916dcf054f7ba348b3c9d555d6542a421c3cc1ed1feda1276bd798064d SHA512 19b48e8150e6776f4c51f80cc0b4d468cbb320a9468dfe298debe21177e13a2c9a41d7ef2a24b54c5e7986231402f72d7db19c6c8b075ae9a3f103c040dd9262
diff --git a/sci-mathematics/nauty/nauty-2.6.7-r1.ebuild b/sci-mathematics/nauty/nauty-2.6.7-r1.ebuild
new file mode 100644
index 000000000000..3bbf8f7251b1
--- /dev/null
+++ b/sci-mathematics/nauty/nauty-2.6.7-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_PV1=$(ver_rs 2 'r')
+MY_PV=$(ver_rs 1 '' $(ver_rs 2 'r'))
+
+DESCRIPTION="Computing automorphism groups of graphs and digraphs"
+HOMEPAGE="https://pallini.di.uniroma1.it/"
+DEBIAN_PATCH_VERSION="1"
+SRC_URI="http://cs.anu.edu.au/~bdm/${PN}/${PN}${MY_PV}.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${MY_PV1}+ds-${DEBIAN_PATCH_VERSION}.debian.tar.xz
+ http://pkgs.fedoraproject.org/cgit/rpms/nauty.git/plain/nauty-popcnt.patch"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-libs/gmp:0
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}${MY_PV}"
+DOCS=( schreier.txt config.txt formats.txt changes24-26.txt )
+PATCHES=(
+ "${WORKDIR}"/debian/patches/upstream-lintian-spelling-error.patch
+ "${WORKDIR}"/debian/patches/upstream-fix-gt_numorbits.patch
+ "${WORKDIR}"/debian/patches/upstream-fix-include-extern.patch
+ "${WORKDIR}"/debian/patches/upstream-zlib-blisstog_c.patch
+ "${WORKDIR}"/debian/patches/upstream-C2help2man.patch
+ "${WORKDIR}"/debian/patches/upstream-autotoolization.patch
+ "${WORKDIR}"/debian/patches/system-preprocessing-examples.patch
+ "${DISTDIR}"/nauty-popcnt.patch
+)
+
+src_prepare() {
+ default
+ rm makefile || die
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static --enable-runtime-popcnt --enable-tls
+}
+
+src_install() {
+ default
+
+ # remove .la file
+ find "${ED}" -name '*.la' -delete || die
+}