summaryrefslogtreecommitdiff
path: root/sci-mathematics/msieve/msieve-1.53-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /sci-mathematics/msieve/msieve-1.53-r1.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'sci-mathematics/msieve/msieve-1.53-r1.ebuild')
-rw-r--r--sci-mathematics/msieve/msieve-1.53-r1.ebuild30
1 files changed, 14 insertions, 16 deletions
diff --git a/sci-mathematics/msieve/msieve-1.53-r1.ebuild b/sci-mathematics/msieve/msieve-1.53-r1.ebuild
index 4cf9b2d6dce3..1f8a4593e738 100644
--- a/sci-mathematics/msieve/msieve-1.53-r1.ebuild
+++ b/sci-mathematics/msieve/msieve-1.53-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
@@ -24,26 +24,24 @@ PATCHES=(
# TODO: Integrate ggnfs properly
"${FILESDIR}"/${PN}-1.51-reduce-printf.patch
"${FILESDIR}"/${PN}-1.53-fix-version.patch
+ "${FILESDIR}"/${PN}-1.53-makefile.patch
)
-src_prepare() {
- default
+src_configure() {
+ tc-export AR CC RANLIB
- sed -i -e 's/-march=k8//' Makefile || die
- sed -i -e 's/CC =/#CC =/' Makefile || die
- sed -i -e 's/CFLAGS =/CFLAGS +=/' Makefile || die
- sed -i -e 's/LIBS += -lecm/LIBS += -lecm -lgomp/' Makefile || die
+ use ecm && export ECM=1
+
+ if use mpi; then
+ export MPI=1
+ export CC=mpicc
+ fi
+
+ use zlib && export ZLIB=1
}
src_compile() {
- use ecm && export ECM=1
- use mpi && export MPI=1
- use zlib && export ZLIB=1
- emake \
- CC=$(tc-getCC) \
- AR=$(tc-getAR) \
- OPT_FLAGS="${CFLAGS}" \
- all
+ emake all
}
src_install() {