summaryrefslogtreecommitdiff
path: root/sci-mathematics/metamath/metamath-0.198.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /sci-mathematics/metamath/metamath-0.198.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'sci-mathematics/metamath/metamath-0.198.ebuild')
-rw-r--r--sci-mathematics/metamath/metamath-0.198.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-mathematics/metamath/metamath-0.198.ebuild b/sci-mathematics/metamath/metamath-0.198.ebuild
new file mode 100644
index 000000000000..1f48ed968847
--- /dev/null
+++ b/sci-mathematics/metamath/metamath-0.198.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Proof verifier based on a minimalistic formalism"
+HOMEPAGE="http://us.metamath.org/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}-exe.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}-exe/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-exe-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}/${PN}-configure.ac-dont_force_optimize.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}