summaryrefslogtreecommitdiff
path: root/sci-mathematics/metamath-databases/metamath-databases-20220303.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /sci-mathematics/metamath-databases/metamath-databases-20220303.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'sci-mathematics/metamath-databases/metamath-databases-20220303.ebuild')
-rw-r--r--sci-mathematics/metamath-databases/metamath-databases-20220303.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-mathematics/metamath-databases/metamath-databases-20220303.ebuild b/sci-mathematics/metamath-databases/metamath-databases-20220303.ebuild
new file mode 100644
index 000000000000..32304b03acd4
--- /dev/null
+++ b/sci-mathematics/metamath-databases/metamath-databases-20220303.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=99d707bc3c600a9d6052a46a7c85f05b74c589a2
+
+DESCRIPTION="Sample databases for Metamath"
+HOMEPAGE="http://us.metamath.org/mpeuni/mmset.html"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/metamath/set.mm.git"
+else
+ SRC_URI="https://github.com/metamath/set.mm/archive/${H}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}"/set.mm-${H}
+fi
+
+LICENSE="CC0-1.0"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="sci-mathematics/metamath"
+
+DOCS=(
+ CONTRIBUTING.md README.md
+ discouraged iset-discouraged
+ mmnotes.txt
+ other-databases.md verifiers.md
+)
+
+src_install() {
+ insinto /usr/share/metamath
+ doins *.mm *.mmts
+
+ einstalldocs
+
+ if use doc ; then
+ docinto html
+ dodoc -r people
+ dodoc *.html *.svg
+ fi
+}